Skip navigation

How do I turn off startup sound?

80497 Views 35 Replies Latest reply: Apr 3, 2014 8:38 AM by Wizard_Magic_Spell RSS
  • wariovonflutenhausen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2013 6:37 AM (in response to imicanada)

    I just hit the mute button before I reset and get no chime on start up. Hope that works for you!

  • Hippomormor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2013 7:55 AM (in response to imicanada)

    Why use third party stuff for something you can do yourself in terminal?

     

    1. Login as administrator and open a terminal window

     

    2. Create scriptfile for muting
    sudo nano /path/to/mute-on.sh

    3. Enter this as content, when done press control+O to save and control+X to exit:
    #!/bin/bash
    osascript -e ‘set volume with output muted’

    4. Create scriptfile for unmuting
    sudo nano /path/to/mute-off.sh

    5. Enter this as content, when done press control+O to save and control+X to exit:
    #!/bin/bash
    osascript -e ‘set volume without output muted’

    6. Make both files executable:
    sudo chmod u+x /path/to/mute-on.sh
    sudo chmod u+x /path/to/mute-off.sh

    7. Check if any hooks already exist (these will be overwritten, so make sure it is OK for you)
    sudo defaults read com.apple.loginwindow LoginHook
    sudo defaults read com.apple.loginwindow LogoutHook

    8. Add hooks for muting
    sudo defaults write com.apple.loginwindow LogoutHook /path/to/mute-on.sh
    sudo defaults write com.apple.loginwindow LoginHook /path/to/mute-off.sh

    Notes:
    - /path/to/ is the location of the scripts, I used /Library/Scripts/
    - you can skip the unmuting loginhook (i.e. each logout will silence your machine), but I like it this way because I always have sound available exactly at the volume level I set last time
    - root has to be the owner of the script files – running an editor from command line with sudo is the easiest way to achieve that (otherwise you need to chown)
    - to delete the hooks, use the following:
    sudo defaults delete com.apple.loginwindow LoginHook
    sudo defaults delete com.apple.loginwindow LogoutHook

     

     

    OR

     

    hold down the mute key when turning it on

  • MAC-ATOM Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2013 3:23 PM (in response to imicanada)

    Just purchased a new 27inch iMac....was greeted to a deafening chime on start up!  I can't believe Apple doesn't have a setting to reduce or mute the volume???  My previous iMac was a lot quieter, so wasn't too much of an issue.  I tried the 3rd party "Ninja" program with no luck.  Holding down the mute button was ineffective as well.

     

    APPLE please fix!  I don't want to wake up my partner every time I restart or boot up

  • Hippomormor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2013 1:49 AM (in response to MAC-ATOM)

    Hmm the hooks doesn't work in Mavericks ...

  • Hippomormor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2013 2:31 AM (in response to Hippomormor)

    Ok i got it working in Mavericks!

     

    DO THIS:

     

    - Go to terminal.

     

    - Write sudo nano /Library/Scripts/mute-off.sh

     

    - Paste:

     

    #!/bin/bash

    osascript -e 'set volume without output muted'

     

    - Press 'Ctrl + X' and press 'Y' and 'Enter'

     

    - Write sudo nano /Library/Scripts/mute-on.sh

     

    - Paste:

     

    #!/bin/bash

    osascript -e 'set volume with output muted'

     

    - Press 'Ctrl + X' and press 'Y' and 'Enter'

     

    - Paste this in terminal and press enter :

     

    sudo chmod u+x /Library/Scripts/mute-on.sh

    sudo chmod u+x /Library/Scripts/mute-off.sh

    sudo defaults write com.apple.loginwindow LogoutHook /Library/Scripts/mute-on.sh

    sudo defaults write com.apple.loginwindow LoginHook /Library/Scripts/mute-off.sh

     

    - If you want to remove it again write this in terminal:

     

    sudo defaults delete com.apple.loginwindow LoginHook

    sudo defaults delete com.apple.loginwindow LogoutHook

     

    It is really not that hard

     

    All we did was make a command (script) that's executed (hooked) upon logout and login. So when you logout it mutes, and when you login it unmutes

     

     


  • Hippomormor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2013 4:39 AM (in response to imicanada)

    OR

     

    I made a simple install script.

     

    Download it here:

     

    https://www.dropbox.com/s/ll3t1j27eav7rrh/Muter.zip

     

    place 'mute-on.sh' & 'mute-off.sh' on your desktop and double-click on 'mute.command'

     

    Type your password and press 'enter'

     

    You can now remove the files again.

     

    Enjoy a soundless startup

  • MilosMar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2013 3:16 AM (in response to Hippomormor)

    I tried it twice - no working for me :-(

  • MilosMar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2013 3:23 AM (in response to Hippomormor)

    How to remove ?

     

    #!/bin/bash

    osascript -e 'set volume with output muted'

    #!/bin/bash

    osascript -e 'set volume without output muted'

     

     

    I dont want workless mess in my system. Thanks for understanding

  • Ralphemc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2014 9:04 AM (in response to imicanada)

    Yes, this is a ridiculous feature that Apple has forced owners to deal with for many, many years, without resolution. I had installed a third party software program when I first got my iMac in '09 and had Snow Leopard installed. I have no idea what the program was, or where it resides in my computer, but it worked fine, even when I upgraded to Mavericks last month. Until yesterday. All of a sudden The Chimes are back, loud and awful! I didn't do anything to my computer, didn't add any software but there they are. Checking on the web reveals there are no positive solutions for Mavericks users unless you want to install a change to the Terminal, which involves high techy stuff which I wouldn't trust myself to interpret and utilize without permanently damaging my OS, so I'm not going to try. Why Apple won't at least open the architecture so that 3rd parties can develop and app to fix this is beyond me. Please Apple, do the right thing. Thanx.

  • kuhak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 27, 2014 3:47 PM (in response to Ralphemc)

    I'm sorry but Hippomormor's suggestion did not work for me... this, however, did.

     

     

    1. Launch Terminal (from Applications > Utilities > Terminal);


    2. Wait for the Terminal UI to display your computer’s name (root directory) and punch in:


     

    CODE

     

    sudo nvram SystemAudioVolume=%80



    3. Hit Return/Enter;


    4. Now you’ll be prompted to type in your administrator password. Do that, hit OK, and you’re done.


    When you restart your Mac, the OS X boot chime should no longer play. If you somehow decide you want the boot sound back, simply fire up Terminal again and, instead of the aforementioned command, use sudo nvram -d SystemAudioVolume.

     

     

    Source: http://news.softpedia.com/news/How-to-Disable-the-OS-X-Startup-Sound-on-Mountain -Lion-365852.shtml

     

    And yes, I'm on Mavericks. Hope this helps, cheers.

  • codywohlers Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2014 1:22 PM (in response to kuhak)

    Thank-you!  "sudo nvram SystemAudioVolume=%80" is the only method I could get to work to stop the startup sound on my MacBookPro 10,1 running OS X 10.9.1.

  • drjamez Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 7, 2014 4:27 AM (in response to MAC-ATOM)

    The only thing that is currently working for me (on my iMac) is "Auto Mute"

    http://auto-mute.com/

  • .antti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2014 7:55 PM (in response to wariovonflutenhausen)

    If one is looking for a temporary solution, this is exactly how it works in Mavericks. The Mac remembers the volume set for the system before reboot, so if one mutes the system first and then reboots, the start-up sound will be muted. Holding down the mute button while rebooting won't help at all. It all depends whether the system was already muted before reboot.

     

    It's necessary, however, to unplug headphones, etc., since adjusting the volume while one has the headphones plugged in only changes the volume that goes into the headphones. And as we know, the start-up sound overrides the volume settings for the headphones, etc.

     

    So:

     

    1. Unplug the cord that leads up either to your headphones or stereo, etc.
    2. Mute the system.
    3. Reboot – without sound.

     

    I think the system should remember its volume settings even if one plugged the cord back after step 2, but I haven't tried this, and won't, since all the house is sleeping at the moment.

  • Michael Hall5 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2014 2:00 AM (in response to imicanada)

    I use external speakers (hi-fi connected for Garage Band and iTunes), so this solution works for me:

     

    1. Unplug Audio-out cable from back of Mac
    2. Go into volume settings and click mute (or just hit F10)
    3. Plug audio-out cable back in
    4. Adjust volume for everyday use (volume settings, or F11/F12)

     

    Now, when you turn on the Mac, as long as my external speakers are turned off, I get no sound when I boot up.

    Once booted, I turn on my speakers/hi-fi and I'm sorted.

  • lollypop852 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2014 3:26 AM (in response to imicanada)

    what i did last time i used it before i turned it off turn the volume to mute and when i turned it back on agian it didnt make a sound .... it worked for me

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.