Skip navigation

HT5771: Apple Configurator 1.4: Updating from an earlier version

Learn about Apple Configurator 1.4: Updating from an earlier version

HT5771 apple configurator upgrade error

2654 Views 9 Replies Latest reply: Sep 19, 2013 12:41 PM by west97 RSS
g2328 Calculating status...
Currently Being Moderated
Jul 10, 2013 8:15 AM



I have just upgraded apple configurator to the latest version and i am now getting an error saying


unable to upgrade your library to the latest version please revert to a previous library and try again


The article says to browse to this folder


~/Library/Containers/ .apple.configurator/Previous Data/


Yet i have no support folder under ~/Library/Containers/


Any advice would be much appreciated



iPad 2, iOS 6.1.4
  • Pat Cahill Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 10, 2013 8:03 PM (in response to g2328)

    I think the article means...

    ~/Library/Containers/ Support/com .apple.configurator/


    Under there the file AppleConfigurator.storedata was failing to migrate properly and every time it tried it made a folder "Previous Data{Random Num}


    My issue turned out to be file/folder permissions.

    When migrating, it could not access AppleConfigurator.storedata or the temp area it was working in correctly.


    *WARNING: I know next to nothing about default folder permissions in OSX, doing the following may fix your problem while creating another elsewhere.


    I went back up to /Users folder and got the Info for the UserHome folder my Configurator was under (/Users/VPP).

    Under "Sharing and Permissions" I made sure that the user (VPP) was the owner (under the cog) and had Read & Write Access.

    Then I went to "Apply to Enclosed Folders" (again under the cog)

    OSX asks you for an administrator password to make the permission changes.


    The next time I opened Configurator it migrated correctly.

  • ictjs Calculating status...
    Currently Being Moderated
    Jul 13, 2013 4:11 PM (in response to Pat Cahill)


    I wondered if you or anyone could help with the following error message that appears when backuping up using the new configurator!!

    The zip archive is corrupt

    CRC mismatch; expected e5c82713 but got 0


    I am stuck and can't find a way to revert to a previous version. Any help much appreciated!!

  • west97 Calculating status...
    Currently Being Moderated
    Aug 21, 2013 10:18 AM (in response to g2328)

    i realize this message was posted in july...and has since, perhaps, been resolved; HOWEVER, i had the same issue after configurator crashed on me this past monday.  i did NOT have a back up (of course) of my data (which included VPP codes)...and so was pretty invested in figuring out how to get it working again.  i managed to locate the folder with the "previous library" (it was actually in ~/Library/Containers/ .apple.configurator/PreviousData), but could not figure out how to get the app to open using the previous library.   i called apple's technical support to see if they could help me with this part.  i explained my situation...and was told there was nothing i could do to fix it without having a backup--i would basically have to start over and lose all the data/VPP codes.  at this point, i decided that if i had to start all over again, it couldn't hurt to play around with it myself--i couldn't possible make it WORSE.  and, amazingly enough, what i did appears to have worked.

    so here's what i did:

    1. i went to the folder with the current library file (~/Library/Containers/ and dragged the file named "AppleConfigurator.storedata" to the trash.

    2. then i tried taking the similarly named file (AppleConfigurator.storedata) from the previous data folder (~/Library/Containers/ and dragging it to the current folder.  THAT didn't i put it back and tried dragging the file named Users.storedata from the previous folder to the current one.  tried opening the app luck.

    3. finally, i put all the "previous" data files back in the folders where they had been, and dragged the original AppleConfigurator.storedata file out of the trash and into the current folder.  when i tried opening the app again, it opened with all my data.  whoo-hoo!

    i don't know if anyone else will find this at all helpful, but i thought i would post it because i was near tears at the realization that i had lost everything i had done with the 25 ipads i have...and about $2000 worth of VPP codes.

  • west97 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 21, 2013 4:53 PM (in response to g2328)

    oh, and i forgot to mention, that i had been looking at the wrong "library" folder.  i found (from some other search online) the trick to finding the *right* one.

    open up the finder...hold down the option key while clicking on the "go" from the finder menu--the library appears in the list.  THAT is the library where the folder is.

  • rosjcohen Calculating status...
    Currently Being Moderated
    Sep 11, 2013 9:16 AM (in response to g2328)

    I was able to solve this problem simply by removing the file

    ~/Library/Containers/ from the Library and all worked okay.



  • Dreyfuzz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 18, 2013 2:30 PM (in response to rosjcohen)

    I didn't have a file ".../AppleConfigurator.storedata-journal." I had a AppleConfigurator.storedata file but removing that removes all the data in Configurator; apps, codes, devices, everything. It doesn't even know that the device I'm trying to back up is supervised anymore.


    Other solutions?

  • west97 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 6:03 AM (in response to Dreyfuzz)

    i didn't have a "journal" file either.  what i did (outlined above) only removed the storedata file temporarily.  I replaced it with the "old" storedata file, tried to open the app...and it did a "migrating" thing...then I put everything back into its original spot (pulling the storedata file out of the trash and back to its original spot).  I didn't lose anything.

  • Dreyfuzz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 8:37 AM (in response to west97)

    Moving this file away, letting it get rebuilt, and putting it back actually caused me a lot of problems. Now all my apps come up as "App Missing" and need to be reimported. I can only do a few at a time before I get an "Unable to communicate with iTunes store" error. This might just be because yesterday was iOS 7 release day and iTunes store servers are overloaded. 

  • west97 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 12:41 PM (in response to Dreyfuzz)

    i don't i said, i was at a loss and was basically told that all my app codes, etc were gone, and i was out of luck since i didn't have it backed i just started mucking around with it and that is what worked for me.  i'm sorry it is not working. 


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.