Skip navigation

Application stuck "installing..."

131922 Views 52 Replies Latest reply: Mar 26, 2014 6:37 PM by YousefSter RSS
  • RichardMcCarty Calculating status...
    Currently Being Moderated
    Aug 31, 2013 11:44 AM (in response to rosagparedes)

    I found a different solution for my stuck-installing app problem. After trying numerous suggestions here, I noticed that I had no more space for icons available on my desktop. Moved several into a folder, suddenly the icon for the stuck-app showed up, and I was able to get it installing by tapping on it.

  • tdenmark Calculating status...
    Currently Being Moderated
    Sep 1, 2013 3:36 PM (in response to rosagparedes)

    On my iPhone I deleted the app that was stuck installing, then went to the app store did a search for the app, found it, reinstalled.


    That worked.

  • igeekart Calculating status...
    Currently Being Moderated
    Sep 2, 2013 10:51 AM (in response to rosagparedes)

    Read through some of these with no success and finally just deleted the apps again and reloaded them and they automatically show up if you have an icloud account, otherwise, just downloading the entire app again will fix it. And took hardly any time at all. Thanks Apple!

  • dcnicholls Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 19, 2013 7:06 PM (in response to Liquidsmoke)

    Thanks, Liquidsmoke, that fixed my problem. iTunes thought the app was installed, but no icon and no way to remove it to reninstall.  Settings > General > Show all apps allowed me to remove the app from the iPad and the reinstall was simply a matter of reinstalling from iTunes.

  • Jamesnotjim Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 26, 2013 11:39 PM (in response to Dan Rosellini)

    Thanks. This worked for me as well. I tried tapping each app (of the three I had stuck this time). Two changed their labels to from "Installing" to "Waiting," but a third changed it's label first to "Waiting" and then, after another press, to "Loading." Nothing seemed to happen, but I could see via the toolbar icon that my iPad was receiving data. So i just left it alone for a few minutes and that third app finally got a progress bar and finished installing. Then one of the others resumed. I'm still working with it, but I assume the remaining app will follow suit.

  • kenmorefield Calculating status...
    Currently Being Moderated
    Oct 1, 2013 7:13 PM (in response to rosagparedes)

    After having much trouble deleting Mahjong Vacations and having it reinstall, I found this:


    Based on their suggestion, I opened Itunes and "signed out" of the store. (Menu in upper left corner.) I then went to the store while signed out (on my Itunes, not on my phone) and found the app (Mahjong Variations). I clicked on "downlaod for free." I was prompted to log into the store, and when I did, the app downloaded completely rather than getting stuck in "install" mode.


    Not sure why this happened, but that fixed it for me. I was then able to delete the app.

  • PaddyFH Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 4:11 AM (in response to Jas42)

    I had recently started having trouble with apps stuck on installing on my iPad 2. Jas42 solved my problem.


    The steps I took in detail:


    - connect iPad to iTunes via USB

    - Click on the iPad on the left sidebar to bring up the iPad contents on the iTunes window.

    - Click on apps tab

    - On the list of apps installed on the iPad there is a button with either Remove, Install or update to the right of each of the apps on the list.

    - For all the apps which have stuck on updating/installing, they are the ones which show up as "update"

    - When you click on "update" the button will change to "will install". Do that for all your apps stuck on installing

    - Now sync your iPad.


    The apps will load and update on the iPad. And all is good again with the world...!

  • YousefSter Calculating status...
    Currently Being Moderated
    Mar 26, 2014 6:37 PM (in response to rosagparedes)

    What i did was i rebooted the idevice and the app should say Waiting when it is just hold the home screen (ios 1-6) or hold the app (Ios 7) and delete it,It might take a few trys but it WILL work

1 2 3 4 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.