Skip navigation

Email problem after iOS 7 update

91801 Views 69 Replies Latest reply: Mar 31, 2014 2:39 PM by anonymous4a RSS
1 2 3 ... 5 Previous Next
aboothe22 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 18, 2013 3:50 PM

After upgrading to iOS 7, all of the emails in my account are showing as unread on my notifications but they aren't there to actually read/mark read.  So I have a notification that says I have literally over 40,000 unread emails.  I am extremelly anal about notifications on my phone, and it's already driving me nuts that I can't clear them...Can anyone please HELP?

iPhone 5, iOS 7
  • Psmith0103 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 12:18 AM (in response to aboothe22)

    Hi I had the same problem, if you go to edit then mark all and mark as unread then do the same thing but mark all as read it clears them!!!

     

    Thanks

     

    Paula

  • Garywoo Level 1 Level 1 (65 points)
    Currently Being Moderated
    Sep 19, 2013 2:01 AM (in response to aboothe22)

    If this email account is Hotmail:

    Hotmail has used POP for emails in the past and this does not sync if messages are read or not. This is an old standard and shouldn't be used any more.

     

    You can now use Exchange or IMAP for hotmail and this should mark them as read and stop this from happening again. Add a new mail account on your iPhone, and select Exchange instead of Hotmail/Outlook.com and sign in with your hotmail details. You may need to change the Mail Days to Sync options after you set it up to get all your emails back. Your hotmail account may also have put all your emails into a POP folder. Sign in to hotmail on a computer and move all the emails in that folder back into your inbox.

     

     

    If exchange does not work, you can try using IMAP, the details are

     

    • Incoming Mail Server IMAP
      • Server: imap-mail.outlook.com
    • Outgoing Mail Server SMTP
      • Server: smtp-mail.outlook.com

     

    To add the account, select other when you add a new mail account, and put in a nonsense email address for example "blah@blah.com" to avoid the mail app automatically setting up the account for you.

    Then select IMAP and input the proper details. your username is your hotmail address.

     

     

    If this email account is something other than Hotmail:

    It sounds like your email account is using POP, try to find out if your email account supports IMAP and enter those details like i explain in the bottom part of the hotmail explanation.

  • stzoran1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 4:53 AM (in response to aboothe22)

    I solved this problem by login in to my original mail server and deleting few oldest e-mails. Few seconds after deleting badge on my iPhone reseted and start to show real number of unreaded e-mail messages.

    Hope this will help.

  • Howardsweb Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 19, 2013 7:37 AM (in response to Psmith0103)

    I did this and it worked.  But then a few hours later they returned. I have done it three times so far .......

  • davidgarher Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 11:15 AM (in response to Garywoo)

    Thank you very much!

  • marki2013 Calculating status...
    Currently Being Moderated
    Sep 19, 2013 1:34 PM (in response to aboothe22)

    Finally I could find the solution.

     

    Scroll down on each of your Inbox e-mails and download all your emails. When you see "updated just know" keep scrolling down and more and more e-mails will appear and will be downloaded (it will take more than an hour).

     

    As soon as you finish with all downloads go to EDIT, mark all and mark as read.

     

    Be patient and you will get rid of all of the annoying unread emails.

     

    good luck. marki

  • Icevein Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 3:54 PM (in response to aboothe22)

    The ONLY thing whcih I found worked is to go into the offending email account and downalo all emails - 250 at a time - until youhave all (some users have 13,000) then "edit - mark mark as read" VERY tedious and VERY disappointing - Some users have said that the problem recurs after you do this. I have an iPod, Iphone and iPad - So far I am only upgrading the iPod as I don't have the patience to do this on each device.

     

    Where is the quality control in a new OS???

     

    This also means I will be putting off buying the 5S until problems like this get fixed.

  • cynlady Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 3:57 PM (in response to aboothe22)

    I started deleting all my unread emails and later they all appear again. So deleted my hotmail account and creating a new one as an "Outlook" but you can use your hotmail account and only appeared 40 (I think is what is permitted per account?) I hope this works.

  • kay_kay24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2013 7:02 PM (in response to aboothe22)

    I WORKED IT OUT GUYS! ok if you have hotmail delete the account on your phone . Add it back as an exchange email account. Then once you have done that go and edit that account in the settings choosing how far you want your mail to go back to and how much mail u want to show. Eg 3 days 1 week and so on. This is what helped me. If u don't have hotmail try it anyway.  Then u can select all as read messages. :)

  • g_borgulya Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2013 5:03 AM (in response to aboothe22)

    I deleted the non functioning exchange account, but could not add it again. Actually I could add it: adding took about 50 minutes, but after that it just did not work, it said I had no emails what's ridiclous. After a reboot I was able to add it again.

  • RJay324 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2013 6:05 AM (in response to aboothe22)

    I've tried everything that was mentioned. It would disappear as long as I don't close the mail app (meaning when you double click the home button and all the apps running appear). However, as soon as I close all the apps and reopen my mail, all the thousands mails reappear. My problem was on all comcast accounts.

     

     

    What I did was I went to my comcast email accounts that was causing the problem. I created a new folder and moved the oldest emails until the number of unread mails in my ipad and ipod decreased...eventually to zero as I moved more and more emails. Deleting would do the same but I have no time to review and delete all emails so I moved them for now. Now, whether I close the running mail app or not, there's no more unread mails. Hope this helps.

  • sternd12 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2013 8:28 AM (in response to aboothe22)

    This worked in gmail for me.

     

    1. log into gmail on your browser

    2. go to the advanced search by clicking the down arrow in the search bar

    3. directly under the word search is pull-down menu, click it and select "Unread Mail"

    4. click the magnifying glass to search

     

    this will bring up all of your unread mail that may be hiding.

     

    5. click the "Check All" box under the search bar

    6. click "Mark as Read"

     

    if you have mutliple pages of unread mail, as I did, you will have to repeat steps 5 and 6 until all unread mail is gone. then update your email on your device.

  • knigmich Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2013 8:51 AM (in response to aboothe22)

    The real problem here is the feature is removed to sync X amount of days (3 days, a week etc).

     

    They completely removed it for pop accounts and are saying to sync as exchange/imap now when 50% of users use POP and don't know how it works otherwise.

  • cleomissy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2013 3:01 PM (in response to knigmich)

    You are exactly right.  The "show" feature for iOS 6 is gone.  Now, instead of wating for the messages to drop off the inbox after a preset time or limit, they stay forever.  And you can't bulk delete them.  You either have to swipe each one, delete each one after reading, or select each one - individually - before the the "Trash" button lights up.  Big disappointment, Apple. 

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.