Skip navigation

More issues with poor Aperture performance

556 Views 15 Replies Latest reply: Sep 21, 2013 4:58 AM by Hakeswill RSS
1 2 Previous Next
Hakeswill Calculating status...
Currently Being Moderated
Sep 20, 2013 6:31 PM

Sorry to start another thread on poor Aperture performance, but none of the other threads I've found have been of any help (alas). I'm running Aperture 3.4.5 and am experiencing stupefyingly poor performance. It's not an issue of slow operation, but of regular beach balls. When I start it up, it beach balls. Then it stops and I foolishly try and do something, like move the mouse, and it beach balls again. This goes on for about a minute.


If I start editing, say, and then do something else, like switch to my library, it beach balls twice. Always a double beach ball. The editing process isn't slow as such, like it would be if my Mac wasn't powerful enough, it's just that I get regular issues of Ap freezing on me. After a while the app does start to run slowly, which makes me think that there's a problem somewhere.


I'm running a 15" Retina MBP with a 2.6 GHz i7, 16 GB of RAM and a 256 GB SSD, which is currently just over half full. My Ap library (managed) is about 37 GB, but it used to be bigger until I archived most of it.


Any ideas? Thanks!

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Sep 20, 2013 7:14 PM (in response to Hakeswill)

    You should create a new library, and test loading and using it for a small sample.


    I don't see anything of this sort with my rMBP, even if I use a library managed on the SSD.  My primary library is 1.8 TB, managed, and contained on a 4 TB TBolt drive.



  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Sep 20, 2013 11:39 PM (in response to Hakeswill)

    Before you do that, switch to (or create) a new user account and repeat the test there. If the problem persists then yes, reinstall. If not then something on the original account is causing the problem, not Aperture itself.

  • léonie Level 8 Level 8 (46,535 points)
    Currently Being Moderated
    Sep 21, 2013 12:38 AM (in response to Hakeswill)

    I created a 10-image library and the problems started immediately.


    I've tried all the usual stuff, like repairing the library and permissions and deleting various cache files, but none of that works.

    Do you see the beach ball, whith a new, empty Aperture is library, or only after adding images?


    Does Aperture start without beachballing, if you launch it with the SHIFT key ⇧ held down?

  • léonie Level 8 Level 8 (46,535 points)
    Currently Being Moderated
    Sep 21, 2013 1:27 AM (in response to Hakeswill)

    Yep, it beachballs when I open a new, empty library.

    That is an important clue. Your freezes seem not to be related to the actual processing of images. Aperture could be waiting for drives to be mounted, network access to sync with Flickr or facebook, etc., or privacy settings in your user account, like file vault, may be preventing immediate access to your library.


    Yes, the shift-key prevents preview generation on start-up. Even with preview generation disabled in the preferences, Apertre may still try to render previews, if you have enabled this for individual projects, like this:

    Screen Shot 2013-09-21 at 10.21.25.png


    While you are testing TD's suggestion: Did you update any software lately or install other programs? Incompatible third-party applications may be causing such problems.

  • léonie Level 8 Level 8 (46,535 points)
    Currently Being Moderated
    Sep 21, 2013 1:40 AM (in response to Hakeswill)
    Hmmm, new library on new user account = no beach ball on opening, or when moving around the interface. So does this mean that there's a problem with my current account? I did upgrade it to Mountain Lion from Lion (without doing a clean install). Could that be an issue?


    Did the problems start immediately after updating to Mt. Lion? You should be able to install Mt. Lion on top of Lion. Do you have Aperture plug-ins that are only used in your account and may not be compatible with Mt. Lion? Did you install anything else?


    Do you use helper preference panes that are only used in your account?


    If none of the above applies, start by removing the user preferences and next the presets from your user library.

    See Aperture 3: Troubleshooting Basics   on how to remove user preferences and presets; see the paragraphs: "Delete the user preferences" and "Move the user created presets, keyword lists, and so on..."

  • léonie Level 8 Level 8 (46,535 points)
    Currently Being Moderated
    Sep 21, 2013 2:23 AM (in response to Hakeswill)

    Do you still have the contents of "Hard Drive/System/Library/Caches"? Then restore it. Some items from the system cache can cause problems, if they are missing, for example: Re: Import video to Aperture library on Mountain Lion


    One problem with trashing preferences and presets in Mt. Lion are, that this may not help at the first try, due to the process model with "Automatic Termination". Even if you quit an application, you cannot be sure, that it will not be kept in the caches and restarted from the cached version. The only safe way to be sure to start a fresh copy is logging off and on again or rebooting.


    So try again, but log off and on after removing the preferences, moving presets, clearing user caches.


    Also try to clear Aperture's cache in the  $TMPDIR :


    Check this temporary directory - you can open it from the Terminal:  Launch the from Applications > Utilities and and enter the following line:

          open $TMPDIR

    Hit return. This will open a Finder window. Look for a folder ""

    You can delete its contents.



    The only plug-in I use is Photomatix HDR (trial version - I'd bought the full version prior to the Ap plug-in being released, grrrr). Worth removing?

    Look at Photomatix website, if your version is current and supported by Mt. Lion.

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Sep 21, 2013 4:33 AM (in response to Hakeswill)

    Have you tested with this wireless external drive not connected?


    In the other User Account, hold down the Option Key while clicking to launch Aperture.  What libraries are offered in the resulting dialogue?  Is the primary library that you use in your normal user account listed?  If so, can you choose and open it?  (there might be a legit issue of permissions with that, but check)



1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.