7 Replies Latest reply: Sep 21, 2013 8:11 AM by Eric Root
djohn15841 Level 1 Level 1 (0 points)

I have a MacBook running OS X v10.6.8 and I'm trying to upgrade to Mouton Lion but I can"t download it from the app store. It says I need a intel core duo which i have. does anyone know whats happening here?


MacBook, Mac OS X (10.6.8)