Skip navigation

Upgrade Dramas 3.4.5 - NIK Plugins

1325 Views 6 Replies Latest reply: Sep 23, 2013 8:56 AM by fla41w RSS
drsquidd Calculating status...
Currently Being Moderated
Jul 3, 2013 3:22 AM

Hi,

Had the usual upgrade to Aperture 3.4.5 dramas and sorted it out with a reinstall and some swearing. Then my NIK plugins got knocked out. NIK were kind enough to link me to the full new suite. Guess what? They all crash. BOOOO!!!

Still waiting on word from them, anyone with similar dramas?

 

I'm more of a hobbyist so I'm not sitting on dealine jobs, but still quite frustrated.

Thanks

 

Tried ArnieB's slution from Dec2012 - nuthin'!

 

Re: Nik Software

 

Dec 22, 2012 1:58 PM (in response to Pabli)

 

Thanks Pabli, I too contacted Nik and they sent me the following instructions, which failed to work

Maybe you will have better luck.

 

Thank you for contacting Nik Software.  HDR Efex Pro 2 and Color Efex Pro 4 take advantage of the Graphics Processing Unit (GPU) of the computer system. The GPU is also sometimes referred to as the Display Adapter or Video Card, in any case they are all the same. Sometimes certain video cards will not handle this additional processing.

 

In order to resolve this, the first measure would be to update the Display Adapters or GPU driver.  Generally the video card that comes with your Mac will be updated automatically. The exception may be when there has been an additional video card added. In that case the user may need to go to the video card manufacturer's website to download an updated driver for their secondary GPU. If you are using Mac OS Snow Leopard (10.6) ensure to update to 10.6.6 or higher as this can affect performance. If this does not apply to you, please go to the next section below.

 

If after following the above steps you are still experiencing the same issue, the next step will be to either disable the GPU (if possible) or force the plug-ins to not use the GPU (safe-mode). In order to disable the GPU in the plug-ins, please do the following in each one:

  1. If you are able to open the program and can see part of the interface, see if you can click on the"Settings" button in the lower left.
  2. In Settings locate the section "GPU" and expand it, in this section you will see a check box "Enable GPU Processing", uncheck this so the GPU will be disabled, then close the settings window.
  3. Close out of the program (click Cancel), quit out of any and all host applications (Photoshop, Lightroom, Aperture), and then relaunch HDR Efex Pro 2 or Color Efex Pro 4 to see if this corrects this issue.

If you are unable to disable the GPU via Settings or if the issue has not been resolved (e.g. HDR Efex Pro 2 or Color Efex Pro 4 crashes or the buttons are not displaying correctly), please try the following steps below after quitting out of all host applications (Photoshop, Lightroom, Aperture):

  1. Open a finder window (or double click on the Macintosh HD on the desktop) and navigate to:
    Macintosh HD : Users : <user name> : Library :Preferences : Nik Software : HDR Efex Pro 2
  2. Locate the file, HDREfexPro2.cfg and right-click and choose "open with..." and then click "Choose" and then locate the applications, "TextEdit" to open this file.
  3. At the very beginning (before all the text) of the configuration file, paste the following code below verbatim:
    <configuration>
  4. <group name="INTERN">
  5. <key name="UseSafeMode" type="bool" value="1"/>
  6. </group>
  7. </configuration>
  8. Now save the file, close it and relaunch HDR Efex Pro 2 and see if the issue has been resolved.

Then, for Color Efex Pro 4:

  1. Open a finder window (or double click on the Macintosh HD on the desktop) and navigate to:
    Macintosh HD : Users : <user name> : Library :Preferences : Nik Software : Color Efex Pro 4
  2. Locate the file, ColorEfexPro4.cfg and right-click and choose "open with..." and then click "Choose" and then locate the applications, "Text Edit" to open this file.
  3. At the very beginning (before all the text) of the configuration file, paste the following code below verbatim:
    <configuration>
  4. <group name="INTERN">
  5. <key name="UseSafeMode" type="bool" value="1"/>
  6. </group>
  7. </configuration>
  8. Now save the file, close it and relaunch Color Efex Pro 4 and see if the issue has been resolved.
iMac, OS X Mountain Lion (10.8.4), 2.8 GHz Intel Core 2 Duo, 6GB ram
  • fla41w Calculating status...
    Currently Being Moderated
    Sep 21, 2013 12:36 PM (in response to drsquidd)

    I think that the issue is only with HDR Efex Pro 2. I have used Define and Color Efex Pro 4 on the same image files. They do their job. HDR is the only one that quits.

     

    I have tried the Google suggestion of adding the coe to the HDR Efex configuration file and it did not change anything.

     

    I have just checked for duplicate Arial fonts, and I do not see any duplicates as mentioned in point 4 (so everything has been kept).

     

    Scrolling further down I find the "Microsoft" folder. It is full of fonts, some Arial (see attached).

    fonts.png

    Should I just delete the Microsoft folder? I do have some MS Office for Mac installed.

    MacBook Pro (15-inch Early 2011), OS X Mountain Lion (10.8.5)
  • LongSticks Calculating status...
    Currently Being Moderated
    Sep 23, 2013 2:22 AM (in response to drsquidd)

    To the dr....

     

    Hi I have the same exact problem as fla41w - only affecting HDR Efex Pro 2. Have checked Arial fonts and they are clear of duplicates as well.

     

    Any further suggestions?

  • fla41w Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 5:43 AM (in response to drsquidd)

    No, I have not done that. I have submitted a ticket to Nik to see what they have to say. Everything had been so stable, for so long, that I have lost touch with how to get the latest versions of Nik software. The plug-ins themsleves used to take me to the right location at Nik. I will have to re-educate myself.

     

    When I hear back from them I will decide whether to Command R the situation.

     

    Thanks for your help. I should be back sometime today.

  • fla41w Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 8:56 AM (in response to fla41w)

    OK, I have the Nik update. They sent me a link to download the latest versions of all plugins "NikCollection_1.007_22671_mac_full.dmg", with instructions to install the collection. They claimed that they have seen this issue with older Nik versions.

     

    I installed all plugins and started Aperture. It worked. HDR Efex Pro 2, stopped crashing during load of the image. I was able to use a couple of presets and saved an HDR version.

     

    When I tried the full screen version, I got a smeared rendering of the lower left as I have seen described above. I quit Aperture and restarted and the image looked fine in full screen mode.

     

    I figure that I might have to redo the GPU configuration fix, to finishup. I will maybe get to that later.

     

    For now, I am happy that the plug-in is not crashing.

     

    Thanks to the Dr and to others who took an interest in this issue.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.