Skip navigation

Frontrow under Mountain Lion it works!

28441 Views 36 Replies Latest reply: Feb 24, 2014 7:23 AM by nessviewer RSS
  • martbr Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 12, 2013 2:46 PM (in response to on parole)

    This sounds great, on parole.

     

    I tried to read your post several times, but I am still working on it:

    1.) You bought (?) "Remote Buddy" (that is about 20 Euro)?

    2.) You downgraded iTunes to 10.3?

    3.) You re-builded (or you will do that) your iTunes playlist?

     

    Can you give us a hint how much time to spend for this? And what it gives us at the end? Do you now have access to all your music, videos, iTunes DRM videos, movie trailers and whatever we all like? And we used to have with Front Row?

     

    Please do not misunderstand me - but before I try this, I would like to know how much it costs (time & money) and what I get for this!

  • on parole Calculating status...
    Currently Being Moderated
    Aug 13, 2013 4:13 AM (in response to martbr)

    Sorry i was very tired when i wrote that.

    So After reinstalling Front Row via Olli Happy's first awesome post here

     

    1.) I downloaded 30 day free trial of Remote Buddy

    2.) I downgraded to iTunes 10.3   (i found a post on line that this is the latest version that will work in front row in OS 10.8.4)

    3.) I transferred all my music and movies and podcasts back into iTunes from my back up drive with one click of "add to library " under the  "File" tab  in  iTunes Menu bar .

     

    If you follow the instructions on the 2 links i posted previously the whole process of steps 1-3 will take about 20 minutes.

     

    In Front Row everything will still automatically be listed under playlists like "Artist", "Genre", "Album"etc .And YES you have access to everything in iTunes from Front Row as before such as movies etc.

     

    But because your downgrading iTunes unfortunately it wont recognize your personal playlists from a later version  it just loads all music in as one very long playlist so you then have to reorganize your own specific playlists again if you want iTunes organized and personal playlists in Front Row. I never really use i tunes except for storage so i cant comment on what functions you miss out on with 10.3 compared to version 11 im sure its alot. But of course upgrading back is simple especially if you have your playlists saved on external drive.

     

    But i suggest you just download the free 30 day trial of remote buddy first before changing i tunes and see if you like it.

    Its pretty cool it lets you access all your applications via IR remote (like Quicktime Player,Preview,Safari ,DVD Player ,etc) and you can shutdown your computer etc with it. Its worth a look.

    It DOESNT OPEN Front Row though...Trying to hold the menu button down to open front row crashes remote buddy everytime !!!

    i have to maually open front row icon by doulbe clicking it and then the remote works in it as usual .

    Except the menu button only exits Front Row once its open. To scroll back one screen (from a song back to the album for example) i have to hold the + button down for a few of seconds.So worth trying remote buddy first to see if your happy with the functionality before downgrading itunes i guess.

     

    COSTS: So far nothing because of free trial...ill see how much i like it after a couple of weeks and decide. At this stage it seems pretty cool. Being able to use it for everything (except to open front row)  and be able to  shutdown computer etc from my bed makes it tempting to buy

     

    TO BE HONEST MOST OF ALL I JUST LOVE HAVING A FULLY FUNCTIONAL FRONT ROW AND A WORKING REMOTE WHEN APPLE BELIEVES I SHOULDNT LOL

  • on parole Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2013 8:43 AM (in response to martbr)

    Im Awake now!!! 

    Here are the steps above without the rambling on

    This assumes you have reinstalled Front Row already and backed up your itunes folders to external drive or have them backed up in a system back up already :

     

    1:) DOWNLOAD "Remote Buddy" free 1 month trial http://www.iospirit.com/products/remotebuddy/software

    2:) DOWNGRADE Current iTunes to version 10.3 http://www.emacconsulting.com/apple/itunes/downgrade-itunes-11-to-itunes-10-7

    3:) LOAD all your music and movies etc back into iTunes version 10.3 via "add to Library" tab in iTunes.

    4:) Stop living in the present and start living in the past

         OPEN Front Row and party like its 2011 again!!!

     

    Optional time consuming part of course:

    5:) Re-organize your music files back into personal playlists in iTunes 10.3.... blah!!!

  • martbr Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 13, 2013 1:19 PM (in response to on parole)

    Thank you for your posts and the shorter description.

     

    Did you try CandelAir (http://www.iospirit.com/labs/candelair/) instead of "Remote Buddy"? It is based on the driver of "Remote Buddy" and free of charge. As far as I know it maps the remote commands to the old way - so may be it helps to control Front Row.

     

    One disadvantage is - in my opinion - the downgrade of iTunes. If you have an idevice (iPhone etc.) with the current iOS, then the newest iTunes is necessary to transfer your music. Except you use iCloud - which I would never do.

  • mariofromwestlake Calculating status...
    Currently Being Moderated
    Sep 8, 2013 5:27 PM (in response to OlliHappyOnMac)

    Having upgraded to Mountain Lion 10.8.4, I tried grabbing the Front Row files in vain from my 2011 and 2012 backups from my older system, Snow Leopard.

     

    I partitioned my HDD and installed Snow Leopard on a smaller (50 GB) partition. Front Row works perfectly there, with my IR remote and all. I followed your instructions as to copying the files and creating an application in the Apple Script Editor (a breeze!). I renamed the application Enable Front Row.app and gave it the same Front Row icon and placed it on my dock. Works like a charm, except that the Remote Buddy (30-day trial) crashes in OSX 10.8.4.

     

    I wonder if there is a way to reenable Front Row on the IR Remote under OSX 10.8.4 natively.

     

    Thanks!

     

     

    Mario

    Westlake, OH

    Equipment: 2009 17-inch MacBook Pro running Snow Leopard 10.6 & OSX Mountain Lion 10.8.4, 8 GB RAM, 320 GB HDD.

  • Electric Wolf Calculating status...
    Currently Being Moderated
    Sep 19, 2013 5:40 AM (in response to OlliHappyOnMac)

    The above code DOES NOT COMPILE

     

     

     

    #launch Front Row

    tell application "/System/Library/CoreServices/Front Row.app"

      launch

    end tell

    tell application "System Events"

      key code 53

    end tell

  • nkalvi Calculating status...
    Currently Being Moderated
    Sep 19, 2013 5:47 AM (in response to Electric Wolf)

    It seems to compile fine on my system.

     

    Have you tried without (or modifying) the first line of comment? (I don't think you're running pre-2.0 - though it is good to eliminate the case).

     

    https://developer.apple.com/library/mac/documentation/applescript/conceptual/app lescriptlangguide/conceptual/ASLR_lexical_conventions.html

     

    • Starting in version 2.0, AppleScript also supports use of the # symbol as an end-of-line comment. This allows you to make a plain AppleScript script into a#Unix executable by beginning it with the following line and giving it execute permission:
      #!/usr/bin/osascript
      Compiled scripts that use # will run normally on pre-2.0 systems, and if edited will display using --. Executable text scripts using #!/usr/bin/osascript will not run on pre-2.0 systems, since the # will be considered a syntax error.
  • Tza_Mac_happy Calculating status...
    Currently Being Moderated
    Sep 22, 2013 12:13 AM (in response to Alexandros1965)

    I'm also not getting the trailers to play... instead just getting the spinning wheel at the first second of the trailer about to start.  It hangs there for ever.  Please help with any suggestions?

    cheers

  • Electric Wolf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 9:12 AM (in response to nkalvi)

    It doesn't compile on mine. Is there a way to compile it so that I can run Front Row? I seem so close yet so far away

  • mariofromwestlake Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 1:51 PM (in response to Electric Wolf)

    Wolf,

     

    You need to copy that script onto Apple Script; before you compile it, select Application in the Save As box. Otherwise, it won't work.

     

    I created the script for Front Row as a new app the first time and it works. I run Mac OSX 10.8.5.

     

    Cheers,

     

    Mario

  • Electric Wolf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 11:36 PM (in response to OlliHappyOnMac)

    I get this syntax error when I try to compile it:

     

     

    Expected “end” or “end tell” but found unknown token.

  • nkalvi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2013 4:50 AM (in response to Electric Wolf)

    Could you tell us the OS X version you're running?

  • Electric Wolf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2013 12:23 PM (in response to on parole)

    I'm running 8.2

  • nkalvi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2013 1:28 PM (in response to Electric Wolf)

    Assuming it is 10.8.2, I'm not sure why it wouldn't compile. Just to eliminate any character conversions during copy/paste, you may want to try using this file: https://dl.dropboxusercontent.com/u/1496969/Start%20FrontRow.scpt

     

    I'm just curious - any reason for not updating to 10.8.5?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.