Skip navigation

An erroe message please see other link ( inside the post )

1045 Views 13 Replies Latest reply: Sep 25, 2013 4:33 AM by ronenhaim RSS
ronenhaim Level 1 Level 1 (10 points)
Currently Being Moderated
Sep 21, 2013 2:09 PM

A new discussion related to :

 

https://discussions.apple.com/thread/5317193?start=15&tstart=0

 

I had a Live Chat with an Apple advisor ,

he said :

 

"

 

The problem started when you updated to 10.8.5, but the reason is because your external drives were connected during the update and this has caused an issue.

 

 

"

 

I say :

 

if ill upgrading software -the HD should be disconnected ???

 

 

To try and solve the issue , :

 

If ill Format the 2 HD external drivers - can this solve the problem instead of cleaning my iMac PRAM ....and other solutions

 

Thanks

iMac, OS X Mountain Lion, 10.8.5
  • Eric Root Level 6 Level 6 (13,835 points)

    If you reformat the drives, you will lose any data that is on them.

     

    I'd start with the Pram and then try the Safe Mode which rebuilds things, or the other way around.

     

    Reset NVRAM/PRAM

     

    Safe Mode

     

    Safe Mode - About

  • Eric Root Level 6 Level 6 (13,835 points)

    Did you see the post in your original thread where someone said they had talked to Apple and this is a known bug they are trying to fix?

  • marchyman Level 1 Level 1 (20 points)

    I've tried a few things.  Some googling suggests it is a known bug (some drives disconnect when the machine is sleeping) exacerbated by the newer iMacs going into standby mode (which is different from not sleeping).   I tired this:

     

    sudo pmset autopoweroff 0

     

    and it did not help (but then I really didn't expect it to help).  Next on my list is this:

     

    sudo pmset standby 0

     

    My machine is connected to AC... there is no reason to hibernate.   The time machine disk is lost only when the machine hibernates.   I have hope for this "fix" in that my machine entered hibernate mode 70 minutes after sleeping and the "standby delay" as reported by pmset is 4200 seconds (70 minutes).  I'll update this once I know something either way.

  • marchyman Level 1 Level 1 (20 points)

    Replying to my own post...

     

    Using pmset to set standby to 0 seems to have solved the issue for me.  I let the machine sit and it went to sleep after 90 minutes... which is the value I have set in the Power tab of the Energy Saver system preference.  Just to be complete my display is set to sleep at 9 minutes and hard disks sleep when possible.

     

    When I hit a key to wake the machine about 5 hours later it woke upo quickly... that told me before I looked at the system logs that the machine wasn't in hibernation mode.   And because it wasn't in hibernation mode my time machine disk wasn't lost.   Looking good.  If tomorrow morning I don't have the issue again I'll call it resolved.

     

    So ronenhaim... open a terminal window and type

     

    sudo pmset standby 0

     

    It will ask for your admin password.   There is a chance that this will resolve your issue.

  • marchyman Level 1 Level 1 (20 points)

    It's not a preference.   It's a command to be entered in a terminal.  And it IS the fix to your issue.

     

    Your choice is simple.  Do nothing and continue to see the problem until some future apple upgrade happens to resolve the issue... maybe.  Or launch Terminal, enter one simple command, then Quit Terminal.   It will resolve your issue.  It will not harm your machine in any way.  It is reversable should you ever want to go back to the way it was.

     

    You choose.

  • marchyman Level 1 Level 1 (20 points)

    When you have two thunderbolt disks it apparently takes a while for both to become active when the machine is hibernating.   This seems to cause OSX to give up and declare one of the disk as not being present.  On my system it was always the time machine disk that was "lost".  The logs you posted show your machine is hibernating. Mine did, too.  I don't know why.   However, until Apple does something about this you can resolve the issue by making sure your machine doesn't hibernate.

     

    1) Launch Terminal

    2) Enter the command

        sudo pmset standby 0

    3) enter your password when prompted

    4) Quit Terminal

     

    That stopped my machine from hibernating and resolved the lost disk issues.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.