Skip navigation

Wifi not working after upgrade to iOS 7

125863 Views 240 Replies Latest reply: Apr 10, 2014 9:24 AM by rayfern72 RSS Branched to a new discussion.
1 2 3 ... 17 Previous Next
Gustavojosedf77 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 23, 2013 4:45 PM

After upgrading iOS 7 on my iPhone 4S, the wifi is not working. It cannot detect any wifi nor am I able to enable wifi under settings. Is there a way for me to fix this?

iPhone 4S, iOS 7

iPhone 4S, iOS 7
  • Lawrence Finch Level 7 Level 7 (24,590 points)
    Currently Being Moderated
    Sep 23, 2013 4:47 PM (in response to Gustavojosedf77)
  • scoho Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 5:15 PM (in response to Lawrence Finch)

    Thanks, there are many other threads on this, and the reset rarely seems to work.  I have tried it -- and many other supposed fixes -- and it has not worked.  There is clearly a bug given the number of people this has happened to.  I also have a 4S.

  • scoho Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2013 5:24 PM (in response to Lawrence Finch)

    Sorry, maybe I am not understanding.  Are you saying there was a similar problem before or that it's not really an issue? 

  • Lawrence Finch Level 7 Level 7 (24,590 points)
    Currently Being Moderated
    Sep 23, 2013 5:44 PM (in response to scoho)

    There has been a similar problem reported with every version of iOS ever released, back to 1.1. Indeed, some of the people who reported it for 6.1.3 say that 7.0 fixed the problem. Usually it is a software configuration issue, and can be fixed by a clean install as a new phone if nothing else works (such as Reset Network Settings and Reset All Settings). Sometimes it is a hardware issue, and the upgrade somehow aggravated an existing problem.

     

    That tip leaves out a few solutions that have anecdotally worked. The first I have no problem with; the others I would be very cautious with. If the phone is in warranty I would take it to an Apple store for replacement rather than try them.

     

    1. Remove the SIM. Reboot the phone (hold HOME and SLEEP until an Apple logo appears). Try WiFi. Reinsert the SIM.
    2. Put the phone in a plastic bag in a freezer for about 10 minutes.
    3. Heat the phone with a hair dryer for a couple of minutes.
    4. Open the phone, resolder the WiFi chip (don't try this at home).
  • Rajkumar Warrier Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 23, 2013 5:54 PM (in response to scoho)

    Quite correct. I contacted tech support. Iphone4s has a wiFi issue which he acknowledged. Numerous measures suggested in Apple forum as well as on google site did not work. Once the firmware is upgraded it is not possible to go back to iOS 6. That means the back up done before the update to iOS is useless.

    I have been given an appointment to an apple store this week end. I hope they can fix it. If not the phone will be unable to get WiFi until Apple decides to come up with a fix. This seems to be a random issue with 4s., as far as I can understand. Phone 5 may not have this issue, I am not sure.

    Good luck all the cosufferers out there!  I will be very reluctant to try anything other than no 1 above.

     

    RKW

  • samwillhelp Level 1 Level 1 (125 points)
  • Rajkumar Warrier Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 29, 2013 7:01 PM (in response to samwillhelp)

    UPDATE

     

    This is an update on my WiFI connection issue I had discussed earlier.

    I visited Genius bar in an Apple store. After checking my phone the person informed me that this is a hardware issue. She also indicated that the upgrade to iOS 7 and loss of WiFi might have been coincidental.

     

    Since my phone is out of warranty the option offered to me is that it may not be worthwhie to fix this problem at this time. The cost for fixing this issue is about $180.  (For this price I can get a new phone since I am eligible for an upgrade with ATT. So I am just going to explore my options at leisure and buy whatever suits my needs)

     

    RKW

  • Micrl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2013 9:07 PM (in response to Lawrence Finch)

    This is the first time I have seen a suggestion to Remove the SIM. Reboot the phone (hold HOME and SLEEP until an Apple logo appears). Try WiFi. Reinsert the SIM.

     

    I've had this issue before and had my wifi chip replaced, after updating to iOS7.0.1 wifi was greyed out again but appears to be back for the meantime after trying this. I wish I had tried it when my wifi broke last time.

     

    Freezing and Heating the phone do not work.

  • sherifelabd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 30, 2013 1:59 PM (in response to Gustavojosedf77)

    I have the same problem with iOS 7 and 7.02 on both iPhone 4S and iPad 3, moreover connecting through the cellular data is becoming also very annoying. Everything was working flawlessly with iOS 6.

    I tried everything I can think of deleting network, soft/hard restart, resetting network  and restoring nothing worked.  On the other hand my notebook connects to the same wifi easily, so it's not the wifi problem it's the iOS 7.

     

     

    Freezing and heating does not work :))

     

    Apple :(((

  • Lawrence Finch Level 7 Level 7 (24,590 points)
    Currently Being Moderated
    Sep 30, 2013 2:17 PM (in response to sherifelabd)

    Is this just on your Home network? If it is reset your router by removing all power from it for 15 seconds.

  • JLuther23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2013 4:59 AM (in response to samwillhelp)

    @samwillhelp--this fix worked on my iPhone 5 and iPad 3 as well. Thank you.

  • alicepattinson Level 1 Level 1 (40 points)
    Currently Being Moderated
    Oct 1, 2013 5:19 AM (in response to Gustavojosedf77)

    RESET NETWORK SETTINGS

  • Sunny0308 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2013 11:17 AM (in response to Rajkumar Warrier)

    GOOD NEWS (I hope)  I have done all the so called resets, reinstalls and restarts.  I have even put my 4s in the refrigerator for 10-15 minutes then did a General>Reset>Reset Network Setting which was successful for a few minutes.  As soon as the 4s got back to room temperature, it would lose the wifi connection. 

     

    On the morning Sept. 29, 2013 I tried another suggestion which HAS BEEN SUCCESSFUL for 3 days now.  After putting the 4s in the refrigerator (wrapped in a paper towel to avoid moisture) for 15 minutes, I did another General>Reset>Reset Network Settings. 

     

    Then I went to my wifi and it connected. 

     

    Once connected I tapped on the wifi connection and then I tapped on the small "i" within the circle to the right of my wifi connection.

     

    I scrolled down near the bottom of the page and tapped on Renew Lease.

     

    My 4s has been connecting perfectly.  It stayed connect in my home.  I went to Starbucks and it connected there with NO PROBLEM and then I went to another local location and it picked up wifi with no problem.  Upon returning home it reconnected automatically to my home wifi.  I hope this is not a short term thing.  I will be thrilled if it is truly fixed. I know the refrigerator thing sounds crazy but it appears to stop the 4s from getting too warm and allows for the wifi connection.  Once it connected I was able to proceed with the above and it has be perfect for 3 days now.

1 2 3 ... 17 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.