1 2 3 Previous Next 31 Replies Latest reply: Oct 3, 2013 1:34 PM by Old Toad
Wapace11 Level 1 Level 1 (0 points)

I have a the mac app store app, but it says that it needs 10.7 OS X or later to run it which doesn't make sense. Any help would be appreciated.

Thanks


iMac, Mac OS X (10.6.8)
1 2 3 Previous Next