Skip navigation

iTunes audio/video drifts out-of-sync

111751 Views 76 Replies Latest reply: Apr 6, 2014 9:38 PM by Fuzzmunky RSS
  • TJisret Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2013 7:51 PM (in response to Sean Knudsen)

    I must admit that I have had the same problem for over a year and Apple Support was not much help they as much said I was on my own with this!  I tried this fix in this string of conversation from I think Mr Me and it works like a charm. Don't remember changing the setting in the Audio Driver but I must of. 

  • Stygants Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2013 10:35 AM (in response to Sean Knudsen)

    Mr Me, thank-you, your solution solved the problem. I too have Realtek audio and as long as the settings there match what is in itunes preferences, all seems to be well.

  • kazvye Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2013 1:05 PM (in response to kazvye)

    As predicted, it was just a blip.  I've got a TV show running now and it's completely out of sync.

  • kazvye Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2013 12:55 PM (in response to Sean Knudsen)

    I've tried resetting all my preferences to the different bit/Hz settings and nothing has worked.  After a few lines, it's all out of sync again.

     

    And I stil can't view anything via QuickTime because it says my computer isn't authorised, yet when I log in it tells me I have 2 computers authorised to view content.

  • Toxic Dump Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2013 6:24 PM (in response to Sean Knudsen)

    This worked for me on windows 8, but it could be different for everyone else.

    Itunes doesn't have the same default audio preference as your computer,

    so you will need to find what your computer's preference and change Itunes preference to match your computer preference.

     

    Open control panel and look for sound, a new window will show up with the tabs "playback","recording","sounds", and "communications"(This is what I saw in windows 8, may vary depending on your operating system)

    Look for "Speakers" button, when you find it right click on it or find a way to access the "Speaker Properties" window. Go to the "Advanced" tab, there show what bit rate and Hz your computer is running on.

    (Control Panel>Sound>playback>right click on "speakers" for properties>Advanced>write down your bit rate and Hz)

     

    Once you know what bit rate and Hz, open Itunes and go to Edit>Preferences... (Ctrl+,)

    Go to the Playback tab, on the bottom there will be the slot for bit rate and Hz.

    Change it to match your computer default settings.

     

    For windows 8, I just change the preferences in Itunes to:

    Bitrate For Audio Playback: 48 kHz

    Bits Per Sample For Audio: 24

     

    P.S. Once you change Itunes audio setting it may not take effect until you restart.

     

    Just in case...

    48,000 Hz = 48 kHz

    K means thousand, I'm sure everyone already knows

  • DarkScorpion Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 9, 2013 9:54 AM (in response to Sean Knudsen)

    Following Mr Me's advice, I went in another direction just as Toxic Dump did. I am using Win 7 Pro with Realtek HD. I went into my Itunes settings ( Preferences> Playback ) and upped the audio sampling to match what I have my computer already doing. I changed it to 192khz and 24 to match my Realtek settings of 24bit and 19mkz. I no longer have the audio/video drift. I did this change before I even read Toxic Dump, but I can confirm that it works the same in Win 7 as they confirm Win 8. {Grins.}

  • geeksedition Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2013 4:11 PM (in response to Sean Knudsen)

    SOLVED   -   For those who have not solved the issue with audio adjustments.

     

    I KNOW this is an issue with MS Surface Pro.  Perhaps its a Windows 8 issue all together, I am not sure.   As much as it pains me to say you need to install another apple product to fix the problem with an apple product, thats just the case. 

     

    Simply install QuickTime and the problem will jut go away.   That is all. 

     

    I hope this helps.

     

    Cheers,

    //Ian\\

     

    www.solutions3.ca

  • kazvye Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2013 2:15 AM (in response to Sean Knudsen)

    I have QuickTime and that doesn't work either (no sound or picture, but the time on the programme runs) or it asks me to login to my account in order to authorise the PC, which I do but it still doesn't show the programme. 

     

    I've adjusted my audio settings (I don't have Realtek either, so it's not specific to that).  On Saturday evening, a programme ran fine and in sync.  On Sunday evening, out of sync once again.

  • RiverSong1995 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 14, 2013 8:29 PM (in response to mt1083)

    The only thing that worked for me was pausing and letting the video buffer for a while before playing it again.  Annoying, but effective.

  • Retsef Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2013 4:26 PM (in response to Sean Knudsen)

    I'm having the same problem as everyone else.  I tried setting the bit rate and kHz to match, even tried a few different settings and it still gets out of sync.  I am using windows 8.  The only thing i haven't tried is downloading QuickTime but my iTunes is up to date.  I looked through my TV's settings too but I didn't see anything that might matter.  Any input would be greatly appreciated!

  • zimba07 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 27, 2014 3:17 PM (in response to Retsef)

    I had the same problem. Tried with setting same KHz setting in both itunes and Realtek HD Audio manager without success.

     

    Found a solution which seems to work for me (Windows 8.1, asus UX301LA laptop with Realtek HD audio drivers):

     

    The solution is to disable the Realtek HD Audio manager at startup in Windows 8.1

     

    1. Right click task bar -> Task manager

    2. Select the Startup-tab

    3. Find Realtek HD Audio manager -> right click -> Disable

    4. Reboot

     

    Itunes now works without audio drifting out of sync. (Currently running Itunes 11.1.3.8)

  • kazvye Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 28, 2014 8:02 AM (in response to Sean Knudsen)

    I'm on Windows 7 on a 2-year-old PC and we don't have Real Tek (don't know what we do have).  Mine is now temperamental but can be out of sync within 2 mins.  Sometimes it will play (although I find myself endlessly watching the lips just waiting for it to happen) but mostly and at present, it's still woefully out-of-sync.

     

    I've tried most of the solutions on here, matching the KHz settings and such.  Quick Time still doesn't work either despite being uninstalled and reinstalled, I've even uninstalled and reinstalled my itunes library. Not something I want to make a habit of doing.

  • Xelajú Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2014 3:21 PM (in response to Sean Knudsen)

    I have the same problem.

     

    Motherboard: Gigabyte GA-MA785GPMT-UD2H

    Chipset:

    1. North Bridge: AMD 785G
    2. South Bridge: AMD SB710

    Video: Integrated ATI Radeon HD 4200

     

    HDMI Audio through the HDMI port out to the TV.

    Tried on Windows 7 Pro 32bit and Windows 8.1 Pro 64bit.

    Tried with the integrated ALC889A audio device enabled and disabled (It seems that the video card drives the HDMI audio device though, because it still appears in Windows even if I disable the Audio device in BIOS).

     

    Latest iTunes and drivers installed.

     

    I have already tried all sugestions about matching Windows Audio settings to iTunes settings (bit depth, frequency rate).

     

    Apple, any suggestions? I'm not having a great customer experience after buying a pair of HD movies in iTunes.

  • Sam Savin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 22, 2014 5:03 PM (in response to Sean Knudsen)

    I have found a sollution to this!

     

    go into itunes click file > prefrences > playback and turn the bit rate all the way up

     

    then go to the sound option it the bottom right hand corner right click > playback devices > right click on your device > properties > advanced and turn the bit rate down to about dvd quality.

     

    annoying process but i guess whatever works!

     

    Hope this helps!

  • turingtest2 Level 8 Level 8 (43,970 points)
    Currently Being Moderated
    Feb 22, 2014 5:13 PM (in response to Sam Savin)

    You could also try turning off Direct Sound.

     

    In iTunes go to Edit > Preferences > Playback > Play Audio Using > Windows Audio Session.

     

    tt2

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.