1 Reply Latest reply: Sep 27, 2013 2:42 PM by Tony T1
Jules in Devon Level 1 Level 1 (0 points)

Trying to Sync my new iPad but I get a message saying "can't use iTunes as I don't have  iTunes update 11.1. I've searched the WEB but can't find a button that says  press to download


iMac, iOS 5.1.1