Skip navigation

24" iMac Screen Freezes since 10.6.3 update - pls help!

454943 Views 1,593 Replies Latest reply: Mar 5, 2014 4:31 PM by forevermacintoe RSS Branched to a new discussion.
  • dmaude Calculating status...

    You've been lucky. My iMac 7,1 with ATI Radeon HD2400 froze within seconds of installing 10.8.5. Kext fix fixed it, although ever the display can't sleep and browser windows wander of their own accord. Quite pathetic, Tim and Sir Jony! No wonder some analysts are predicting you'll go the same way as Nokia and RIM...

  • hardtofin Calculating status...

    Does anyone know if there is a kext fix for the nvidia cards also, as per my posts on page 93?

     

    I have exactly the same problem yet no sign of a fix at all

     

    Many thanks.

  • 53dandthird Calculating status...

    My iMac 7,1 finally went down today, just short of 10 days of uptime since applying the 10.8.5 Combo update. All the same symptoms, pages of GPU debug stuff in Console. The funny thing is, after days of pushing the iMac hard to try to force a crash, today I was just browsing and listening to iTunes. It was NHL.com that brought it down. Anyway, I applied the 10.6.2 kext fix and all seems fine. Like Iftokyo, this is the end of the line for me. I'll just run 10.8.5 with the kext fix until this iMac dies. I don't forsee this issue ever being resolved.

  • Colin Fox1 Calculating status...

    I went ahead and applied the kext fix (10.6.2 drivers) to my 8.1 iMac today. ati2600 card

     

    I had a number of freezups including a kernal panic on 10.8.5.

  • tomasz17 Level 1 Level 1 (0 points)

    I have had two crashes since 10.8.5 Combo Update - but without any metion to GPU / SLOT 1 in the console logs.

     

    Today I have applied the kext fix.

     

     

    That disappointing, Apple.

  • Fred1723 Calculating status...

    Anyone still reading this and having issues refer back to page 28!!! Full instructions on how you are able to fix the problem created by Apple!!

     

    I have a mid 2007 20" Intel iMac with the ATI Radeon HD 2400 XT 128 MB graphics chip...running 10.8.4

     

    My condensed story is a few years back while I was living in Canada I started having the problems everyone else was having with this model. I brought it into the Apple Store near Toronto for them to diagnose. After they had it for a few days they called me back saying my screen and fans were failing. They offered to replace these at no charge because I was "just out of waranty". A bit confusing on my part because I didnt buy applecare and the computer was just over 3 years old. Oh well...free repair, sign me up! Well then a couple days later they call me back saying logic board was also failing. Surprisingly they offered to replace my logic board too! Again, free repair part 2! So props to Apple for doing this!

     

    That unfortunately didnt take care of the problem. I dealt with the issues with the computer because at this point we werent really using it much because we were in the middle of immigration, selling a house, etc.

     

    Fast forward to spring of 2013. Now that we are using the computer more or trying to it gets frusterating again. I could guarantee a freeze at least a few times a day. I remember one time trying to start the machine up 6 times in a row and no luck and saying f- this I'm done with it for today. Well I get in contact with Apple again and they sign me up for an appointment at the closest Apple store which is 40 mins away from me. I take it to them and after their 1st diagnosis thay can't replicate the problem and their stress test shows no problems. ***? Then after talking to them I mentioned that I had my logic board along with screen and fans replaced a few years back. They tell me they are going to run more stress tests and get back to me. Well later that night I get a call saying my logic board is failing. Really?? I tell them it was just replaced a few years back and I have a hard time believing I got two bad logic boards. They tell me a logic board can go at any time...blah blah blah and it will be something like $500 or so for them to fix. Then they go into the you might as well just buy a new computer spiel, in a few months it no more parts will be made for it....etc I tell them at this time I'll take it up with the Apple guy who signed me up for the appointment because this is rediculous. I go back and forth with the Applecare guy and they agree to not charge me labor as long as I pay for the part.

     

    In the meantime of going back and forth I stumble across this thread and learn of a lot more people with the same exact situation! After educating myself a bit more I go back and forth I email the applecare guy back informing him that I feel my computer problem was mis diagnosed! I link him to this thread along with all the others. A week goes by and nothing. Then I email him again and nothing. Finally a few weeks go by and I email him one last time and get the email returned saying not a valid email address anymore. UGH! Back to the drawing board.

     

    I come back here and do more research and reading. Not being a big tech guy I still decide I'm going to give it a shot! Especially since it seems like KrzysiuTurek made it super simple.

     

    So after a whopping 15 minutes fixing the KEXT files my computer was running great again! Too good to be true?? Its been about 2 months now and NOT ONE FREEZE...GOOFY SCREEN...NOTHING! A perfectly good running computer again!

     

    Again very disappointing on Apple's part because if the good people of this thread didnt come together I wouldnt have found it and might have spent the money trying to "fix" it again based off of a mis diagnoses by Apple!

  • hardtofin Level 1 Level 1 (5 points)

    Does anyone know if there is a kext fix for the nvidia cards also, as per my posts on page 93?

     

    I have exactly the same problem yet no sign of a fix at all

     

    Many thanks.

     

    Love the way people just ignore this question and keep posting about ATI cards.  Is there a ******* NVIDIA kext fix?

  • Brian from VA Calculating status...

    Thanks, Fred1723, for your story, and I'm glad this thread has helped make your computer useful again!  It's been a life-saver (well, actually machine-saver) for me, too.  I applied KrzysiuTurek's "kext fix" over two years ago and it definitely fixed the frustrating "screen freeze" problems I was having every day.  Luckily I came upon this thread before I replaced any hardware.

     

    hardtofin, I'm sorry to say that I've been following this thread for over two years and cannot remember anyone posting a reference to a similar fix for NVIDIA cards.  I don't know why that's the case, but there you have it.

     

    For reference, I've got an iMac8,1 which is a 24" Early 2008 Core 2 Duo 2.8 GHz with ATI Radeon HD 2600 Pro (256 MB), purchased in May 2008.

     

    Still, something about this kext fix is odd, though.  First, my symptoms didn't appear until some relase after 10.6.3 (I think it may have been 10.6.7).  Second, at its worst, I got about one screen freeze a day (much less than some others here).  Third, 28 days ago I upgraded my OS to 10.8.4 (later to 10.8.5), did not install the kext fix, and have had no problems.  Others' postings above seem pretty convincing that 10.8.5 does need the kext fix, and I wonder why mine seems to be working without it now.  I'm quite sure that I had the same symptoms as others here, and that the kext fix did resolve the problem -- so what's going on now with my machine?

     

    Also, I (too quickly) read a posting on another site (I think it may have been MacRumors' forums) that claimed that there were three versions or revisions of the ATI Radeon HD 2600 Pro card used in these iMacs:

     

    1) exibited frequent freezes in 10.6.3 and above

    2) had less frequent freezes, only in 10.6.7 (I think he/she said) and above

    3) one with no problems

     

    This hypothesis could explain my experience and how it differs from many others'.  I will try to re-find the thread and post a link, but does anyone have any other info on this idea?  If there were truely multiple revisions, would we be able to find a revision number on the physical graphics card board?  Has anyone really looked closely at one?  (I know that when I had my iMac open for a HDD/SDD upgrade, the graphics card was the last thing I was worried about!)

     

    System Information-->Graphics shows a Revision ID, but AFAIK everyone's is always 0x0000, so this argues against the idea.  But still possibly there were different revisions of the hardware that (for some reason) don't show up in System Information.

     

    (I used "kextstat | grep ATI" to ensure the old ATI kexts were not being used.  I get only one ATI kext loaded now: com.apple.ATIRadeonX2000 (8.1.6) and the date on the file is May 7, too new to be the 10.6.2 version.)

  • TK111 Calculating status...

    @hardtofin: It would seem to be obvious. Find the last known good version of OS X re: the kexts for your GPU. Grab those kexts and substitute them into your current version of OS X using the same procedure described in this thread.

     

    @Brian from VA: I got a new HD2600 PRO GPU installed by Apple when I went with an extensive documentation of all the freezes I had been having. It worked without fault for several months, but the problem reoccurred. If you're going 28 days on 10.8.5 without a problem, nice work. But I wouldn't bet the house on it staying that way.

  • aieronimo Calculating status...

    Dear Brian from VA,

     

    You may be right on there being various versions of the ATI card.  I have the same ATI card and same iMac edition (8,1) as you, and I need the KEXT fix to prevent crashes.  However, my friend has the same ATI card and the same iMac edition as I, but has had NO system crashes ever.  So maybe ATI issued a bad run (or two) of cards, then fixed the problem.  I do not believe there is a difference in model code between the two cards, at least in how the info shows in "About this Mac."

  • geychaner Calculating status...

    I have an iMac 7,1 with the ATI2400 graphics card (Rom revision 113-B2250A-207). Updated to 10.8.5 today; computer (screen) froze almost immediately, first time Safari was used. Installed the Kext fix as usuall; kids now happily playing PBSKids.

  • steveylin Calculating status...

    Here's a direct link to page 28:

     

    https://discussions.apple.com/thread/2384136?start=405&tstart=0

     

    BTW, did anyone try to update the graphic card firmware by booting into Windows via Bootcamp?  I just wonder if a firmware update could have fixed this problem

  • pc1234 Calculating status...

    Do you know where there is a Windows based firmware update for the card?  My 2008 iMac 24" has an ATI Radeon HD 2600 Pro 256MB with ROM: 113-B2250L-259.  I was not able to find any Windows firmware update for it.  I found one from Apple but it is for version 113-B2250L-259 which is already installed.

     


  • pc1234 Level 1 Level 1 (0 points)

    Disabling hardware acceleration seemed to help me.  I went  3 months  without a crash after I disabled it in Firefox.  It crashed today, so I  just disabled the following in my Chrome browser to see if it will help:

     

    from the chrome://flags/ page, disabled:

     

    Override software rendering list

    GPU compositing on all pages

    GPU Accelerated SVG Filters

     

    I  also disabled hardware acceleration in Flash Player for Safari, Firefox  & Chrome by following the instructions at:  http://forums.adobe.com/thread/891337

     

    Hopefully I can go longer than 3 months without a crash this time.  I have not applied the kext fix yet and I am running 10.7.5 (Lion)

  • KVDB Calculating status...

    Mavericks doens't fix the problem. And the kextfix isn't working anymore on Mavericks! It even freezes with the kextfix

1 ... 93 94 95 96 97 ... 107 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (56)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.