Skip navigation

Complete installation download of Garageband 11 from App Store won't install

1243 Views 7 Replies Latest reply: Sep 28, 2013 4:54 AM by léonie RSS
strikeforest Calculating status...
Currently Being Moderated
Apr 24, 2012 12:49 AM

I've recently upgrade to Lion OS X 10.7.3 and I then purchased Garageband 11. It downloaded and intalled and then Garageband said i needed to download another 1.6 gb for the COMPLETE installation and began to do so. So I took two hours for that and then it began to install, seemed to complete instillation and then the window just closed. So i went to Garageband and opened it up and the same window popped up telling me the same thing, and it began to download the 1.6 gb ALL OVER AGAIN. So i waited for it to download AGAIN, and then it did the exact same thing.

 

What's happening here? I don't know if it's crashing right before it completes instillation or what. Surely the 1.6 gb worth of the complete instillation still has to be stored SOMEWHERE on my computer. This is very frustrating, someone please help!

 

Processor: 2.4 GHz Intel Core 2 Duo

Memory: 2 GB 667 MHz DDR2 SDRAM

MacBook, Mac OS X (10.7.3)
  • léonie Level 8 Level 8 (46,330 points)

    GarageBand downloads additional instruments and loops. You will find these items in your system library:

    • /Library/Audio/Apple Loops/Apple/
      and
    • /Library/Application Support/GarageBand/Instrument Library/

     

    To browse the system Library bring the Finder forward, and select "Go  -> Go to Folder" from the Finder's  main menu bar, then type in "/Library".

     

    In the window that opens navigate to the "Audio" folder and the "Apllication Support" folder.  Compare, if he folder contents is changing after the download and if you see more loops and instruments than before.

     

    If not, then I'd try to reinstall GarageBand:

    • Quit the AppStore.
    • Move the GarageBand Application to the Trash, but do not empty the Trash.
    • Reopen the AppSTore and sign in again with the same account you used to buy GarageBand. Now you should be able to download GarageBand again and to reinstall it.

     

    Good Luck

    Regards

    Léonie

  • Eduardo Gutierrez De O. Level 1 Level 1 (5 points)

    I came here, finally having found a question exactly like I'm experiencing. Alas, the solutions didn't work.

     

    Every time Garageband tries to open it says it needs to download its loops and instruments. A 1.6GB. No way to skip it or work without them (as I don't need them).

     

    Letting it complete just results in GarageBand quitting at the end, no error, no completion, no nothing. Console.app astonishingly doesn't show anything.

     

    I've tried several times, to see if any stuck. I've tried repairing permissions, even though I'm against doing that by hand. I've tried copying the installer when complete and running it myself through the standard installer, I've tried throwing GB to the trash and redownloading and then reopening. It didn't care if GB was in the trash or not. I've tried removing all files related to GB, without luck.

     

    I'm now pulling my hair. I could live with an error to investigate but it's just "1 hour waiting for download to complete. 10 minutes waiting for install. Garageband closes." and start over. Garageband says it'll resume (and it does) if cut-off short. When it "completes" it starts from scratch so somewhee it's being marked as complete but not complete-complete.

  • léonie Level 8 Level 8 (46,330 points)

    For some posters it worked to create a different administrator user account and to download the loops while signed into this new account.

     

    Corrupted preferences files, fire walls /AV software may be interfering with the completion of the download.

     

    If that does not solve the problem, try mteeps solution here and run the installer from the Terminal:

     

    Re: GarageBand '11 won't download additional loops

     

    If that does not work, uninstall  and trash the preferences, see Dagon's post:

    https://discussions.apple.com/thread/3039094?start=0&tstart=0

  • Eduardo Gutierrez De O. Level 1 Level 1 (5 points)

    Thanks, I have tried all this (I suspect you're the same Leonie with a website with a FAQ for this). The only thing I haven't tried is using a different admin user account, which sounds somewhat ludicrous but it's the only thing in all these threads I hadn't seen so I haven't tried it.

     

    Mteeps suggestion may not work in some specific scenarios (like in mine, where GB has never ever opened as it requires the additional install, a different scenario than the post), since I don't get any updates available at all. Shouldn't be different than installing myself the instruments, which didn't work.

     

    Message was edited by: Eduardo Gutierrez De O.

  • Eduardo Gutierrez De O. Level 1 Level 1 (5 points)

    Oh. Come on!

     

    I've tried with another Admin account. Garageband opened perfectly. Switched back to mine and the thing started downloading all over again the loops. :-|

  • léonie Level 8 Level 8 (46,330 points)

    I've tried with another Admin account. Garageband opened perfectly.

    So your regular user account has a serious problem.

     

    It looks like GarageBand cannot write to your User Library to store the fact, that the library has been updated.

     

    Did you migrate the files in your home folder from a previous system? Then it might be, that you are not the owner of all your files.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.