2 Replies Latest reply: Sep 29, 2013 11:10 AM by BDAqua
Gr1Tutor Level 1 Level 1 (0 points)

I have an iMac version 10.4.11.  Tried to get pogo.com, but am told I need to update my Adobe Flash Player.  When I try to update/upgrade Adobe Flash Player, I'm told my iMac is too old.

 

Likewise when I try to do banking online, I'm told I need to update my Safari Web Browser, but when I try to update, I'm told my computer is too old.

 

Short of buying a new computer, WHAT DO I DO??


iMac, Mac OS X (10.4.11)