Skip navigation

I can't update itunes!

113 Views 1 Reply Latest reply: Sep 30, 2013 8:31 PM by Snidertech RSS
Snidertech Calculating status...
Currently Being Moderated
Sep 30, 2013 8:17 PM

I'm trying to update itunes to 11.1 so my iPhone 4S will sync to it but it just doesn't wont to work..

If I open itunes and try to update it failed after 5 or 10mb it says something about invalid signature I've tryed both just downloading as well as downloading and installing. I tried to download it from apple.com but when I run the .exe it says it's not a win32 then If I try to run it from the download it gets 'interrupted' also tho was using interne explorer I tried to use safari but I couldn't even start the download just kept saying thanks for downloading or what ever um I also turned off pop up blocker and the safewall or something in advanced settings can some one help ASAP?!??!

iPhone 4S, iOS 7, Toshiba Windows 7

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.