1 Reply Latest reply: Oct 2, 2013 8:45 PM by MarkH356
MarkH356 Level 1 Level 1 (30 points)

I wonder if anyone might be able to help me with a problem trying to USB tether my iPhone 4 to my MacBook Pro.

The iPhone is running iOS 5.1 and the MacBook Pro is running OSX 10.6.8.

 

USB tethering used to work fine when i last used it a year ago and I have not updated any software on the iPhone or MacBook Pro since. I stopped udating iOS at 5.1 after that update wiped my iPhone and iPad's APN settings.

 

When I turn Personal Hotspot on and connect to the MacBook Pro via the USB cable, nothing at all happens as far as network connections go. In the Network Prefernces there isn't any iPhone network service to select (no USB Ethernet). All that is present is AirPort, Ethernet and Firewire.

 

WiFi and Bluetooth tethering still work, but not USB. The reason for wanting to use the cable is my Outlook Exchange email will not connect via the WiFi or Bluetooth tethering, but used to connect with the USB connection.

 

Unsuccessful steps that I attempted to resolve the problem;

 

1. deleted the AppleUSBEthernetHost.kext file, rebooted the computer (to make sure it wasn't still in memory) and used the Kext Utility to reinstall version 2.3.6 of the driver, rebooted both iPhone and MacBook Pro = no effect, no USB tethering possible

 

2. deleted the AppleUSBEthernetHost.kext file, rebooted computer and then ran the iTunes 10.7 installer and rebooted = no effect, still no USB tethering possible. Will not upgrade to iTunes 11 as I detest the new interface.

 

3. tried to tether the iPhone on my daughter's MacBook Air which is running Lion = no effect, still can't USB tethering

 

4. also tried to USB tether another iPhone to my MacBook Pro and to the MacBook Air = ne effect, couldn't USB tether either iPhone to either computer

 

Since 2 different OSX versions on 2 different computers have the same problem, I thought the iPhone was the common problematic denomenator. However, having tried 2 different iPhones (both iPhone 4) on 2 different computers running 2 different OSX versions means I am at a total loss to figure out how to restore this function. 

 

Does anyone have an iPhone 4 that they are able to tether to an OSX computer ?


iPhone 4, iOS 5.1
  • 1. Re: USB tethering not working
    MarkH356 Level 1 Level 1 (30 points)

    After 4 hours of searching and downloading different versions of AppleUSBEthernetHost.kext and installing/deleting I have found one that works on OSX 10.6.8.

     

    AppleUSBEthernetHost.kext Version 2.3.6

    - doesn't work at all

     

    AppleUSBEthernetHost.kext Version 2.3.0

    - works if the file size is 225 KB on disk (189,646 bytes)

    - does not work if the file size is 184 KB on disk (180,760 bytes)