Skip navigation

Aperture error message

291 Views 8 Replies Latest reply: Oct 3, 2013 9:46 AM by léonie RSS
Fulmar1 Calculating status...
Currently Being Moderated
Oct 3, 2013 4:30 AM

Having just downloaded Aperture and begun working with the library I get the following error message - 'There was an error opening the database for the library “/Users/ianbell/Pictures/Aperture Library.aplibrary”.' I've tried a re-download. Any ideas?

MacBook Pro, OS X Mountain Lion (10.8.5)
  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Oct 3, 2013 4:57 AM (in response to Fulmar1)

    Having just downloaded Aperture

    Is that the first time you are using Aperture, or are you using an older Aperture library? If it is an older library, how has it been created?

     

    If it is a new installation - is there a crash log with the error message? If yes, could you please paste the first 50 lines of the report here?

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Oct 3, 2013 5:53 AM (in response to Fulmar1)

    Usually the crash log will be shown directly in the panel with the error message - look for a text starting  like this:

     

    Process:         Aperture [1439]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4.5 (3.4.5)

    Build Info:      Aperture-320090000000000~1

    Code Type:       X86-64 (Native)

    ....... etc.

     

    The Console.app (in Applications > Utilities) will show you all log files stored on your computer.

    Press "Show log list" in the Toolbar, and then look for diagnostic reports in the side bar.

  • Frank Caggiano Level 7 Level 7 (22,820 points)
    Currently Being Moderated
    Oct 3, 2013 8:38 AM (in response to Fulmar1)

    Sounds like you have a possible library or permissions problem.

     

    You wrote that this is a new installation, have you imported anything into the Aperture library yet?

     

    Two things you can try, one start Aperture while holding down the command and option keys. This will bring up the library first aid window. Run the permission repair after it is done if the library still doesn't open start Aperture the same way again (command and option keys) and run the library repair.

     

    You could also try making a new library. Start Aperture while holding down the option key only. This will bring up the library selector window. Select the option to make a new library and see if Aperture will run with that.

     

    regards

  • Frank Caggiano Level 7 Level 7 (22,820 points)
    Currently Being Moderated
    Oct 3, 2013 9:07 AM (in response to Fulmar1)

    Glad it helped.

     

    Just for my own curiosity did one of the repairs fix it or did you make a new library?

  • léonie Level 8 Level 8 (46,485 points)
    Currently Being Moderated
    Oct 3, 2013 9:46 AM (in response to Fulmar1)

    Great you could solve is with Frank's help I hope you will enjoy Aperture.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.