Skip navigation

imovie project on Usb - cant get it to play!!

2875 Views 5 Replies Latest reply: Oct 7, 2013 8:18 AM by ian172 RSS
Starburst_90 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 4, 2013 3:30 AM

I have finalized my imovie project and have moved it onto a USB that i had to change into MAC format to be able to fit it on.


After waiting 2 hours for it to transfer over, i tried to play it on every mac we have but once its opened through imovie, there is nothing to play. Uderneath the USB hardrive selection, there is no movie. I have no idea how this has happened and its still noticed as being on my USB so i dont know how to go about it.


Any help would be much appreciated, i have been at this for 2 weeks now. I only wanted a simple movie of my 1 year old son to keep as a back up.



MacBook Air (13-inch Mid 2012)
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Oct 4, 2013 10:25 AM (in response to Starburst_90)

    What file are you trying to move to your USB drive?


    Are you using the Share menu to create a movie file that will play independently of iMovie?


    Details here:




  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Oct 4, 2013 2:55 PM (in response to Starburst_90)

    Starburst_90 wrote:


    Was this where i went wrong?




    Finalizing prepares (renders) your project so it can be output (Shared).


    Sharing, as described in the article I linked to. creates the kind of file that you're looking for.


    Generally, you don't want to touch the files in the iMovie Events and iMovie Projects folder. So if you moved a file out of the iMovie Projects folder, you should return it before you try Sharing.


    You can also Share a project without first Finalizing it as the process of Sharing also first renders your project.



  • Bengt Wärleby Level 6 Level 6 (18,920 points)
    Currently Being Moderated
    Oct 4, 2013 11:07 PM (in response to Starburst_90)



    As Matthew writes in full.


    I do

    - USE an USB-Memory - DOS formatted (as my TV or Playstation doesn't take anything else)


    - Share to QuickTime (or Export to QuickTime) and as .mpeg4 AND HERE I SELECT as H.264


    This plays well for me.


    Yours Bengt W

  • ian172 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 7, 2013 8:18 AM (in response to Starburst_90)

    Did this work starburst,have you got the imovie playing on a usb?

    I'm having problems to,i can't get my finished imovie files to play on my sansdisk usb.

    The usb plays every other file under the sun,but once they have been in imovie i can't get them to play. 

    Before i had a mac i used sony vegas on my pc and had no problem transferring them over to a usb and playing them.

    Now because HD files are so big after imovie renders them i usually transfer them to my ipad and stream them using apple tv to a tv set,but has the files are so large it must take 30 odd minutes to even begin to start to play a largish movie.

    So i bought a sansdisk usb to put the finished movies onto,plug it into the blu ray and hopefully play,but if anything has been made in imovie,it just won't play them,weird.

    Sometimes in the usb menu it will show the name of the file i want to play but when asked to play,nothing happens.


    Please can anyone help its doing my head in,even resorted to uploading them to you tube and then streaming over the net,but the quality is poor.




More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.