Skip navigation

TV show won't play on iTunes- black screen

28060 Views 20 Replies Latest reply: Feb 14, 2014 5:26 AM by Saltycturtle RSS
  • 25Bravo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2013 6:31 PM (in response to McBren)

    Trying to open it in Quicktime did not work for me.  In fact, this issue seemed to stump Apple support as well.  I was on the phone with them for a little over two hours trying to solve this problem with no result.  We left off with the guy wanting me to back up my files and reinstall my OS which I haven't done yet but I may have to try.  I'm litterally out of options. 

     

    - I tried playing the files in both Quicktime and VLC

    - I've reinstalled iTunes and Quicktime

    - I even went so far as to buy Quicktime Pro thinking that would solve my issue

    - I deleted the files and re-downloaded them

     

    I tried a dozen other things with Apple support all which did nothing.  Someone has GOT to have an idea I haven't tried yet.

  • aloonz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2013 10:30 PM (in response to teacher_k)

    I had the same problem on both my mac and windows laptop, its a simple solution that might sound really stupid. Close everything opened on your laptop. Shut down the laptop safely (dont click on the power button too long), open it again and it should play perfectly. I know it sounds like it wont work, but it did for me on both my mac and windows. I believe it has something with the add-ons not loading properly when opening, the only real way to reopen them is for a full restart. I prefer the shut down wait 5 minutes and open it back up.

    Good Luck!!

  • Borne2Run Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2013 8:46 PM (in response to aloonz)

    Easy solution for everyone else:

     

    Stems from the helper add-ons not loading properly. To fix:

     

    Windows:

    Close itunes

    Open up the Command Line/Command Prompt from the Windows Button (search for 'Command Prompt')

     

    Type in: TASKKILL /IM ITunesHelper.exe -f

    ---- This ends the ituneshelper process. It will restart when you reload itunes.

     

    Then, open itunes.

    Run your tvshow or movie. It now works.

  • brettjw Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2014 10:49 AM (in response to Borne2Run)

    That did it - thanks for the post and the help.

  • Wolf66 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 10, 2014 5:44 PM (in response to Borne2Run)

    This worked perfectly for me, too.  Thank you for the help.

  • Saltycturtle Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 14, 2014 5:26 AM (in response to Borne2Run)

    Same problem here - I purchased two episodes, one of which did not play while the other was fine. QuickTime up to date, Taskkill attempted but still no luck :(

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.