Skip navigation

iTunes 11.1 OS X 10.8.5 - Permission errors after installing

13489 Views 79 Replies Latest reply: Feb 28, 2014 3:20 PM by DavidMac RSS Branched to a new discussion.
  • KGeez00 Level 1 Level 1 (0 points)

    I don't know if this is genuine request, or just a facetious attempt to try and stir? However, I shall treat it as a genuine question.

     

    When I went through this laborious process, I described before, I made sure that every step of the way that a disk repair and permissions was done. (To me this is a normal check on each step of the process).

     

    What is more, I used the OS X Recovery, which you may find in on helpful Apple website page. Here is the link if you need it: http://www.apple.com/osx/recovery/

     

    Before installing a fresh downloaded iTunes DMG and making sure that every trace of iTunes had been removed by using a reliable "Un-install" application that anyone can get on the Apple Apps Store: I made sure that all the all the permissions were correct. There were no permissions that needed to be repaired. There was no long list of repairs, it was totally clean!

     

    After a "Restart" I downloaded a fresh iTunes, and then doing another permissions check using the OS X Recovery. Unfortunately, the long list of permissions that would not be repaired, were there again with the new iTunes download.

     

    As I love my music, I took the "assumed" notion that Apple would soon correct this with an update, and reloaded my iTunes library which should only contain MP3 and MP4 files with a few book and iTunes Movies files thrown in. These should not import any incorrect permissions in to a library that previously was functioning without errors!

     

    After reinstating the library, which remains housed on as separate hard drive (Western Digital FW 1TB), (as it is too large to be filed on my Mac hard drive, as I need all the space for my graphic work), iTunes works well, but the permissions still remain uncorrected.

     

    As for the Clean Install is concerned, a friend of mine who is a little more of an iTunes fanatic than I am, took the drastic decision to do a complete clean install and attempt to go back to iTunes 10.7. (He couldn't do it and had to settle for iTunes 11.1 again). Unfortunately, this did not prove to be a remedy. On the strength of this I decided not to do the same, leave the permissions un-repaired and wait for Mac to post an update to repair iTunes.

     

    At this time my iTunes seems to be running well and the incorrect permissions do not seem to be a problem.

  • islane Level 1 Level 1 (30 points)

    Somebody recently watched jOBS !

  • KGeez00 Level 1 Level 1 (0 points)

    That might be a bit to "area specific", please explain, sounds interesting?

  • EgonX Level 1 Level 1 (0 points)

    Try resetting your PRAM. I had this happening as well, but it wasn't just iTunes locking up and resetting the PRAM seems to have made a dent in the issue.

     

    Resetting the PRAM

    http://support.apple.com/kb/HT1379

  • peteperro Calculating status...

    Has anyone tried this?

     

    http://blog.chron.com/techblog/2011/09/want-to-really-repair-permissions-on-your -mac-try-this/

     

     

    1. Restart Lion, and before you hear the chime, hold down the Command and R keys.

    2. You’ll be at the Repair Utilities screen. Click the Utilities item in the Menu Bar, then click Terminal.

    3. In the Terminal window, type resetpassword and hit Return.

    4. The password reset utility window launches, but you’re not going to reset the password. Instead, click on icon for your Mac’s hard drive at the top. From the dropdown below it, select the user account where you’re having issues.

    5. At the bottom of the window, you’ll see an area labeled Reset Home Directory Permissions and ACLs. Click the Reset button there.

  • killhippie Level 3 Level 3 (580 points)

    These permission don't actually need repairing, in fact you very rarely have to run 'repair permissions' these days. Obviously you can before major upgrades and OS updates. iTunes 11.1 and iTunes 11.1.1 both changed alot of things, and the DU tool has not been updated by iTunes to reflect the changes. I would imagine they wont now with Maverick around the corner, but who knows. In the mean time there is no need to keep trying to get rid of them. Yes its untidy and Apple should know better but years back you always ended up with permissions you could not fix, its not a big deal. http://support.apple.com/kb/ts1448

  • cisit Level 1 Level 1 (0 points)

    On Mountain Lion, when I restart with Command R, it will launch internet recovery; so I stopped it as I don't want to re install Mountain

  • chandanankush Calculating status...

    i am facing bigger trouble after updating iTunes, OS is not launching each time i click on power button it opnes OSX utility page. I have tried to repair disk permission but after repair complete it again opens same utility page.

    Please help me i don't have backup to restore...

  • MoonRunner Calculating status...

    If Disk Utility can’t repair your HD you may need a better program like DiskWarrier. It will not repair the iTunes preferences as they cannot be repaired but it will repair your HD so that you can start normally. Then you can use iTunes as it is, the bad permissions don’t interfere or you can replace the updated version of iTunes with the older one, 11.0.4 from a backup you should have. Remember, as outlined earlier in this thread, you will also need to replace your iTunes library with the older version.

  • JCC123 Level 1 Level 1 (30 points)

    After updating to Mavericks and the newest iTunes, the permissions seem to have been fixed! I'm no longer getting the long list of iTunes permission errors.

  • carboncanyon Level 1 Level 1 (15 points)

    On my 2012 Mac Mini Server, I have that same list of bad permissions and many of my songs in iTunes are now misdirecting. When I go to Get Info, instead of showing the .mp3 (or whatever audio file) in its folder, it'll show an email attachment or a jpg or a final draft document, etc. Additionally, every new file added to my library creates its own file outside of the music folder and my MacBook (running Leopard), which had previously had no problem, now refuses to import half of the movies I try to bring into its iTunes library as it does not recognize them as video files. My media library of 12,000+ songs, 500 tv episodes and 400 movies is stored on a 4 TB external drive. Airplay continues to work fine, with the system apparently just skipping the songs it has mistaken for non-audio files when on shuffle, and my iPhone 4s and iPad 2 continue to sync and update and backup over wifi. However, my 5s which was not set up to sync over wifi is no longer even noticed by iTunes when I plug it in, meaning I can no longer sync, backup or update it. At the end of my last 6 hour exercise in futility with 7 Apple Care support techs who kept passing me back and forth between departments, I was left to reset the ACLs which I let run for about 2 hours before giving up and accepting that the whole thing was just frozen. Like a previous poster, my back-up of this computer died earlier in the fall and I had intended to repurpose one the 2 TB drives my media library had previously been stored on before this situation arose. Have any of the rest of you experienced the file misdirection issue as well?

  • jklmnk Level 1 Level 1 (0 points)

    I was wondering if this has been fixed yet?
    I can't even open Itunes without it slowing everything to a crawl, I had to relaunch everything and verify permissions, its been running for 40 mins now still going? everything says permissions differ on itunes...... I can't barely get my imac to function at this point !

    HELP

  • Chris CA Level 9 Level 9 (73,410 points)

    jklmnk wrote:

     

    I was wondering if this has been fixed yet?

    Yes.

  • MoonRunner Level 1 Level 1 (0 points)

    I don't know about your other problems but the permission problem has not been fixed. It is not iTunes but ARDAgent 3.7.1 and is the latest update available. To solve the permission problemfor now you need to revert to ARDAgent 3.7 and then not update Remote Desktop Client Update 3.7.1 as suggested by Software Update. Look at earlier posts, it will explain everything. Other problems in iTunes have been fixed.

  • Chacapamac Level 1 Level 1 (0 points)

    I’m with Mac from the SE era and I never see something crappy like that.

    This update render Disk Utilies meaningless.

    The quality of the UI and maybe the software itself is declining.

     

    With all the problems I see here, you want me to update to Maverick, are you serious?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.