2 Replies Latest reply: Oct 7, 2013 7:04 AM by BobTheFisherman
jdevillo Level 1 Level 1 (0 points)

I am using an HP Windows 7 laptop, and just downloaded Safari 5.1.7. I went to an Adobe Flash-required website that I have had no problem going on to using IE and Chrome. I was surprised to find that it said I needed to download the latest version of Flash Player. I deleted Flash and then reinstalled. (v. 11) I went back to the website after installing, yet it still won't work... Can someone help?