2 Replies Latest reply: Oct 9, 2013 3:55 PM by catwoman001
catwoman001 Level 1 Level 1 (0 points)

I am having problems getting my Ipod classic to sync with Itunes.  Is 2.0.4 the current firmware for me to use with my Ipod using Windows 8?  If not, please let me know what firmware I need to use.  Thank you.


iPod classic, Windows 8