Skip navigation

is not registered with iMessage.

35057 Views 31 Replies Latest reply: Mar 27, 2014 11:06 AM by P Willis RSS
  • sicklypig Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2013 3:25 PM (in response to detour12)

    I'm having the same problem on both my brand new Iphone 5 and new macbook pro and its kinda messing my day up because i dont live in cell serviece, someonw help.

  • Kurty66 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2013 3:53 PM (in response to detour12)

    This happened to me the moment I updated my iPhone to 6.1.3. Hopefully this gets fixed soon. Is there a way I can downgrade my IOS to before I updated?

  • Sibailey1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2013 5:04 PM (in response to Kurty66)

    Whats going on ?? I have just started getting this problem. I have a new mac book pro, and an iphone 4s. my sister has a 4s too. I regularly send her pictures from my macbook to her iphone. just tried it now and am getting the "not registered with imessage" she is and I've messaged her many times before ?? does anyone have any helpful solutions to this problem ??

  • Sibailey1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2013 5:08 PM (in response to Sibailey1)

    Further to my last,

    This issue for me seems to have sorted its self out, with me doing nothing. Hope everyone else's problems ge sorted but I'd still like to know why this happens and how to sort it if it happens again if anyone has any knowledge.

    Regards

  • djViper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 13, 2013 10:11 AM (in response to detour12)

    I'm having the same problem.. I can iMessage my sister in law from my iPhone4s yet I'm getting the red error message on my iPad 3rd generation. I've run through some of my contacts on the iPad and I'm getting the iMessage on all these.. It's just her that's causing issues... !!!!

  • Howard Brazee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 20, 2013 1:28 PM (in response to detour12)

    I can text my grandson with my iPhone, but not with my iPad.   They both use the same contacts and e-mail address.

  • Howard Brazee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 22, 2013 5:58 AM (in response to Howard Brazee)

    I'm wondering if one device has to be a phone.

     

    I can send a message from my iPhone to his iPod, but I can't send a message from my iMac or my iPad to his iPod.

     

    The contacts are the same with all.

  • lllaass Level 10 Level 10 (135,140 points)
    Currently Being Moderated
    Apr 22, 2013 6:08 AM (in response to Howard Brazee)

    It could be because of the "number/email" address you are using to message.You can't send a Message to yourself. Is it that when you send a Message from the iPod/Mac the "number/email " you are Messaging to is is only listed in the iPod/Mac in the list in Send and Receive? You can go there and either delete or uncheck the number/email address so yo are not trying to Message yourself.

  • Howard Brazee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 22, 2013 7:11 AM (in response to lllaass)

    I'm not understanding this.

     

    But it seems that such a setting would apply the same with the messages I sent my granddaughters as it did my grandsons.

  • lllaass Level 10 Level 10 (135,140 points)
    Currently Being Moderated
    Apr 22, 2013 7:21 AM (in response to Howard Brazee)

    It would depend upon what number/email address you are Messaging and what number/email address are listed in Settings>Messages>Send and receive on each device.

  • Howard Brazee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 22, 2013 7:22 AM (in response to Howard Brazee)

    Entering the name of that grandson , I see the blue drop indicating that that e-mail address accepts messges if I'm sending it from my iPhone.    Or if I send to his brother or cousins, I get it from either my iPhone or my iPad.

     

    But when I enter his name on my iPad, I don't get that symbol.

  • Howard Brazee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 22, 2013 7:39 AM (in response to lllaass)

    Ahh, I found a difference.    My phone has two names in Send and Receive, my e-mail and my wife's Mac e-mail.

     

    So I added her e-mail here, and entered he password.   Then it asked for my AppleID password and I entered it.   Then I switched back to iMessage and it still failed.   So I returned to Settings/Message/Send & Receive and didn't see her e-mail, so I tried adding it again, but got an error in verifying it because it was already in use.   So I removed it and tried again, with the same result.

  • TimeDaniels Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2013 6:56 AM (in response to detour12)

    I dont know if this will work for everyone but i found a solution that worked for me

    http://www.igeeksblog.com/fix-imessage-waiting-for-activation/

    well at least it started allowing me to select my phone number in imessage on my phone, still troubleshooting so phone number will show up on imessage on ipad and my macbook.

     

    Step 1: Turn off iMessage (and FaceTime)

    Step 2: Turn on the Airplane mode. Wifi will be turned OFF automatically.

    Step 3: Turn ON Wifi

    Step 4: Head back to Messages and turn ON iMessage

    Step 5: You’ll be prompted for your Apple ID if you haven’t added it yet. (else, you don’t get any notification)

    Step 6: Now, head back to Settings and turn OFF Airplane mode.

    Step 7: Mostly, you’ll be shown a notification that says ‘Your carrier may charge for SMS’ – Tap on OK

    Step 8: If not, go to Messages, turn OFF iMessage and then turn it ON again.

    Step 9: In a short while, iMessage should get activated.

    Step 10: You’ll see a greyed out number and an email ID. A little later, the number should be checked and that’s it.

    (This worked for us, seriously.)

  • netsoup Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 7:41 PM (in response to TimeDaniels)

    I just got hit by this bug, on the Mac.

    I am having errors messaging a known and constant imessage contact, and can't even message myself.

    it says my phone number is not registered with imessage though my phone is how i got started with imessage to begin with.

    I think it is a definate bug since I can't even message myself now from my mac, and I've messaged myself just fine plenty of times, as well as my friend who is now blocked too.  from the mac end it just errors out sending to my friend and sending to myself it actually says my phone number is not registered with imessage though it is.

    weird.  I tried signing out and back in on my mac and no difference so far.

  • netsoup Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 7:49 PM (in response to netsoup)

    Well, a little weirdness to add.

    I plugged in my Mac to a power supply, and now I can send imessages to know good imessage contacts.

    I still can't send to myself, getting the error saying my phone number is not registered, though my phone is surely set up to send and receive imessages from my number, but I was only testing myself to troubleshoot.

    At least I can send to other contacts from my mac, and it started working as soon as I plugged into power...

    I am up to date with mountain lion as of right now.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.