Skip navigation

Magic Mouse keeps disconnecting from bluetooth

146719 Views 180 Replies Latest reply: Mar 11, 2014 6:25 AM by Clayton Colwell RSS Branched to a new discussion.
  • Mactoyz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 10:54 AM (in response to Lourufmom)

    I have two iMacs that had the same problem. My work Mac was so bad, I was using a wired mouse for a while. I spent a lot of time with Apple support and we finally zapped the PRAM and everything began to work fine. I then did the same thing on my home iMac and that fixed the problem. That was over a year ago and no reoccurance.

     

    I have pretty much the same apps on both Macs. I can't say that I have bought a lot of apps through the App Store, but I have bought some. I do have a variety of USB devices connected to both.

     

    I have never used anything but Rayovac Alkaline batteries.

     

    Mystery to me why this trouble doesn't go away for others.

  • DB1@mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 12:44 PM (in response to Mactoyz)

    Mactoyz, in an unhelpful way you are turning a deliberately blinded eye to most people's clear, observable findings and ridiculing the real-life solution experienced and offered here to others, many times.

     

    Like others, I have reset the PRAM and other 'fixes' as suggested. These processes made absolutely no difference to the lack of connection: absolutely NO difference.

    Like many others, I have checked the fit of the batteries in the housing and I can plainly see that this is one poor design of battery housing. To remedy it, I have adjusted the fit of the batteries to ensure that they
    1) make contact,
    2) maintain contact.
    Standing on one leg or spinning a ball is not involved in any way. Why you infer that, I have no idea.
    What IS usually required is to remove the wrapping & insulation (unfortunately) from the +ve end of the battery so that the terminals can actually make proper physical contact. After that, the mouse works. Simple. Fact. This is the case with every 'Magic Mouse' that I have for every iMAc at work and at home. Simple fact. The fix has been repeated many times, the latest being last week with a colleague's iMac.

     

    There may be other problems that others including you are having, separate to this,and in that case it's great to have the solution to those problems also, but as this lack of connection is a massive, widespread problem for users, please do not deflect people from a real, straightforward solution that will fix most cases - and please do not let Apple off the hook on this mouse design.

  • Mactoyz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2013 7:25 PM (in response to DB1@mac)

    Not trying to be unhelpful. I have had a lot of experiance with the MagicMouse and have owned six of them. I have never had a battery problem, but as indicated previously, I have only used Rayovac Alkaline so if you have used another brand, I cannot speak to that.

     

    I solved my problem and want to make sure that others benefit from that. If that did not fix your problem, please feel free to keep trying the battery solution.

     

    As far as taking Apple "off the hook" for their mouse design, I don't think they are on the hook. Millions of those mice have been sold with a lot of happy users. The fact that some people have had trouble does not mean the design is bad or the unit is defective.

     

    I fully believe that if there were a legitimate problem with the mouse battery contacts, it would already be known to Apple. They monitor these posts and I doubt very much that they would continue to duplicate a design that has shown to be a problem. Everyone makes mistakes and Apple is not exempt from that, but they have very little history showing that their products are poorly designed. I have been a user since 1984 and work in a mixed office. I think their design and product quality is the best in the business.

     

    As far as the "standing on one leg" comment, I am sorry that was my very weak attempt to be humorous. I should not have done that because I realise not everyone thinks this issue is funny.

  • cchonig Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2013 3:31 AM (in response to Dana Spiegel)

    In June I posted this, and it still stands:

     

    My conclusion was that it might be just bad contact.

    I sandpapered both ends of the batteries. Then I scratched with a tiny, sharp flathead screwdriver both contacts inside the mouse: the sprung negative one and the recessed positive one. The mouse worked like a charm and has not failed since. It will likely work for you too, and it works with any batteries...good luck !

  • nnaous Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 18, 2013 5:45 AM (in response to Dana Spiegel)

    It definitely is bad contact, which fails upon a more heavy "knocking" of the MM upon the surface it resides on. I just put two pieces of paper below each battery and I am no longer experiencing the issue I have suffered for months. I originally thought this problem is with my MM only, but it seems I am not alone.

     

    Ugly, but quick and working solution.

  • rdj Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 12, 2013 12:30 PM (in response to nnaous)

    Mine turned out to be bad contacts as well! I used a slim mechanical pencil's eraser to clean the recessed contacts inside the Magic Mouse as well as the spring-loaded ones, and for good measure, "erased" the ends of the batteries as well.

     

    My guess is that the MM is highly voltage-sensitive, and slight soiling on any of the contacts creates just enough resistance to cause these spurious disconnections.

     

    Hope so, anyway!

     

    Thanks to all.

  • evolver33 Calculating status...
    Currently Being Moderated
    Jan 8, 2014 12:58 PM (in response to Qida)

    For me, it's the size of the battery. It seems to make the most sense based on what I've read here about people replacing the MM and also myself trying to stuff paper in the back compartment to seat the batteries more securely.

     

    I never had a problem until I swapped out my lame-o Kodak-branded batteries for EnergizerRecharge rechargeables. The Kodak batteries never gave me a problem. When I switched to the Energizers, the mouse cut out about 20x/day and was consistent with the tapping issue that others have explained. You'd lift the mouse off the desk and then bring it down again, even if it was ever-so-gently, and it would disconnect.

     

    I put the Kodaks back in, and no problems.

     

    Lesson learned!

  • Lourufmom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2014 1:16 PM (in response to evolver33)

    We bought the Apple Magic Mouse rechargeable battery and rarely have a problem now.  I only notice occasional "skating" of the indicator arrow when I'm playing Branium Free Cell 1.0.2.

  • Pedaler Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 8, 2014 5:16 PM (in response to Lourufmom)

    Good luck for 3 months so far on the Apple rechargeable batteries. No apparent mouse disconnects, and I care a lot less about the battery life...

  • Infinite Sinewave Calculating status...

    I was having the same problem with my mouse disconnecting. I have 3 different types of rechargeable batteries AND regular double AAs. ALL of them disconnected. I typed in the problem and found this forum. I went to the mac store to buy their batteries and told them the issue. They DENIED it. They said it works fine with all batteries. I couldn't believe how snobby they were. It seems that Apple has lost its way. They don't listen to the customer. One of the guys told me, why are you using it? I purchased a mac in March of 2013. If I would have known what jerks they are, I'm not sure I would have made the decision to buy a macbook. It's all good now, but these are serious warning signs for the future of this company in my book. Anyhow.. I paid the $29 for their batteries and now it works fine. I noticed that the head of the Apple recheargable batteries are a little wider than the heads of all my other double AAs. This makes me pretty sure that this was an INTENTIONAL design so that we also have to purchase the mac batteries. I don't mind paying more for the magic mouse... just be upfront about it instead of finding cheap ways to trick the customer. After the apple guy told me that my problem didn't exist, I loaded up the forums... and opened it up on all the macs in the store. Then he pointed at the date... (I found one from 2011).. and he told me that the issue had been resolved. What a load of crap.

  • DCStephens Calculating status...

    I was having this same problem and it was progressively getting worse until I wrapped my batteries with a folded sticky note to make them fit more snugly in the battery compartment. I haven't had a problem since.

  • cchonig Level 1 Level 1 (0 points)

    I posted this  in June and it still stands:

     

    It is just bad contact.

    I sandpapered both ends of the batteries. Then I scratched with a tiny, sharp flathead screwdriver both contacts inside the mouse: the sprung negative one and the recessed positive one. The mouse worked like a charm and has not failed since. It will likely work for you too, and it works with any batteries and any operating system...good luck !

  • pete98 Calculating status...
    Currently Being Moderated
    Feb 12, 2014 7:04 AM (in response to rdj)

    I had a problem which also suggests the MM is voltage sensitive. About 4 months after purchase the mouse had been working fine on the supplied batteries. I got an onscreen warning that batteries were low, and put in a pair of Duracells from a previously unopened pack. The mouse kept cutting out - disconnecting and no green light. I tried another pair of batteries from the same pack, and had the same problem. I then contacted Apple Support who sent out a new mouse the next day. It came without batteries so I put in the same Duracells I had been trying on the old mouse - had exactly the same intermittentent disconnection. At which point the penny dropped and I tried a pair of Duracells from a newer unopened pack which I had just bought the week before. Both old and new mice worked fine.

     

    I returned the new mouse to Apple, and two weeks on the old mouse continues to work fine on the newer batteries. I checked voltages and the batteries from the older pack gave 1.47 volts, and those from the newer pack 1.58 volts.

  • ratgurrl Calculating status...
    Currently Being Moderated
    Mar 10, 2014 7:39 AM (in response to Geestig)

    I used a business card. Folded it in half, trimmed the edge, stuck the folded edge between the batteries, then folded the ends on top. Put the cover back on and - Voilà! - No more disconnects.

  • annjon2 Calculating status...
    Currently Being Moderated
    Mar 10, 2014 9:09 AM (in response to Nick Radonic)

    Unfortunatly since Steve Jobs...we're in the windows world!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.