Skip navigation

Mac OS X Lion WiFi issues

114647 Views 262 Replies Latest reply: Oct 29, 2013 7:15 AM by chirodoody RSS
  • Dagge3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 4, 2012 5:12 AM (in response to Dagge3)

    I found a solution that is working for me (at least for the time being).

     

    My problem was, after running Apple Hardware Test, that WiFi stopped working and the WiFi icon in the menubar reported "No Hardware Installed".

     

    After a number of restarts and trying some of the tips in this thread, the menubar icon still showed No Hardware Installed and the Network Pane in System Preferences display a button saying Turn WiFi On. Pressing the button does not change anything - wifi still dead.

     

    I was tipped to take the MacBook Pro to an Apple sevice center.

     

    Before doing that I decide to run Apple Hardware Test once again to see how it would report the WiFi error and possibly get some more information about the error.  To my surprise AHT did not report any error with the WiFi.

     

    I rebooted my Mac and to my surprise the WiFi menu (in menu bar) showed 'Turn On WiFI'. I clicked it and WiFi started working again. And has continued to work for 24 hours.

     

    So for me it seems that Apple Hardware Test has toggled the WiFi firmware/hardware.

     

    Anyone with the problem that WiFi reports "No Hardware Installed" could try to run Apple Hardware Test.

     

    Good luck.

  • OscarBCN Calculating status...
    Currently Being Moderated
    Sep 5, 2012 9:07 AM (in response to Ethanace)

    Hi, here another one which had a lot of problems with the wifi and, for now, they have been solved.

     

    My environnment: Two imacs working with Lion OS. Mine was previously with Snow Leopard, then with no wifi problems. The newest imac with Lion always provoke problems. I was so stupid to change my OS to Lion. Result: Both computers working badly. For me it is clear that is a software gap in the new OS. I was using the same computer with the same router with no problems. Changed the OS and voilà!

     

    I have tested almost all the solutions that you indicated in here with no success...

     

    Until I tried this (hope it works for you):

     

    1. Click the little wifi image at the top of the screen or go to apple/preferences/net

    2. Select "advanced"

    3. In the window "TCP/IP", in IPv6, select "only local" (sorry but my menus are in spanish, so I am providing an improvised translation into english)

    4. Go to your router menus (write 192.168.1.1 in your browser) and, in security, select

    WPA PSK/WPA-PSK2

    5. In your routers menu, search for the channel that is using the router and select "13". Don't let it to change automatically, be sure that the router uses always the same channel.

     

    And it works for me. Don't ask me why. Perhaps it is one of the changes or the sum of all. I don't know. But I do know that yesterday my computer was desconnecting from the wifi every other minute and, since the changes, BOTH computers connect to internet flawlessly. And I have been using them for hours and hours.

     

    Hope it works also for you.

     

    Cheers!

  • fwhofsteenge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2012 3:59 PM (in response to Ethanace)

    For a while I thought Ethanace was right. I hooked up a different router/modem, upgraded to Mountain Lion, and all my problems were gone ... until about a week ago. The old problem gradually sneeked in again: my 27" mid 2011 iMac started dropping the WiFi connection like it did some time ago. And now the problem is back like it never went. I get very tired of this issue. Everybody else hooks up to my WiFi, even old PC notebooks, except my iMac. I am going to revert to ethernet again. Disappointing. Now let's see if I can post this without having to switch Wifi off and then on again.

    Anyone else with the same experience?

  • Cattus Thraex Level 4 Level 4 (1,715 points)
    Currently Being Moderated
    Nov 6, 2012 9:51 PM (in response to fwhofsteenge)

    You must identify and narrow down the reason: if this worked, then did not work, something happened, i.e. something was changed/added to the initial settings. Or the device has a problem.

  • TBoon Calculating status...
    Currently Being Moderated
    Oct 14, 2013 12:41 PM (in response to fwhofsteenge)

    Hello,

     

    I recently bought myself a new MBP Retina 15''  with Mountain Lion and am facing this very annoying behaviour since the beginning.

     

    I was able to bypass the problem by opening the network preferences, deactivating the wifi, on the tcpip tab changing 'using dhcp' to 'using dhcp with manual address', typing in 192.168.1.8 (or similar), press ok, press apply, turn wifi on, wait until failure connecting, turn off wifi, advanced tab, on the tcpip tab changing 'using dhcp with manual address' back to 'using dhcp', press ok, press apply, turn on wifi and for me this always works. Very annoying doing this 20 x a day.

    Yesterday, I upgraded my wife's older MBP 14'' to mountain lion and ... yes, she has the same issue of (re)connecting to wifi.

     

    This confirms that there is an severe software bug in the new OS.

     

    What I'm most sad about is that there doesn't seem to be any ownership from Apple to communicate their acceptance of the bug and eventually a solution which I would appreciate sincerely.

     

    Tom

  • Cattus Thraex Level 4 Level 4 (1,715 points)
    Currently Being Moderated
    Oct 14, 2013 1:02 PM (in response to TBoon)

    Tell us which version of ML are you using, there are 5 so far, from 10.8.0 to 10.8.5, a recent update. If you are with 10.8.0, you should update to last v., 10.8.5. There were indeed some problems with wifi connectivity if non-Apple routers are there. btw, what wifi router do you use?

  • chirodoody Calculating status...
    Currently Being Moderated
    Oct 29, 2013 7:15 AM (in response to fwhofsteenge)

    Yes, having the same problem with my macbook pro.

    All software up to date, but wifi is often off when i switch on laptop, and will not switch on.

    Very annoying...

1 ... 14 15 16 17 18 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.