5 Replies Latest reply: Oct 15, 2013 8:37 AM by randers4
DJ Rotherham Level 1 Level 1 (0 points)

All of a sudden I find I can't connect to iCloud. My smtp settings seem right, but my Incoming Mail Server is greyed out and can't be changed. Any ideas?


iMac, iOS 7.0.2
  • 1. Re: Connecting to iCloud
    randers4 Level 9 Level 9 (57,260 points)

    If you are using OS X 10.7.2 or higher, go to System Preferences>iCloud uncheck Mail, restart your Mac, then go back and check Mail again.  (This removes, then adds back you iCloud email account.)

  • 2. Re: Connecting to iCloud
    DJ Rotherham Level 1 Level 1 (0 points)

    Thank you, but unfortunately that didn't work - probably my inexperience. I got a message saying "iCloud Mail couldn't be enabled from the iCloud Preference Pane (in System Preferences). Open Mail and add your iCloud accoiunt from Mail Preferences.

    I tried, but iCloud has gone altogether from Mail Preferences.

  • 3. Re: Connecting to iCloud
    randers4 Level 9 Level 9 (57,260 points)

    Try going to System Preferences>iCloud, click Sign Out, choose Delete at all of the prompts, restart your Mac, then sign back in.  (This only temporarily deletes the iCloud data from your Mac but not from iCloud.  Your data will reappear when you sign back in after a brief delay as it redownloads.)  Then try checking Mail again.

  • 4. Re: Connecting to iCloud
    DJ Rotherham Level 1 Level 1 (0 points)

    Thank you very much indeed. I think it is great that someone I don't even know is kind enough to help me like this. Thank you so much. David

  • 5. Re: Connecting to iCloud
    randers4 Level 9 Level 9 (57,260 points)

    You're most welcome.  Glad I could help.