1 Reply Latest reply: Oct 15, 2013 2:52 AM by Klaus1
juwu Level 1 Level 1 (0 points)

I have an old iMAC that runs on 10.5.8. After having trouble with slow internetsurfing, I'm thinking of updating to snowleopard (10.6), which I understand shall make the computer to be faster. The system requirement is not clear on apple store where they state that the upgrade require a "MAC Intel processor". My iMAC G5 has a PowerPC G5 (3.0) processor with 1.8GHz speed - is that an intelprocessor or not and can I run Leopard on my computer? What happens with my office and Adobe programs on my computer - will they stop running?

Sincerely,

Johan


iMac, iOS 5, OS 10.5.8