Skip navigation

My 2008 Macbook won't boot.

255 Views 1 Reply Latest reply: Oct 17, 2013 3:02 PM by braden85 RSS
KittyWhy Calculating status...
Currently Being Moderated
Oct 15, 2013 6:50 AM

When I turn it on, it gets to the grey screen (no apple logo) and stays there for a long time, after which I get a black screen which says 'partition not found. grub rescue >'

 

I've previously used bootcap on my mac, setting aside ~150GB of space. However, I realised I wasn't using windows that much and wanted to free up space for my mac by deleting the bootcamp partition. When I tried using Disk Utility (both MacOS and SnowLeopard installation disc) I got the same error: "Mediakit: Partition not found". Decided to try to get around it using ubuntu's disk utility and deleted the bootcamp partition as well as one of the ext4 partitions (it took up a fair bit of space so I decided to delete it). Did not touch my Macintosh HD partition.

 

I then rebooted and realised I could no long boot into my mac. The partition is still there but when I press options at start up I cannot find it/boot it. Is there any way to get around this? Didn't do a backup for about two years so I would be losing all my work. Otherwise, is there any way i can recover my data (using another computer etc).

 

Thanks so much

MacBook, iOS 6.1

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.