Skip navigation

problem autofill function

864 Views 3 Replies Latest reply: Nov 6, 2013 7:01 PM by dinglydell1 RSS
justice92 Calculating status...
Currently Being Moderated
Oct 15, 2013 3:58 AM

I don't understand why the autocomplete function doesn't work with Safari on my macbookpro. Yet in the preferences for Safari AutoFill tab options: Use the information in my address book, and other forms are ticked

 

Thanks.

MacBook Pro
  • Carolyn Samit Level 10 Level 10 (84,200 points)
    Currently Being Moderated
    Oct 15, 2013 6:59 AM (in response to justice92)

    Might be corrupted Safari preferences ...

     

     

    Open a Finder window. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Preferences/com.apple.Safari.plist

     

    Click Go then move the com.apple.Safari.plist file to the trash.

     

    Quit and relaunch Safari to test.

     

     

    If that didn't help, open a Finder window. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Caches/com.apple.Safari/Cache.db

     

    Click Go then move the Cache.db file to the Trash.

     

    Quit and relaunch Safari again.

     

     

    If that didn't help, try troubleshooting extensions and third party plugins.

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

  • Linc Davis Level 10 Level 10 (107,955 points)
    Currently Being Moderated
    Oct 15, 2013 1:55 PM (in response to justice92)

    If you're not running OS X 10.8 or later, substitute "Address Book" for "Contacts" below.

     

    Select your card in Contacts. Then select

      

    Card Make This My Card

      

    from the menu bar.

     

    In Safari, select

      

    Safari Preferences AutoFill AutoFill web forms: Using info from my Contacts card.

  • dinglydell1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2013 7:01 PM (in response to justice92)

    I have tried all the fixes here, but nothing works! Autofill worked perfectly till a few weeks ago, and now doesn't work at all.

     

    Any more help available?

     

    Thanks.

     

    Mac Pro OS 10.8.6

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.