3 Replies Latest reply: Oct 16, 2013 12:13 PM by rccharles
Clayto1332 Level 1 Level 1 (0 points)

I have a G5 and my printer died. Now I have since bought two printers and neither of them are compatible. I am running 10.3 and cannot update my operating system because of my processor. Is there some sort of workaround or list of modern printers I could buy that would be compatible? I refuse to believe a computer that was new in 2006 is already outdated....


iMac, Mac OS X (10.3.x)
  • 1. Re: Printer for 10.3?
    Klaus1 Level 8 Level 8 (44,495 points)

    A G5 can run OS X up to, but not beyond, Leopard 10.5.8. and if yours was new in 2006 it did not come with 10.3 but with Tiger 10.4.

     

    The Canon Pixma series of printers still has drivers for Leopard. I know this because I have one and use it with my G5 iMac running Leopard!

  • 2. Re: Printer for 10.3?
    Allan Jones Level 7 Level 7 (30,435 points)

    I found Canon drivers for new PIXMA printers that went back to 10.3, and successfully installed a Canon 3100 on a 1998 PowerBook running 10.3. Canon is quite good about supporting older Mac OS versions.

  • 3. Re: Printer for 10.3?
    rccharles Level 5 Level 5 (5,360 points)

    Try ebay for the same printer you had working before.

     

    Here is how to find out what version of Mac OS you are running:

    Click on the blue apple in the upper left hand of the screen.

     

    click on this icon

    Picture 8.png

     

    Click on the first line, "About This Mac"

     

    Picture 9.png

    Most of these are numbers & that's what we want.

     

    What version & Processor do you have?