Skip navigation

Duplicate songs on iPhone after iCloud download

189879 Views 117 Replies Latest reply: Apr 19, 2014 6:08 AM by mproopesh RSS
  • svn1thr3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 18, 2013 9:03 PM (in response to masterleep)

    masterleep wrote:

     

    This happened to me after a warranty hardware replacement and doing a restore.

     

    I had to call Apple to get it solved.  Here is what worked:

    1. Turn off music syncing to the phone in the computer's iTunes.
    2. Sync to remove music.  Everything will be gone except the infernal iCloud duplicates.
    3. Make sure iTunes Match is off in the phone Settings.
    4. go to the iTunes & App Store settings on the phone.
    5. Click your apple id account and Sign Out
    6. Power off the phone
    7. When powered back on, all music should be gone.
    8. Then turn on music syncing in the computer's iTunes and resync the library.

     

    Never would have figured that one out...  iCloud is a giant cluster of the F kind!

     

    This worked, after the update to iOS 7-- but I had to go through a couple extra steps to get a few remainder iCloud songs that were downloaded but not removing after logging out:

     

    • go into Settings -> General -> Usage
    • then under Storage-- if Music is not listed tap Show all apps
    • then tap Music
    • tap Edit in the upper right hand corner
    • then tap the red circle with the line to remove all data

     

    You can restart the phone and verify in the Music app under songs that nothing is listed before you resync.

     

    Do this BEFORE you re-login under iTunes & Store and resync with iTunes.

  • Tuaca Tom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2013 11:33 PM (in response to clevercubed)

    If iCloud & iTunes Match stores all your music in the iCloud, then why is Apple so lame as to not allow you to "only" see/use what you have stored in iCloud, thus eliminating duplicates.  The duplicates are very annoying when plaing music from a specific artist's entire album.  Amazing for a company so talented in other areas.

  • jefferypetergore Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2013 3:21 AM (in response to clevercubed)

    I think I may have solved this. Had the same problem after upgrading to the 5s.

     

    Under the settings app, go to iTunes and App store, under your apple ID, is a switch that says 'show all music'. Turn it off.

     

    All iCloud files should now be hidden, with automatic downloads still active.

  • JonS Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2013 2:39 PM (in response to svn1thr3)

    Thanks.  I had one duplicate purchase, I couldn't get ride of it and it was driving me nuts.  This did the trick.

  • Kingdaddy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2013 3:56 AM (in response to svn1thr3)

    I callled Apple support since my 5s is still under 90 day free tech support and I wanted this reported.  The fix was to go into Settings - General - Usage - Music and delete all of the music by choosing "Edit" and then the minus sign next to All Music.  I left the phone alone for a while while I did other things, and then later went back and re-downloaded each album (some artists like Led Zeppelin for me have multiple albums, so I just hit download all) from iCloud.  It takes quite a while to go into each artist and select download, but it finally fixed the problem.

     

    I never used the sync to iTunes method, and it still worked to fix the problem.  And for whatever it's worth, I have 13.5 GB of music.

  • JackKelly Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 4:04 PM (in response to clevercubed)

    This is ridiculous. I shouldn't have to read 8 pages of this thread to try different solutions people have posted. Apple should document a clear way of resolving this that doesn't require me to have to manually delete the duplicate entries/files from any of my iOS devices or my MacBook Pro. I should just have to change some sort of settings on one or more devices and that should clean up my disk storage as well as library entries. If the iCloud is the cause of this then Apple should have thoroughly tested the integration of it with multiple devices syncing with it under a single account.

  • CitySam Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2013 7:04 PM (in response to svn1thr3)

    Yes, thank you Svn... !  Signing out of Itunes on the handset is what did it for me.  Much appreciated. 

  • Scs38 Level 1 Level 1 (0 points)

    Ok I had this issue for a long time , I tried all the solutions showed up below but it didn't worked so I found a way on my own here it is: ( OF COURSE I AM ABSOLUTELY NOT RESPONSIBLE IN ANY CASE FOR THIS GUIDE , DO A BACKUP PLEASE OF YOUR DATA BEFORE TRYING MY SOLUTION ) THIS WAS TESTED FOR IOS 7 ONLY

     

    1. -Download and install iBackupBot ( please support them, do not pirate it ! )
    2. -Plug your iDevice on your PC or Mac with a usb cable
    3. -Do a backup with iTunes incase everything fails
    4. -Go to Preferences menu and Store and uncheck show music in the cloud
    5. -Disconnect your Apple ID in iTunes and on your iDevice
    6. -Backup your music somewhere ( USB etc.) and delete everything on itunes and your on iDevice BE CAREFUL google it first, an easy way can be found on Settings app
    7. -Open iBackupBot and select your iDevice
    8. -Go to Raw Filesystem and -> Purchases folder and DELETE everything
    9. -Go to iTunes_Control folder and DELETE everything in each folder
    10. -Close iBackupBot
    11. -Unplug your device and power off it
    12. -Power on it and plug it on your Mac or PC
    13. -Open iTunes and Select 'manually manage music and video' , click OK (see http://support.apple.com/kb/ht1535)
    14. -Tadaa there is nothing on your iDevice, no duplicates , Enjoy ! Download your music with iTunes app or drag and drop your music with a usb cable on iTunes

     

     

    If everything has failed try my solution with a clean install of iTunes ( Uninstall all the components, delete every file left from it , reboot your PC and reinstall iTunes ) or do restore of your device before

    Seriously Apple do something for this f****n eternal bug !

     

    Hope that helps

    Scs38

  • Failcakes11 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2014 1:29 PM (in response to svn1thr3)

    Another thing I found is if you delete all the manually added songs under the music tab on your device in iTunes. Also any playlists.

  • kristifromyukon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 28, 2014 8:46 PM (in response to svn1thr3)

    svn1thr3, you are a genius. Fixed my problem perfectly!

  • jv1234 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 15, 2014 7:35 AM (in response to clevercubed)

    Thanks for help

  • bigjohnsta Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 28, 2014 12:46 PM (in response to clevercubed)

    After 8 pages of reading, this finally fixed my issue. My device is the following as well:

     

    • iPhone 5c
    • iOS 7.1

     

    1. Go to Settings > General > Usage > Music (loading) > Edit > Tap the red Negative Circle > and tap Delete.
    2. Go to Settings > Music > turn off Show All Music
    3. Go to your Music App, all music should be gone
    4. Plug iPhone back into PC and open iTunes
    5. Go to your iPhone in iTunes and click on the Music tab
    6. Check Sync Music and choose an option below it. I selected Entire Music Library
    7. Re-Sync iPhone

     

    All duplicate music should now be gone.

  • mproopesh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 19, 2014 6:08 AM (in response to clevercubed)

    Resolution that worked for me perfectly

    Using iPhone 4S and iOS 7.1

     

    1. Connect iPhone to iTunes

    2. Check if Library has the correct No. of songs you purchased

    3. Check if iPhone shows downloaded song and duplicates shown with iCloud icon

    4. Go to 'Settings' > 'General' > 'Usage' > 'Music' - Select 'Music' > Select 'Edit' and delete all songs

    5. In iTunes, select your iPhone icon. In 'Summary', Under Options > Change 'Manually manage music and videos' to selected

    6. Now on the left panel in iTunes click the 'Music' icon

    7. Notice at the bottom panel under the list of songs - A new bar appears - 'Autofill from' - Select 'Music' from the dropdown

    8. On the right side - Notice Settings icon, click > In the pop-up, change checkbox to yes - 'Replace all items while Autofilling'. Select 'Ok' button

    9. Click on 'Sync' button

     

    All duplicates music files should be gone from iPhone. Open Music app in iPhone and check for changes.

    Please let me know if this worked for you.

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.