9 Replies Latest reply: Jan 13, 2014 9:36 AM by tordenspyd
kylehance Level 1 Level 1 (0 points)

I'm having a strange problem with drag and drop in Finder. Often when I try to drag a file into the trash or into another folder, the file will follow the cursor but when I release on the trackpad the file does not "drop." It simply remains attached to the cursor, no matter how much I click or otherwise. Everytime I find I have to force Finder to relaunch. It's become a bit of a pesky issue. Any thoughts?


MacBook Pro (15-inch Late 2008), OS X Mountain Lion (10.8.5)
  • 1. Re: Drag & drop not functioning
    C F McBlob Level 4 Level 4 (2,865 points)

    Have you reset your PRAM?

    Shut the Mac down completely.

    Holding the Cmd+Opt+P+R keys, press the power button.

    PRAM.jpg

    Wait for the startup chime to sound three times and let the keys go.

    When it boots, it should "behave better".

  • 2. Re: Drag & drop not functioning
    Imp68 Level 4 Level 4 (2,155 points)

    Drag lock option maybe?

     

    http://support.apple.com/kb/PH11489

  • 3. Re: Drag & drop not functioning
    Linc Davis Level 10 Level 10 (117,830 points)

    If third-party software called "Air Display" is installed, remove it according to the developer's instructions, then reboot. Back up all data before making any changes.

  • 4. Re: Drag & drop not functioning
    kylehance Level 1 Level 1 (0 points)

    This worked for now! I will wait a couple of days to see if the issue pops back up before deciding it's solved. Thank you!

  • 5. Re: Drag & drop not functioning
    kylehance Level 1 Level 1 (0 points)

    Unfortunately it's already not functioning properly again. I also tried resetting the PRAM, with nothing solved. I have never had Air Display, so that can't be the problem.

  • 6. Re: Drag & drop not functioning
    Linc Davis Level 10 Level 10 (117,830 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, by a peripheral device, or by corruption of certain system caches.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled on some models, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.
       
    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and  Wi-Fi on certain models. The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • 7. Re: Drag & drop not functioning
    kylehance Level 1 Level 1 (0 points)

    I did some additional searching and found a discussion from OS X 10.7 of people having this exact issue. I found people who had installed AirParrot were having this issue, and uninstalling and removing the two AirParrot KEXTs from Library/Extensions fixed their problems. I have installed AirParrot in the past. Those KEXTs are:

     

    AirParrotDriver.kext

    APExtFramebuffer.kext

     

    I tried this and restarted and drag & drop began working again.

     

    I now realize this is similar to uninstalling the Air Display application.

     

    I also did as you said and restarted into Safe Boot. I had no issues, and am still ejoying a fully funcitoning drag & drop after rebooting as usual.

     

    It appears my issue has been resolved! Thanks for the help!

  • 8. Re: Drag & drop not functioning
    hayes.horn Level 1 Level 1 (0 points)

    This fixed my issue! Thanks

  • 9. Re: Drag & drop not functioning
    tordenspyd Level 1 Level 1 (15 points)

    this solved my problem which was very similar, thanks (Powerbook G4, Mac OSX 10.4.11)