Skip navigation

Persistent Subtitles

20019 Views 127 Replies Latest reply: Oct 19, 2013 5:31 AM by Sigh-Man RSS
  • Paul Korntheuer Level 1 Level 1 (85 points)
    Currently Being Moderated
    Oct 13, 2013 12:04 PM (in response to DeanChristopherSmith)

    It is my understanding that Apple awhile back changed the method by which they encode their online movies and embed copyright controls and as such, the 1st generation of TV will not properly decode - hence the issue with subtitles. And it is also my understanding that the 1st generation Apple TV cannot upgrade its firmware. Yes, it a drag that this hundred dollar piece of electronics is no longer useable and yes, Apple should have owned up to the problem (maybe offering a rebate program for 1st gen owners). Technology evolves and poop happens; not the best corporate decisions are made, but time to move on...

  • karima85 Calculating status...
    Currently Being Moderated
    Oct 13, 2013 12:48 PM (in response to Paul Korntheuer)

    Sadly, I am at the same conclusion as Paul K.

    I gave up on my 1st Gen Apple TV about 2 weeks ago and bought the new one. Its fine. Just slightly annoyed with Apple still and do wish they handled the problem better.

    Ive lost a great deal of confidence in their products lately bit still pretty much use/have them all. I am starting to pay a lot more attention to their competition and realize they are not the only game in town. I have a strong feeling they've peaked and it's time for someone else to take over that market.

  • Dr Eldon Tyrell Calculating status...
    Currently Being Moderated
    Oct 15, 2013 8:19 AM (in response to Paul Korntheuer)

    This is my last comment on the subject. Evidently Paul has managed to find a logical answer to why this random subtitle problem keeps occuring. What I find sadly interesting is why Apple stonewalled me in my numerous attempts to find out what the problem was. I think that a straight forward answer would have gone along way to handling the frustration of all involved. Poop does happen and this time it's on Apple, a little honesty goes along way towards customer appreciation and loyalty and although I am a long time Apple user, it seems to me that they indeed have turned the corner from leader to chaser, (look at the new phone software). We all miss the energy and leadership of Steve, but I must admit I didn't think he would be replaced by this. And so it goes, indeed time to move on........

  • denvercx Calculating status...
    Currently Being Moderated
    Oct 15, 2013 8:09 PM (in response to Dr Eldon Tyrell)

    I had the exact same problem until...

     

    Settings --> Audio/Video --> Subtitle Language (choose English). Mine was off.

     

    Works perfectly again. Tested on Iron Man iTunes rental, 1st generation ATV.

  • Thegetches Calculating status...
    Currently Being Moderated
    Oct 16, 2013 1:10 PM (in response to denvercx)

    Holy ****, that seems to work.  That simple?

  • Paul Korntheuer Level 1 Level 1 (85 points)
    Currently Being Moderated
    Oct 18, 2013 8:44 PM (in response to Thegetches)

    Hmmm....  Star Trek: Into Darkness approx 52:40 into the movie the subtitles pop up for Klingon translations - but don't go away. But pausing movie; going to Settings --> Audio/Video --> Subtitle Language (choose English), then resuming the movie will make the subtitles disappear. If rewind, replay that same scene again, the subtitles will appear, as they should in that scene, but again - won't disappear. Whether English is chosen or Subtitles Off - the subtitles will not disappear. Issue repeatable. BUT toggling either between English and Subtitles Off will cause the subtitles to disappear when resuming the movie.

     

    Anyone else coming up with anything different?

  • Thegetches Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2013 5:14 AM (in response to Paul Korntheuer)

    It worked on The Hobbit I purchased (Elves and Orcs subtitles), but last night I rented Hangover 3 and the first thing that came on was title bar telling the viewer where the seen was taking place, AND it never went away.  Had to stop and restart the movie for it to vanish.  So much for that.  Having a hard time letting go of a perfectly good Apple TV for a new version.  Bummer.

  • Sigh-Man Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 19, 2013 5:31 AM (in response to Thegetches)

    I too was having this problem on my ATV gen 1.  Every time it happened, I would "Report A Problem" with my purchase through iTunes and would always get a refund.

     

    However this approach was less than enjoyable - even though it meant that I was able to watch some movies for free.

     

    So I ended up selling my ATV gen 1 on eBay for more than a brand new one (gen 3 rev A) - apparently some people love repurposing ATV gen 1s into mini computers etc... 

     

    In my case (what with purchases in the cloud, and a fast broadband connection) the new ATV is perfectly suited to my needs and has given me no problems.

     

    For anyone thinking of repeating my approach - it may be worth waiting a few days as there are rumours of a new ATV at the next Apple event 22 Oct

     

    Hope that this helps everyone...

1 ... 5 6 7 8 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.