Skip navigation

Bose AE2w Bluetooth headphones won't connect with MacBook Pro

11837 Views 15 Replies Latest reply: Apr 18, 2014 1:28 AM by Alejandro Luengo Gomez RSS Branched to a new discussion.
1 2 Previous Next
Bassman1947 Calculating status...
Currently Being Moderated
May 13, 2013 8:06 PM

New Bose Bluetooth headphone (AE2w) connect with iPod Nano & iPad but not with MacBook Pro.  Is there a software upgrade/solution?

MacBook Pro
  • Tony Welch Calculating status...

    I have found the same issue: connects easily to iOS devices, much more difficult to OSX devices. I did eventually get the headphones to work on both the MB Air and Mac Pro by repeatedly pairing the headphones. Make sure that the volume is set to max on your macbook pro & itunes and check that the stereo phones (not mono) are being used in the sounds control panel. There definitely seems to be an issue though - I just haven't had a chance to contact Bose.

  • CamiASC Calculating status...

    I have tried your suggestions with no luck...

    Worked the 1st time I tried, no luck since!! Flawless with iPhone and iPad though. I've emailed Bose, let's see if I get a reply...

  • CamiASC Level 1 Level 1 (0 points)

    Heard from Bose:



    While the Apple iPad® is the “optimum” device we would recommend, the Bose® AE2w is compatible with any mobile device that supports Bluetooth® version 2.1 or later and A2DP to provide audio. We do not recommend using AE2w with a computer, laptop, television or gaming console due to known compatibility issues. However, the headphones do come with the accessory audio cable, so you would be able to use the headphones with you Apple® Mac using the audio cable to the headphone jack.



    Not exactly what I wanted to hear...

  • Tony Welch Level 1 Level 1 (125 points)

    This is very disappointing to hear - it doesn't make sense though. 

  • vritter Calculating status...

    I'm a little disappointed too, but it's possible to make the headset work with MPs. I have a rMBP and I could pair the phone in my first attempt, but suddenly it stopped working. After perform every kind of reset command on the phone (like holding the mic button and the - vol button for 10 sec to clear the pairing list) and repeatedly "set up Bluetooth device..." on my MP I had no success. So I tried to reset the OS X Bluetooth preferences and it worked! I deleted the Bluetooth Audio File list in:




    and restarted the system. Then, I was able to make the headphone work like the first time.


    Hope that helps!

  • Mc2Mac Calculating status...

    vritter, your solution worked for me. Thank you.

  • TheRuthOneal Calculating status...


    I've just updated the firmware to 01.01.00 (was 01.00). Now the headphones connect better to my mac.


    You should be able to find  the update here: loads/page.html



    Try it, may be it'll solve your problem.

  • TheRuthOneal Level 1 Level 1 (0 points)


    there is a new firmware update 01.02 from Bose.

      Also if you check Bluetooth preferences -> Advanced -> Prompt for all incoming audio request seems to further improve connectivity.

  • Bjarnebritzer Calculating status...

    I dont think firmware has something to do with it. Always better to upgrade though. What made difference though was adjusting system volume to max as someone wrote in a previous post. Little bit strange but.... it worked. Seems to change by it self to mono sometimes also. Its a bit unstable but when it works its great. Didnt even know there was a mic in these =)

  • Jezz7w Calculating status...

    Unfortunately there are actually two problems; one is software which can be partially fixed and the other is a hardware issue which is actually quite a fiassco for all laptops esspecially apple computers.


    On the sofware side of things you can use terminal commands to change your bitpool range, I recomend a bitpool range of 48-80 for the bose AE2w headphones.


    But the bad news... USB 3.


    As it turns out, USB 3 is an absolute fiasco for bluetooth as it emits a interferring 'dirty noise' in the same 2.4GHz wireless frequency as bluetooth which causes a lot of the distortion and worst of all, it significanty reduces the range of the bluetooth signal! I'm not sure if this is apple's or intel's fault.

  • Tony Welch Level 1 Level 1 (125 points)

    >>use terminal commands to change your bitpool range



    I'm using 10.9 and the applscript does not work for me, nor do the terminal commands. I get this message:

    Domain does not exist

  • kpshaju Calculating status...

    thanks guys , it workd

  • fl11th Calculating status...

    The reason I went down this rabbit hole is that my new headphones would connect via Bluetooth but the sound stuttered, sputtered and clicked at a highy annoying interval that was unlistenable!  Took a bit of persistence but here is what worked for me in setting up the new Bose AE2W Bluetooth Headphones on a Macbook Pro <Software  Mac OS X Lion 10.7.5 (11G63b)>:


    For starters opened "Terminal" and executed:


    defaults read


    which in turn yielded the "out of the box" default values...


        "Apple Bitpool Max (editable)" = 64;

        "Apple Bitpool Min (editable)" = 2;

        "Apple Initial Bitpool (editable)" = 30;

        "Negotiated Bitpool" = 30;

        "Negotiated Bitpool Max" = 53;

        "Negotiated Bitpool Min" = 2;

        "Stream - Flush Ring on Packet Drop (editable)" = 0;

        "Stream - Max Outstanding Packets (editable)" = 30;

        "Stream Resume Delay" = "0.75";


    After digging around on the web and trying changing one or two values (including individually setting all of the values below), disconnecting and reconnecting multiple times I was just about ready to give it up.  Then I cranked the values (except the one that is and was during most of my effort at 80) all up to 66 for grins and toggled the Stream Resume Delay to 0 then 1 (I include this for completeness and chuckles as it probably had little to do with the solution). The headphones wouldn't stay connected at all so I cut and pasted the following 6 lines into the Terminal all at the same time, reset Stream Resume Delay to 0.75, disconnected and reconnected... voila it now works without the stuttering effect that plagued the Bose AE2W no matter what I changed individually...


    defaults write "Apple Bitpool Max (editable)" 80

    defaults write "Apple Bitpool Min (editable)" 53

    defaults write "Apple Initial Bitpool (editable)" 40

    defaults write "Negotiated Bitpool" 58

    defaults write "Negotiated Bitpool Max" 58

    defaults write "Negotiated Bitpool Min" 48


    lastly, I made a copy of the (as this file houses the settings) file located in ~/Library/Preferences as a backup just in case something flakes out later...


    Here is what my settings look like now:


    defaults read


        "Apple Bitpool Max (editable)" = 80;

        "Apple Bitpool Min (editable)" = 53;

        "Apple Initial Bitpool (editable)" = 40;

        "Negotiated Bitpool" = 53;

        "Negotiated Bitpool Max" = 53;

        "Negotiated Bitpool Min" = 53;

        "Stream - Flush Ring on Packet Drop (editable)" = 0;

        "Stream - Max Outstanding Packets (editable)" = 30;

        "Stream Resume Delay" = "0.75";


    Probably not the most scientific method as I can only guess as to whether I could repeat the process and am certainly not going to intentionally reintroduce the glitchy sound to find out.  But I post this as I did finally get it working and perhaps this will work for others or at least encourage them to keep trying



  • fl11th Level 1 Level 1 (0 points)

    Hmm well maybe I spoke to soon last night... This morning (the next morning after finally getting it working), I opened my laptop (it was in standby mode) and turned on the headphones.  Yep the stutter, sputter and click is back and the headphones are basically useless.  Checked the settings and they haven't changed but reloaded them anyway by executing this in a Terminal :


    defaults write "Apple Bitpool Max (editable)" 80

    defaults write "Apple Bitpool Min (editable)" 53

    defaults write "Apple Initial Bitpool (editable)" 40

    defaults write "Negotiated Bitpool" 58

    defaults write "Negotiated Bitpool Max" 58

    defaults write "Negotiated Bitpool Min" 48


    Tried turning headphones on and off several times, tried turning Bluetooth on and off several times.  The first few connects it was just the noisy non-functional stutter of whatever was playing. Now I basically connect and hear nothing at all through the headphones the last few attempts.  Guess I will have to go to the Mac Store at some point and see if they have any suggestions as nothing repeatable, as a method, seems to have yielded out of my internet scourings.


    ***Yet another update***


    Tried again after waiting 15 minutes or so and they work again now... But sometimes glitch as I type. (presumably my hand is getting in the path between signal and reciever, I dunno)... 




    Message was edited by: fl11th

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.