Skip navigation
This discussion is archived

Xsan Volume no longer starts

2298 Views 6 Replies Latest reply: Jun 2, 2006 10:40 PM by drewsta@mac.com RSS
drewsta@mac.com Calculating status...
Currently Being Moderated
May 10, 2006 8:00 AM
Over the weekend we upgraded the Xsan system to 1.3 of Xsan. Went reasonably well, everything was working with all systems.

last night went to upgrade one of the edit systems to 1.3, and it didn't see the volume. ran fsck. now the volume won't mount.

the projects data is backed up, but there are a few terabytes that were not.

would love to figure out a save. anybody have any idea?

i've seen a few articles about taking the xsan mdc's back to older versions helping this type of problem, but not sure what the best route is.

appreciate any insight.

Thanks.


here's our log error when it tries to mount:

[0510 03:08:22.587993] 0xa000ed98 (Debug) Inodeinit_postactivation: FsStatus 0x3, Brl_ResyncState 1
[0510 03:08:22] 0x1887600 (Info) FSM Alloc: Loading Stripe Group "MDJ_Pool". 233.74 GB.
[0510 03:08:22] 0xa000ed98 (*FATAL*) PANIC: /Library/Filesystems/Xsan/bin/fsm "
The stripe group "User_Pool" size is 256309120, expected 244182912.
You must maintain the original configuration or re-initialize the file system.
File system 'Hookah' not started.
" file alloc.c, line 2923
[0510 03:08:22] 0xa000ed98 (*FATAL*) PANIC: wait 3 secs for journal to flush
[0510 03:08:22] 0x1887600 (Info) FSM Alloc: Stripe Group "MDJ_Pool" active.
xsan 1.3 / OS 10.4.6 /, Mac OS X (10.4.6), 3 xserves / 3 xraids / 5 workstations
  • jchristensen Calculating status...
    Currently Being Moderated
    May 11, 2006 9:19 AM (in response to drewsta@mac.com)
    Drew.. sorry to hear of the trouble. I had a similar problem when I tried to upgrade a OSX 10.3 server from Xsan 1.1 to 1.2. Once 1.2 was installed, the volume would not mount on any machine (client or server) and, in fact, caused a kernel panic error when you did try a mount.

    My solution was to go back to Xsan 1.1. I followed the detailed instructions in another post. I will try to find that for you and send (or you could search for all article that I've posted to in the Xsan forum and you'll find it there somewhere).

    I don't know if it's possible to go back from 1.3 to 1.2 in the same way that I did. Would be nice if Apple provided some better support on all of this. Xsan has been so touchy from the beginning. We need a very robust set of utilities for this product that, in my opinion, just aren't there. Why on earth do we still have use the terminal just to do a basic disk check??
    G5, Mac OS X (10.3.9), XServe, XServe Raid, Xsan
  • Michiel Nouwens Level 2 Level 2 (290 points)
    Currently Being Moderated
    May 17, 2006 5:12 AM (in response to drewsta@mac.com)
    Sure

    mount -t acfs XsanVolumename /Volumes/XsanMountpoint

    Easy peasy...

    I'm happy to see that Apple eventualy has given you usefull commands, the every body deletes the GUI app. things would be a lot easier

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.