1 2 3 Previous Next 43 Replies Latest reply: Dec 8, 2013 9:03 AM by BozoTexino Go to original post
  • 30. Re: blue screen after startup and system hangs
    rccharles Level 5 Level 5 (5,360 points)

    You migh look here:

    blue apple > system preferences > universal access > mouse

     

    I suggest posting another questions to ask about the mouse.

     

    Robert

  • 31. Re: blue screen after startup and system hangs
    Iritscen Level 1 Level 1 (0 points)

    Based on my and others' experiences, that cursor issue is definitely a result of the graphics card failure.  I experienced the same issue when booting in Safe Mode, but when I removed all the ATI drivers as previously described, the cursor corruption went away.  Not sure why it didn't go away for you too.

  • 32. Re: blue screen after startup and system hangs
    LKNRaiderFan Level 1 Level 1 (0 points)

    Ok, after spending DAYS researching what to do about a G5 iMac that won't boot past the blue screen I have taken the advice of this thread and removed every extension that starts with ATI. I am now finally able to boot the machine, but it seems to be running slowly.

     

    Is there any way to determine if I actually have a video board issue? I've run hardware test, repaired permissions, reloaded the OS, reset the PRAM and the PMU, and done a dozen other things with no result. I also turned off Airport and that didn't help. This is the first thing that has made a difference. I'm surprised this info hasn't been made more readily available to others.

     

    Also, has anyone determined WHICH of the ATI extensions is really causing a concern?

     

    Finally, the instructions call for just pulling the extension out of the folder into another folder. In my experience, this just COPIED the extensions into the other folder. I kept that folder but had to go back to the extension and drag them to the TRASH to actually remove them.

     

    All input is appreciated!

  • 33. Re: blue screen after startup and system hangs
    Iritscen Level 1 Level 1 (0 points)

    If removing the ATI drivers allows the machine to boot, you almost certainly have a bad card.  Those drivers allow the Mac to use the card, so by deleting them, you avoid triggering the defective hardware.  As a result of not finding the drivers, OS X then falls back to its software renderer, which is slower than hardware-accelerated graphics.  But since your goal was to allow your Mac to start up without crashing, you probably won't benefit from restoring any of the drivers, as they are all designed to work together.

  • 34. Re: blue screen after startup and system hangs
    sra_mana Level 1 Level 1 (0 points)

    yes Iritscen, am agree with you. I have a imac g5 PPC, and have the same problem. I did copy and paste the driver in another folder, it work and I can boot my imac but the graphic card is not working the same as it has to be. even if you go to system info and see your graphic/ displays info, you can see that the Quartz Extreme is not supported. and if its not supported you cant use iMovie and other programs.

     

    I am trying to find a better way to solve the problem but still no luck, if any one have find any thing plz let us know.

     

    thanks

  • 35. Re: blue screen after startup and system hangs
    braeburn8 Level 1 Level 1 (0 points)

    As with other people replying I used the same procedure to fix a broken GeForce FX 5200 card.

     

    Could not be better for anyone wishing to extend the life of an iMac G5.

     

    As a further life enhancing fix; and if you like watching, for example BBC iPlayer, or any other videos that need the latest Flash player, on an iMac G5 with OSX 10.5.8, watch YouTube for:

    Flash Player fix for Mac PPC

     

    Link: http://youtu.be/iCrAKhv3R_c

     

    Combining this Flash player fix, with RRCharles’s broken video card fix, I now have an iMac G5 running 10.5.8 performing the death defying feat of playing live BBC on my iMac G5, with a broken GeForce video card.

     

    How’s that!

     

    Kudos to RRCharles for excellent deduction, the courage to try this and share with the community.

     

     


  • 36. Re: blue screen after startup and system hangs
    Troubled Imac User Level 1 Level 1 (0 points)

    Awesome, when i originally posted this issue way back in 2011, never thought the imac g5 will have life past an year or so. Mine screen died completely in early 2012, so i connected a external VGA monitor which lasted for another 3-4 months and since then the video card doesn't seem to support even the external monitor.

         For past 9 months or so my imac g5 with no video support is still operational as file server but only because i was lucky enough to keep the telnet service ON before the video card died down (yes i can still telnet into my imac-g5-ppc).

     

    Wondering if anyone has seen similar faith with their imac g5 ppc (or is it just me because of heavy usage - my kids were using it all the time till it ran out of juice)? Or have found a solution to fix the video card? (i am game to fixing the card by opening the mac - tried that following some net posting about bad capacitors only to notice that my imac had a isight camera whereas the one people mentioned with capacitors issue was the older model)

     

    Thanks in advance

  • 37. Re: blue screen after startup and system hangs
    rccharles Level 5 Level 5 (5,360 points)

    braeburn8, Thanks for the kind comments.

     

    Troubled Imac User: I read some post about reflowing the solder connecting the  viedo pins to the logic board.  This is way beyond my capabilities.  Suggest you try this on some broken board. I'd suspect someother problem than a bad video chip if you do not get a display in safe mode.  Seems like some kind of "cabling" problem too me to the video out port.

  • 38. Re: blue screen after startup and system hangs
    aksCloud Level 1 Level 1 (0 points)

    I also had the problem that I could only boot in the safe mode, or else I would get a blue screen. I removed the ATI files from the Extensions folder, but this alone did not solve the problem. I also removed the GeForce files because I have a NVIDIA card. This allowed me to boot normally. My question is why did this work? and what does this mean about my system?

  • 39. Re: blue screen after startup and system hangs
    rccharles Level 5 Level 5 (5,360 points)

    Glad to hear of your success.

     

    Thanks for your kind words.

     

    Robert

  • 40. Re: blue screen after startup and system hangs
    Iritscen Level 1 Level 1 (0 points)

    aksCloud: See my second post above.  By "bad card" I mean that some of the VRAM, or some other chip, has failed on the graphics card.

  • 41. Re: blue screen after startup and system hangs
    triciacastro Level 1 Level 1 (0 points)

    You are a savior! I've reinstalled two OS versions already thinking it was a bad install. No where else on the internet gave the solution to my problem! You're a genius!!!

     

    T H A N K  Y O U !

  • 42. Re: blue screen after startup and system hangs
    rccharles Level 5 Level 5 (5,360 points)

    Glad you found this discussion.  Happy computing.

     

    Robert

  • 43. Re: blue screen after startup and system hangs
    BozoTexino Level 1 Level 1 (0 points)

    Beautiful, elegant solution for a troubled PPC G5 that's only being controlled remotely now. Thanks rccharles!

1 2 3 Previous Next