Skip navigation

Target Disk Mode gives wrong hard drive (my G4 has 2)

423 Views 9 Replies Latest reply: Oct 22, 2013 3:06 PM by BDAqua RSS
Oaklandguy Calculating status...
Currently Being Moderated
Oct 12, 2013 4:13 PM

OK, I'm getting ready to replace my G4 with a newer Mac Mini. (I bought a 2010 model used, so I can run OS 10.6.x so I can use older software).  I want to try Migration Assistant.  Just tried Target Disk Mode and Firewire.  The G4 has 2 internal hard drives.  From the Mini, and G4 in Target Disk Mode with 400-to-800 Firewire cable, I see one of the G4's drives (all 3 of its partitions!) but not the other drive.  The other is my regular boot drive & has the goodies that I want Migration Assistant to be able to migrate. 

 

Some details about the G4:

Quicksilver 2002; OS 10.4.11

"Temporarily" means long enough to run Migration Assistant; then I want to put the G4 back the way it was before, with both drives.

Both drives have OK system sw to boot the G4. (10.4.11; 9.2.2) 

Both drives are Western Digital, model: WDC WD3200AAJB-00J3A0 revision: 01.03E01 ; Protocol: ATA

The drive that mounts now has:

BSD Name:          disk0

  Unit Number:          0

The drive that doesn't mount has:

  BSD Name:          disk1

  Unit Number:          1

   

Questions:

1.  Can I open up my G4 and temporarily unhook a cable to 1 of the drives?   Is this likely to damage anything?  Will I have to move some jumper or something on the hard drives? 

2.  Which cable(s) to temporarily disable a drive: power? ATA? both?

3.  Do I have to move an ATA cable from 1 drive to the other?

4.  I know 1 drive is "0" on ATA bus, and the other is "1"; but they are the same size & model.  When looking inside the G4, can I tell which is which?

 

Some alternatives, not as good: 

"Plan B".  Get another monitor, network the 2 Macs by Ethernet, and use Migration Assistant that way. (I expect that to be much slower, and there may be something funky with the Mini's Ethernet port.)

"Plan C".  Use Finder copy.  (This probably won't be nearly as good for preferences, hiddlen files, etc.)

 

Ideas would be appreciated.

 

  -  Oaklandguy 

G4, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10 (114,790 points)

    Hello,

     

    FWTDM will only see the first drive on the first Bus, on IDE that'd be Disk0, or Master drive, not Slave drive.

     

    1. You'll have to eithe move the Cable location or drives... MDDs nomally had Cable Select IDE cables, Master on the end, Slave in the middle cable connection, but Jumpers may affect this also, & on QS & earlier G4s Jumpers only.

     

    2. ATA/IDE cable will prevent it being seen, but won't cure your problem.

     

    3. Likely, but there were different ATA buses in G4s.

     

    4. See if one is on the middle of the cable, if so that is likekly the Slave/disk1

  • BDAqua Level 10 Level 10 (114,790 points)

    It's probably not Cablle Select if you have a Zip equipped G4, likely Master/Slave jumpers.

     

    See the PATA jumpers on that link.

  • rccharles Level 5 Level 5 (5,150 points)

    so I can run OS 10.6.x so I can use older software

     

    You can install the server version 10.6 in a parrallel's virtual machine.  I've bought a the server version of 10.6.

    Parallels:

    http://www.parallels.com/en/products/desktop/

     

     

    Get another monitor, network the 2 Macs by Ethernet, and use Migration Assistant that way.

     

    No need for a second monitor.  Turn on desktop sharing in the g4.  The client is built into 10.5 and above.  Unfortunately, I for get the name. 

     

    realVNC includes client & server.  Full version is free for one month.  More limited version is free.

     

    Robert

  • BDAqua Level 10 Level 10 (114,790 points)

    (Note to Apple - I sure wish you included Rosetta with later OS's than 10.6.)  

     

    I'm certain they could, disappointed they don't, but there's no money in it for them if allow you to run older, far more useful SW than Nickle & Dime you to death with their Alpha SW that'll be broken every step of the way.

  • MlchaelLAX Calculating status...

    Oaklandguy wrote:

     

    (Note to Apple - I sure wish you included Rosetta with later OS's than 10.6.) 

    Apple's license for the underlying technology behind Rosetta expired with the release of Mac OS X Snow Leopard 10.6.

     

    The technology was previously scooped up by IBM.  It is doubtful that they would have relicensed this technology to Apple at a reasonable price, even if Apple was inclined to do so.

  • BDAqua Level 10 Level 10 (114,790 points)

    Interesting, thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.