Skip navigation

24" iMac Screen Freezes since 10.6.3 update - pls help!

454878 Views 1,593 Replies Latest reply: Mar 5, 2014 4:31 PM by forevermacintoe RSS Branched to a new discussion.
  • SquirrelMac Level 1 Level 1 (0 points)

    Just ran the fix as on page 28. But unfortuantly have to report it's still doing the graphics glitch.

     

    Running 10.8.5.

     

    As soon as the GPU is loaded with either Photoshop cs6/CC and YouTube, it fails.

     

    Running iMac 2008 with thr 2400 XT gpu.

  • aieronimo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2013 4:36 AM (in response to KVDB)

    Dear KVDB - this is very disconcerting.  Can you let us know what iMac version you have (e.g., 8,1) and what graphics card you are using?  Thanks.

  • TK111 Level 1 Level 1 (0 points)

    I wouldn't be too worried about it at this point, unless KVDB gives some specifics. Mavericks is pre-release software. How did he get it and what version is he using on what machine, what was the initial experience and what was the experience after applying the kext fix?

     

    I will be very interested, though, when Mavericks is released, if some brave soul will buy it and test it and report back, so I have an idea whether I should buy it as well. Or, I might just do that myself.

  • bobtibb Level 1 Level 1 (0 points)

    Hi People

    It has been a long time since I last posted any comments about this serious problem with aspects of the OS regarding the video kexts....

    My present system is:

    System Software Overview:

     

      System Version:    Mac OS X 10.6.8 (10K549)

      Kernel Version:    Darwin 10.8.0

      Boot Volume:   

      Boot Mode:    Normal

      Computer Name:   

      User Name:   

      Secure Virtual Memory:    Not Enabled

      64-bit Kernel and Extensions:    Yes

      Time since boot:    1:29

    ATI Radeon HD 2600 Pro:

     

      Chipset Model:    ATI Radeon HD 2600 Pro

      Type:    GPU

      Bus:    PCIe

      PCIe Lane Width:    x16

      VRAM (Total):    256 MB

      Vendor:    ATI (0x1002)

      Device ID:    0x9583

      Revision ID:    0x0000

      ROM Revision:    113-B2250L-259

      EFI Driver Version:    01.00.259

      Displays:

    iMac:

      Resolution:    1680 x 1050

      Pixel Depth:    32-Bit Color (ARGB8888)

      Main Display:    Yes

      Mirror:    Off

      Online:    Yes

      Built-In:    Yes

    Display Connector:

      Status:    No Display Connected

     

    Now. I have been operating this Mac with OS Snow Leopard 10.6.7 for many months now with no problems relating to the ones mentioned in this thread having utilised the kext fix that was necessary to avoid the freezes. Due to changes with iPHONE and iTUNES I needed to upgrade to 10.6.8! Trepidation ensued!! So I took advice from this thread and went ahead with forcing my system to boot in 64-Bit mode. I then did an upgrade via Software Update, not the Combo, which I had downloaded . . . for some reason it would not allow me to proceed with the update. I updated via Software Update and rebooted. I then applied the kext fix and then immediately did two Permissions fixes. Since then I have been enjoying a stable Mac, like I had done with 10.6.7 but with extra advantages that the update offers. I did make sure that I killed any old applications that would only run in 32-Bit mode first. So, fingers crossed I am now ready to take a leap up the mountain, as it were! Mountain Lion. First, though I will wait and watch this thread to see if it is possible to use the kext fixes as 'normally' applied. Of course, I still have my OS 10.6.7 on my backup drive via Super Duper. That will soon be replaced by 10.6.8 after a few more weeks of stability!

  • KVDB Level 1 Level 1 (0 points)

    24'' iMac (8,1) with the ATI2600 on OSX Mavericks GM. Was running without kextfix and it freezes after a couple of hours. Installed the kextfix and it freezes after a couple of days. Installed the kextfix again and it runs smooth till now (2days testing).

  • TK111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2013 10:33 AM (in response to KVDB)

    Thanks KVDB. I hope it continues to go clear for you.

  • swmaster Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2013 10:34 AM (in response to KVDB)

    installed mavericks on the very same day GM was available.

    installed it straight on top of 10.8.5.

    added a second monitor, cause 10.9 rocks with it.

    it's a 2007 alu imac 20" with ATI2400HD.

     

    been using it all the time, watching fullscreen videos from

    youtube. original kexts from mavericks are used, no fix applied.

    no freezes, nothing. it's stable and responsive since almost 2 weeks.

    (10 days 21 hours).

     

    see command outputs below.

     

    imac:~ bat$ uname -a

    Darwin imac.local 13.0.0 Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64

     

    imac:~ bat$ kextstat | grep ATI

       78    0 0xffffff7f817db000 0x22f000   0x22f000   com.apple.ATIRadeonX2000 (8.1.8) <74 11 7 6 5 4 3 1>

     

    imac:~ bat$ kextstat | grep AMD

       76    2 0xffffff7f820c5000 0x6d000    0x6d000    com.apple.kext.AMDSupport (1.1.4) <75 74 11 10 7 5 4 3 1>

       77    0 0xffffff7f8215b000 0x166000   0x166000   com.apple.kext.AMD2400Controller (1.1.4) <76 74 11 10 5 4 3 1>

       80    0 0xffffff7f8213f000 0x14000    0x14000    com.apple.kext.AMDFramebuffer (1.1.4) <76 74 11 10 7 5 4 3 1>

     

    imac:~ bat$ uptime

    19:28  up 10 days, 21:28, 4 users, load averages: 1.20 1.68 1.77

  • swmaster Level 1 Level 1 (0 points)

    sorry for the bad colours, mvrcks terminal app tend to copy colors and fonts styles...

  • SquirrelMac Level 1 Level 1 (0 points)

    We've just accdently worked out that if you put the mac to sleep with the power button and then wake up, it temporarly fixes the screen corruption.

  • tomasz17 Level 1 Level 1 (0 points)

    Hi,

    I have installed OS X Maverics.

    I have iMac 8,1, ATI Radeon HD 2600 Pro.

     

    So far the new system rocks, much better than ML.

     

    To early to say that it is stable .....

  • morphodone Level 1 Level 1 (0 points)

    Going to try Maverics myself... here we go.

  • SquirrelMac Level 1 Level 1 (0 points)

    Going to try it on a iMac with a 2400 XT.

  • alexsader78 Level 1 Level 1 (0 points)

    I have an iMac 20" with 2.0Ghz using an ATI Radeon HD 2400 XT and I always had that freezing issue. Does it will work with Mavericks without problems? Does anyone have tested already?
    Thanks!

  • bobtibb Level 1 Level 1 (0 points)

    Hi again

    Having updated to a 'stable' setup with Snow Leopard 10.6.8 using the kext fix and forcing into 64-bit mode I copied this to my external HD via Super Duper!. This is now backed up. I downloaded 10.9 Mavericks today and after waiting a very long time for it to download from the App Store (Free upgrade as well), I went ahead and installed it. Once installed I started to arrange how it worked, going through all the setups asked for by the Apple installer. At about half an hour in . . . boom . . . a grey screen. Disappointed to say the least. Anyway, I know it is not supposed to work but I thought I would have a go and install the kext fixes that worked for 10.6.8 (those from 10.6.2). Loaded them in and rebooted. Blimey! When it came up, everything was going along treacle-footed and obviously not correct. So, I did a repair permissions via the Disk Utility. Rebooted and . . . as of now, a few hourse later . . . the system is working. I haven't had chance to test everything but will report back later with a unpdate. If it goes pear-shaped . . . I will revert to 10.6.8. Wish me luck....

  • sequera Level 1 Level 1 (0 points)

    I have a mac 7.1 with ATI radeon 2400 with 10.7 and kext fixes, without freezing or any problem.

     

    Yesterday I installed OS X Mavericks, and again freezing  ....

     

    Then I installed kext fixes and now working without freezing.

1 ... 94 95 96 97 98 ... 107 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (56)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.