Skip navigation

safari 6.1 freezes

3814 Views 20 Replies Latest reply: Oct 29, 2013 7:28 AM by Chris Whatmore RSS
1 2 Previous Next
pepperdog1996 Calculating status...
Currently Being Moderated
Oct 22, 2013 1:19 PM

I just downloaded the update for safari that was released just an hour ago but now Safari is freezing. I get the loading (beach ball thing) and I have to force quit. Someone got any solutions?

 

Thanks in advance!

  • Carolyn Samit Level 10 Level 10 (84,035 points)
    Currently Being Moderated
    Oct 22, 2013 1:24 PM (in response to pepperdog1996)

    Might be an incompatible extension or plugin ..

     

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

  • Carolyn Samit Level 10 Level 10 (84,035 points)
    Currently Being Moderated
    Oct 22, 2013 1:51 PM (in response to pepperdog1996)

    Did you try extensions first?

     

    Freezing or crashing? There's a difference.

  • rgerald Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2013 1:56 PM (in response to pepperdog1996)

    I have the exact same problem. I instead tried to upgrade to Mavericks, and have the same issue with 7.0.

     

    What I've tried:

     

    -turn off third party plugins

    -Safari Reset

    -Delete all website data

    -Delete safari prefs file

    -Full delete of all safari files related to my user

     

    What has resulted is Safari working... sort of. I can only open one tab at a time, new tabs will not open. Sometimes when I launch Safari, multiple tabs are open but none of them work. Sometimes links do not work at all, and Safari crashes. Clicking on a bookmark while in any tab but the first causes the link to open in the first tab, but only partially. It's all messed up, and there doesn't seem to be any way to get it back to working.

     

    HELP!

  • TomV256 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 22, 2013 3:30 PM (in response to pepperdog1996)

    I have this issue too. Ran disk utility and onyx and tried again: nothing. Not very happy to be updating to Mavericks with a dodgy/corrupt version of Safari installed, but fingers crossed!

  • cduerr Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 22, 2013 3:35 PM (in response to TomV256)

    have the same issue. **** - i wanted to create a clone first of a working ML... and ML has been running fine with the latest version of Safari before that.

     

    I wait for an update. It cannot be good to upgrade to Mavericks in that state...

  • TomV256 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 22, 2013 5:24 PM (in response to pepperdog1996)

    Ok, so I restarted in safe mode (restart holding shift before the start up chime) and safari started fine. I disabled all the extensions and disallowed 3rd party plugins in preferences/security. But when I restarted in normal mode the problem reappeared! Still hanging/beachballing every time I open safari. Any help would be massively appreciated:

  • TomV256 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 22, 2013 6:01 PM (in response to pepperdog1996)

    Okay - I've fixed it!

     

    For me the problem was some Glims plugin files that were lurking in my machine. I ran the Glims uninstaller (http://www.machangout.com/faq) and Safari jumped into life!

     

    Really hope that helps you guys too!

  • drfrot Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 23, 2013 2:03 AM (in response to TomV256)

    Me too, thanks! Upgrading to latest version of Glims fixed it.

  • Dimaxum Level 5 Level 5 (5,945 points)
    Currently Being Moderated
    Oct 23, 2013 8:20 AM (in response to TomV256)

    Hi Tom ...

     

    Thanks, fixed my Safari to (updating Glims).

     

    Dimaxum

  • SVA74 Calculating status...
    Currently Being Moderated
    Oct 23, 2013 9:32 PM (in response to TomV256)

    I had the same problem.

     

    Thanks Tom256, your solution (updating Glims) fixed the problem with Safari !

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.