4 Replies Latest reply: Oct 25, 2013 8:28 AM by reststop
reststop Level 1 Level 1 (65 points)

Ok, got the updates available from the App store.

 

Installed the latest Mountain Lion updates, then went back to the app store to install Mavericks.

 

Everything appeared to go just fine.

Download was quick (less than an hour) and the install looked clean.

 

Then, then final reboot after the install was complete.

 

Nice gray startup screen with the white Apple logo...

 

A cursor appears in the top left corner.

 

After a short while, the cursor becomes a spinning beachball... forever ....

 

 

Held down power button for awhile, then rebooted...

 

Same behavior... spinning beachball.

 

 

Booted into recovery disk with Option-boot.  Went and re-install OSX  (Mavericks)

 

2 hours later, download finished, install went automatically, final reboot into Mavericks....

 

Same behavior, gray Apple screen with spinning beachball.

 

 

Help?

 

I'm thinking of trying to re-install Mountan Lion, but do not have a full backup, so I suspect it will not let me install Mountain Lion over the failed Mavericks install.

 

Any suggestions?

 

Anyone else having this problem?

 

Should I just go to the Genius Bar tomorrow?


MacBook Pro with Retina display, OS X Mountain Lion (10.8.5), MacMini, PM8600/300Mhz MacOS 9.0 51
  • 1. Re: Anyone else getting spinning beachball on boot?
    Paul Otteson Level 1 Level 1 (125 points)

    Exact same story. After that, I shut down, dsconnected peripherals, fired up back into recovery, verified/repaired disks and permissions, and started the download/install all over again. Now waiting. Not confident.

     

    Any successes after this gray-screen-of-death issue???

  • 2. Re: Anyone else getting spinning beachball on boot?
    reststop Level 1 Level 1 (65 points)

    Just spent 2 hours at the Apple Genius Bar trying to solve this.

     

    Tried another install using the local installer from the Genius Bar, and we saw the exact same problem.

     

    It was suggested that some 3rd-party software was preventing things from coming up past the login screen.

     

    Since I didn't have a full backup of my system, we left it that I would come home and do a full backup, then look at doing a fresh install instead of an upgrade.  Apple can no longer do a backup and restore of customer data, so it will be up to me to do that and try again.

     

    The other option is to try and disable all 3rd-party SW and see if that works.  Then re-enable things little by little.

     

    I'm going to try that first.

     

    First step, though is to use my Mac Mini to create a backup.

  • 3. Re: Anyone else getting spinning beachball on boot?
    redrock999 Level 1 Level 1 (25 points)

    Had the same issues. Was able to fix without data loss.

    Basically the Boot sector gets corrupted.. Disk util should really fix this.. if apple is listening there are more than a few corner cases of people having this problem.

     

    See Here: https://discussions.apple.com/message/23507015#23507015

  • 4. Re: Anyone else getting spinning beachball on boot?
    reststop Level 1 Level 1 (65 points)

    To cut a log story short.  The issue with my installation of Mavericks had something to do with my login account.

     

    It turns out that even in Safe Mode, I was unable to login to my regular account.

     

    In my case, I had more than one account, and more than one Admin account on my system.  This didn't cause the problem, this is what led me to the solution.  I tried logging in as myself at the Apple Store with no result.

     

    After completing a full backup, which took nearly 24 hours due to the copy hanging with -36 and -50 errors when copying some files, waiting for a <continue> click to get rid of the error message window a few dozen times...

     

    I removed anything that was startup related from the account, and tried one last time.  Still got the spinning beachball just at the point it would try to auto-login.  Had to force shutdown.

     

    Went to safe mode, and decided to log into my non-admin account.

     

    It worked just fine!

    (You heard me, it worked just fine!)

     

    One interesting point, when I logged in I got the System Install window telling me that it was NOW finishing up the installation.  It then went through the user setup steps and let me "Start Using My Computer".

     

    I attempted a second login by clicking on the username in the menu bar, and instead of the spinning beachball, I got the spinning waiting indicator in the login screen.  Had to Force shutdown.

     

    I went back to Safe Mode, and this time logged in as my other Admin account.

    It worked just fine.  In this case, no additional setup was needed.  It just worked.

     

    A friend suggested ssh'ing into the machine and examining the console log.

     

    I only had the one machine with me at the time, so I did the next best thing.  I opened a terminal window and tried to login as my regular user name.  It worked just fine.  So the Unix system allowed login, but the GUI did not.

     

    I spent a few hours examining the console log for errors, but found nothing to point to as the cause.  After several attempts to remove possibly offending files, nothing worked.  Whenever I tried to login via the login screen, I would get the spinning beachball or waiting indicator.

     

    Finally, I renamed my user directory, and created an empty one in its place.

     

    The login screen login failed AGAIN.

     

    So, at this point we determined that the failure was not based on anything in my user directory or Library.

     

    My next step was to login as my other Admin user, then remove my regular account.  At this point, it was a safe operation, because I had saved my real user directory under a different name.

     

    I created a new user with my regular account name, and tried to login.  It worked just fine.

    I spent the next 6 hours piece by piece restoring files and selected preferences and Library components, and after each batch, testing the login to see if anything broke.  Anything not created anew with the new account is now copied back into the Library folder, and I can login just fine.

     

    So!  Somehow in the upgrade to Mavericks, the account with auto-login somehow got stuck.

    It seems that it got stuck before the finishing up the installation was completed, so when that step finally completed, it was still locked out somehow.  I don't know what was wrong.

     

    Deleting my account (after saving the directory) then creating a new account with the same name solved the problem.

     

    I'm now running Mavericks just fine.

     

    Moral:  Always create a 2nd Admin account you can use as a backup when your regular Admin account gets screwed over, compromised, or wedged somehow.  It helps to have a non-admin account for troubleshooting too.