Skip navigation

Cannot connect to WPA2 Enterprise after Maverick OS update

3430 Views 14 Replies Latest reply: Jan 31, 2014 7:47 AM by macbookairben RSS
acl10 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 23, 2013 9:30 AM

After updating my MBA mid 2013 13 inch I cannot seem to connect to my university's WPA2 Enterprise . It doesn't even appear on the Wifi list anymore. I have found a temporary solution which is to choose the "Join other Network" option from the pulldown but i have to keep reentering it as it does not seem to want to remember the info. Is there going to be an update to fix this issue?

MacBook Air (13-inch Mid 2013), OS X Mavericks (10.9)
  • wifiguru Level 2 Level 2 (230 points)

    Is this a hidden network ? Have you tried deleting the network entry from pref. network list and then re-join the network ?

  • I love wireless Level 1 Level 1 (5 points)

    Open up the terminal and run "/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/ai rport -s" and check if you see the network from the scan list?

  • ae12 Level 1 Level 1 (0 points)

    Same issue here, Late 2013 15" MBP Retina

  • schmiri Level 1 Level 1 (0 points)

    I have the same issue. The network isn't in the list but I can connect via "Join Other Network..." by manually typing in network name, username and password. This has to be redone everytime the network is disconnected (e.g. when the notebook goes to sleep), which is really annoying!

     

    Late 2011 MBP

  • robotaki Level 1 Level 1 (0 points)

    Same issue here; MBA 11 (late 2013), wifi perfectly working before upgrade to Mavericks last night. Came into university this morning, and wifi only detects/connects to the open (no password required) Wifi networks, but not the WPA2 ones (eduroam, or university's enterprise one; these are not hidden, just password protected). The WPA2 ones are not shown in the list at all (even after rescanning multiple times).

     

    Selecting "Join other networks", "Security: WPA2 Enterprise", 'Mode Automatic", and entering user name and password will connect to the network (and give you internet access).  You need to do this every time after a reboot - the network is not saved. Strangely the network still does not appear on the wifi network list despite being connected to it. Same room, MacPro 2008, running 10.7.5, has no problem whatsoever with all wifi networks.

     

    Typing /System/Library/PrivateFrameworksApple80211.framework/Versions/A/Resources/airp ort -s at the terminal does return both WPA networks (eduroam, and the university ones), but they don't show up in the wifi list. I also tried deleting the NetworkInterfaces.plist and preferences.plist and rebooting (as someone had suggested in the support forums) but still no solution.

     

    Very annoying...

  • Christiane R. Level 1 Level 1 (0 points)

    I have a similar issue, yet my wireless is still working ... after updating my MBP mid 2012, 13 inch to Maverick today the airport symbol is grey with the exclamation mark - for me until now a sure sign that my wireless connection is not working. Yet my DropBox gave it away as working and the network information window (I'm writing from Germany, so am not sure of the right English term for each and every window) shows the wireless as working.

     

    I also used your terminal advice and found my network on the list though I could not make much sense of it, admittedly.

     

    Oh, and the airport program tells me it cannot find a configured airport base station (in case I can translate it like that?) - is that my router? I'm really sorry guys for probably appearing incredibly unknowledgable!!! As I said, I admit that both my MBP did me the favour of just working for the past 8 years. :-) If any of you can and is willing to give me some advice as to how I need or have to fix this, it would be much appreciated.

  • Hnek Level 1 Level 1 (45 points)

    Trying to connect to company WiFi WPA2 with certificate.

    When "joining other network" and some waiting I get the answer "Invalid password".

  • mirko1977 Level 1 Level 1 (0 points)

    Same problem here, no luck

  • chattphotos Level 4 Level 4 (1,175 points)

    In a test, I am running Mavericks on my 2011 Macbook Pro

     

    I am writing this reply connected to a WPA2 Enterprise AP

     

    It's a cloud-managed AP from Meraki. I do not know if that is a significant factor, just to note, it is working for me.

     

     

    Screen Shot 2013-10-27 at 4.08.16 PM.png

  • Garfinkel Level 1 Level 1 (5 points)

    Using a Macbook Air 11".

     

    Found a peculiar fix.

     

    After much frustration of Googling the topic, and trying different recommendations, nothing worked.


    For the **** of it, I decided to try using an LTE Hotspot on my new 5S for Wifi. No dice. Same problem "invalid password."


    Then I tried the USB hotspot method with my 5S. Boom. It worked. So, I disconnected, and tried the Wifi hotspot method again. BOOM, it suddenly worked. Going for broke, I disconnected from the 5S, and tried my Airport and BOOOM. Finally, worked after no luck all day.

     

    So, I tested logging out to see if it would go back to not working. Logged back in. Worked fine. Remembered my network. No problems.

     

    Took it further. I restarted entirely. All seems to be a-okay.

  • bphendri Level 1 Level 1 (115 points)

    Bloody brilliant!

     

    Tried this with iPhone phoen and worked like a charm!!  When nothing else worked!

     

    Thanks for you help.

  • macbookairben Level 1 Level 1 (0 points)

    I have this problem, after having intermittent wifi problems with my new macbook air, I replaced the whole thing.

     

    Upgrading to mavericks and I have been plaqued by problems ever since.

     

    Mavericks seems incapable of connecting to WPA2 enterprise.

     

    I have no idea what the problem is, it's something to do with an authentication failure.

     

    Very annoyed as no fix has been realised as of yet. Any tips would be excellent!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.