Skip navigation

ipod nano 4th generation wont charge or turn on

1094 Views 1 Reply Latest reply: Oct 23, 2013 11:48 AM by Delgadoh RSS
Roselis Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 19, 2013 8:53 PM

My ipod nano suddenly stopped working, it doesnt do anything, i already tried toggling the hold button and also pressing the select menu buttons at the same time, i plugged it to my pc and this wont "see" it, what else can I do? i dont know what else to try because its totally off

iPod nano, iOS 4

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.