14 Replies Latest reply: Oct 24, 2013 11:48 PM by vmeade
vmeade Level 1 Level 1 (0 points)

Hi, have an issue where all photos taken this year are showing image not found despite the fact I can see them when I open the photo library in preview, any thoughts as to why this would be?

Thanks in advance.


MacBook Pro, iOS 7.0.2
  • 1. Re: Image not found
    Ernie Stamper Level 8 Level 8 (37,475 points)

    This sounds like you did download them directly into the Aperture Library, but either left them on the memory card, or have moved the originals to be Referenced on another drive or volume.

     

    When you import from the camera or memory card, what are the settings in the import dialogue?

     

    Ernie

  • 2. Re: Image not found
    vmeade Level 1 Level 1 (0 points)

    But up to a month ago they were in the library, I deleted them from the memory card months ago and not sure how I would have referenced them and not any other photos, tried rebuilding and repairing, tried to relocate orginals/ locate referenced files but it doesn't seem to find them. In Preview I can see the photo but not the file destination to compare paths.

  • 3. Re: Image not found
    Ernie Stamper Level 8 Level 8 (37,475 points)

    Do you mean the app Preview, or the preview of the missing images?

     

    Have you done any restorations from TIme Machine?  Had any external drive connected at any time?

     

    Ernie

  • 4. Re: Image not found
    vmeade Level 1 Level 1 (0 points)

    Took a while but loaded the whole library into the preview app and found the image. Problem is it doesn't tell me the link, so I can't try to alter the connection in Aperture.

     

    Do you have time machine back up but just afraid I'll lose all other updated data since by restoring that back up as would prob have to go back a couple of months. Tried to copy the library out of a back up and load that but it didn't work. Same problem even though it was a new library.

  • 5. Re: Image not found
    Ernie Stamper Level 8 Level 8 (37,475 points)

    My question Re Time Machine, was to see if you might have replaced from an incomplete library.

     

    In Preview, is the size of the file you found consistent with the size of an original from the camera, or a preview that Aperture made.

     

    Not a good idea to open the folders of the library with another app -- have you done this before?

     

    If you right-click on the Aperture Library file, and choose Show Package Contents, you can find both the folder for Previews and for Masters (originals).  Not the easiest to navigate, but that is the location of originals in a Managed Library.

     

    Ernie

  • 6. Re: Image not found
    vmeade Level 1 Level 1 (0 points)

    Unfortunately Preview is now closed so can't check the size.

     

    Never transferred anything from Time Machine so far, has also been one way traffic besides trying to copy the photo library out which didn't work but I may try it again.

     

    No first time I opened with a different app, just was hoping it would give me some details.

     

    Thanks for the show package contents and will look in more detail later but looks like photos taken with iphone and small camera are there but not my dslr

  • 7. Re: Image not found
    Ernie Stamper Level 8 Level 8 (37,475 points)

    A report of everything displayed in the Import window when you go to import from your DSLR could be useful

     

    Ernie

  • 8. Re: Image not found
    vmeade Level 1 Level 1 (0 points)

    What do you mean by a report? Sorry clearly not very good at this.

  • 9. Re: Image not found
    Ernie Stamper Level 8 Level 8 (37,475 points)

    The best report would be a screen shot.  Failing that, just tell us what is the setting for every possible line of action in the Import window.

     

    Ernie

  • 10. Re: Image not found
    firstlaunch Level 3 Level 3 (610 points)

    Have you tried to log in with a differnt user account? It's possible that it could be a permissions issue. I'd suggest also trying a Repair Permissions on the library. Are you able to reprocess the image through the menu item?

     

    It's good to look inside your package of the library to see if your masters still reside there. If they do, then you are in good.

  • 11. Re: Image not found
    William Porter Level 1 Level 1 (45 points)

    Have you used the Finder (or another app like, say, Lightroom) to rename any folders in the path to your images? I've done that once or twice by accident, forgetting that it was going to mess up Aperture. I'm a bit annoyed with Aperture's "locate" images commands, too. I find it rather more difficult to reconnect a folder of images to their raw originals in Aperture than it is in Lightroom.

     

    Will

  • 12. Re: Image not found
    vmeade Level 1 Level 1 (0 points)

    tried repairing premissions, but no joy, restored a library from a back up in June, which has a lot of RAW files but it's still not linking. I'm the only user on the computer, so logging in as another user isn't an option.

    As Aperture can't find the image I can't reprocess, that I know of anyway.

     

    Had a look in the folders and looks like the images from 2013 aren't in the master file, only images from my iphone, not the canon.

     

    Certainly haven't renamed the files that I know of and it wasn't a referenced library anyway.

     

    Thanks again for your help and the good news I have back ups of most apart from the Sydney NYE fireworks 2013. Although I do have the best 20 on my iphone so if I can get them from that it would be something

     

    here is the import screen shotScreen Shot 2013-10-24 at 23.16.14.png

  • 13. Re: Image not found
    firstlaunch Level 3 Level 3 (610 points)

    Your current import setting is set a referenced and being placed in your Pictures folder in a sub folder call what ever your project name is. Did you look to see if these missing images reside there? Did you do a spotlight search for the file names to see if maybe they were moved somewhere?

     

    What you might be seeing when you open the library in a different application is the previews. You can look in your Aperture library package to view the previews. I also don't recommend doing this.

  • 14. Re: Image not found
    vmeade Level 1 Level 1 (0 points)

    I just tried importing some photos as a trial and I see that. Which is strange, it creates a folder called Asia, for some reason will need to change that setting. Also tried the serach and looks like they are not there unfortunately. Photo's from last year are on the masters but not this year.