Skip navigation

I open iTunes and I received this error message (-45054), then my iTunes closes. How can I fix this?

1140 Views 3 Replies Latest reply: Nov 15, 2013 11:45 AM by George Young RSS
Laura_lt_2000 Calculating status...
Currently Being Moderated
Oct 23, 2013 7:37 PM

After the latest update I did, 23Oct2013 7:30pm PT, my iTunes no longer opens up without the error message (-45054). I click "ok" to acknowledge the message and it immediately closes iTunes with no further information. Any help would be greatly appreciated, expecially if it's an actual employee of Apple. They seem to be way to into the user-helping-user system they need to step up.

iMac (24-inch Early 2009), Mac OS X (10.6.8)
  • glb69 Calculating status...

    I had the same issue with itunes. I am using osx maverik and used disk utility and repaired permissions seems to have solved the issues. I had alot of permissions that needed repaired. Go to the app folder and open up disk utilities, click on verify permissions for your hard drive after verifing permissions run repair permissions if anything shows up in the verification process. Good luck

  • fixed1t Level 1 Level 1 (0 points)

    Hi,

     

    re: the dialogue:  You do not have enough access privileges for this operation  Error code -45054

     

    A fellow musican I know had an identical issue with this and asked me to check it out.  I fixed it and wrote a long set of instructions on my blog.  His problem was with 10.6 but it was an update he did preparing to move to Mavericks.

     

    I was able to reproduce the error by just removing the /Shared folder from /Users

     

    Here is the link to the problem and the instructions on how I fixed1t

     

    http://fixed1t-mac-support.blogspot.co.uk/2013/10/fixing-itunes-you-do-not-have- enough.html

     

    Regards fixed1t

     

    In order to comply with this form, I must point out that the fixed1t blog site does sell cheap Garageband and sampler support software and that I will benefit if you buy it. The reality is, nobody buys these days LOL  ;-)

  • George Young Level 1 Level 1 (0 points)

    My issue was solved by recreating the /User/Shared folder as you suggest. I first moved the broken one out of the way. Afterwards I moved back all the old Shared/subfolders to the new Shared, except for 'SC Info' and adi.

     

    When I looked at my old /User/Shared folder's permissions, there were added ACL entries that were not on the newly recreated one. I think iTunes/System may have newer security constraints which are now tripping over bad ACL's that came from 'improperly' restoring /Users folders in an older Mac OS X Mountain Lion environment/libs which are being transitioned to Maverick.

     

    Recently I have had ACL issues with other non-permission-repairable-by-diskutil folders. It may be a transition security "fix" which may well work when/if we all drink the Mavericks cool-aid. Needs more sugar.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.