Skip navigation

iPhoto crash to create a new slideshow.

1016 Views 13 Replies Latest reply: Nov 1, 2013 1:05 PM by HolyBaloney RSS
guirojas Calculating status...
Currently Being Moderated
Oct 25, 2013 6:18 AM

I just update to iPhoto '11 9.5, but when I clic on Slideshow button I just get the beach ball of death and iPhoto become unresponsive, the only think I can do is Force Quit. Anybody can help me please?

iPhoto '11
  • Terence Devlin Level 10 Level 10 (121,630 points)
    Currently Being Moderated
    Oct 25, 2013 6:20 AM (in response to guirojas)

    As a Test:

     

    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'

     

    Import a few pics into this new, blank library. Is the Problem repeated there?

     

    Post back with the result.

  • Heartnmind Calculating status...
    Currently Being Moderated
    Oct 25, 2013 7:06 AM (in response to guirojas)

    I have exactly same proble since I have updated Mac OX to mavericks and ipohto.

    iPhoto doesn't response when I do these things.

     

    - Click on 'slidshow' botton.

    - Click on any slidwshow list from side menu.

    - Add slideshow from File>New Slideshow

    - Click on slideshow tap to export midea File>Export>Slideshow

     

    I tried to make a new library and did every task in Photo Library First Aid, but didn't work.

    I'm hopeless.. Please help me too.


  • Old Toad Level 10 Level 10 (112,985 points)
    Currently Being Moderated
    Oct 25, 2013 12:08 PM (in response to Heartnmind)

    Try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

     

    home.PNG

     

    or with Lion and Mt. Lion delete the contents the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder.

     

    iP11mtlioncache.png

     

    3 - reboot, launch iPhoto and try again.

     

    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and press the Return key - 10.7: Un-hide the User Library folder.

     

    If you're running Mavericks, 10.9,  go to your Home folder and use the View ➙ Show View Options menu to bring the this window:

    Mavlibvis.png


    where you can check the Show Library Folder checkbox.

     

    OT

  • Heartnmind Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2013 3:12 PM (in response to guirojas)

    Thanks  a lot Old Toad. But it didn't work either.

     

    I spent all day long to try many things in order to solve the problem.

    I deledted all the files which are related to iPhoto in Library and reinstalled iLife.

    iPhoto didn't work on mavericks then I update iPhoto 9.4.

    I tested slideshow in 9.4 however, even in iPhoto 9.4 slideshow freezed.

    Then I updated to iPhoto 9.5. Still the problem occures.

    I almost gave up to use iPhoto.

    Anyway. Thank you very much Old Toad.

  • Old Toad Level 10 Level 10 (112,985 points)
    Currently Being Moderated
    Oct 25, 2013 3:58 PM (in response to Heartnmind)

    Log into another user account on your Mac and try an iPhoto slideshow there.  Does it work?

  • HolyBaloney Calculating status...
    Currently Being Moderated
    Oct 27, 2013 1:42 PM (in response to guirojas)

    Same here. Still broken. Everytime I put the cursor on one of the (empty) slideshow folders on the left in iPhoto the program stop responding. Same thing when I try to create a new slideshow, it stops responding.

     

    How should I delete the old slideshows under the circumstances? Suggestions?

  • Old Toad Level 10 Level 10 (112,985 points)
    Currently Being Moderated
    Oct 27, 2013 2:01 PM (in response to HolyBaloney)

    A long shot but try selecting two slideshows, the problem one last, and attempt to  delete both at the same time.  You can create a test slideshow for this.  If that doesn't work rebuilding the library with iPhoto Library Manager will create a new library but without books, slideshows, cards, etc. and will get rid of that bad slideshow. 

  • HolyBaloney Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2013 5:30 AM (in response to guirojas)

    Thanks. I would select two slideshows if possible, but as soon as I select one of the 12, the beachball starts spinning. When I try to create a new slideshow, the beachball starts spinning. Hence no way in accessing these.

     

    I tried iPhoto Lib Mgr, by using this I can "select" any of the slideshows, but it doesn't allow me to delete any. I haven't tried recreating the whole library yet.

     

    Thus, so far I tried erasing the plist files according to the scheme above, and starting alt+cmd start iphoto and run through all 4 options (permissions repair, database repair, rebuilding database, thumb photo repair), amnd finally run through disk mgr (disk repair, permissions repair).

     

    Rebuilding with iphoto lib mgr seems to be the next option.

  • Heartnmind Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2013 6:27 AM (in response to guirojas)

    I made a new Mac OS X account from System Preferences>User & Group. Then I imported my old iPhoto Library.

    Slideshow worked well in new account but after repairing permission in 'disk utility', same problem occured again.

    But I let iPhoto leave with spinning beachball for a while (about 6 min), iPhoto started slideshow.

    So wierd.. I found that iPhoto takes about 6 minute to start slideshow first time, after that everything works well.

    If I quit and restart iPhoto, I have to wait 6 minute again for slideshow.

  • Old Toad Level 10 Level 10 (112,985 points)
    Currently Being Moderated
    Oct 28, 2013 9:31 AM (in response to Heartnmind)

    Boot into the Recovery volume (boot with the Command +R keys held  down) and use Disk Utility to repair the disk and repair permissions. Reboot and try iPhoto again.

     

    If still not fixed boot again into the Recover volume and reinstall the system.

  • littlebluebro Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 1, 2013 10:53 AM (in response to guirojas)

    Can you check this?

     

    Go to this folder in your home directory, ~/Music/iTunes

     

    Do you see a folder in there named iTunes Music? Or iTunes Media?

     

    The slideshow in iPhoto may be trying to access iTunes files from the wrong path and causing the crash from what I've seen in other discussion threads.

     

    If you see a folder named iTunes Music, then open iTunes and do this

    File > Library > Organize Library… > Reorganize

  • HolyBaloney Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2013 1:05 PM (in response to guirojas)

    Thanks! This could well be the reason for the screw up. In fact, I moved my iTunes library some year ago to an external HD and recently to a network HD. I addition Apple has changed the library path with new iTunes revisions. It's now manually set at /Volumes/share/iTunes/iTunes Music/Music.

     

    Possibly a work around is to move the iTunes library path back to the original and then go in to iPhoto an erase the slideshows.

     

    On the other hand, it's essentially a bug in the iPhoto package that should be fixed.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.