1 2 Previous Next 18 Replies Latest reply: Nov 14, 2013 6:46 AM by Posthumous
Charles Glen Level 1 Level 1 (35 points)

Hey gang,

Anyone know if the Mavericks update will support FCS- and specifically FCP7? I am using FCPX but still have a ton of old projects using FCP7 and don't want to update both my Pro tower and MacBook Pro if its not compatible. Ant word from Apple about this?

Best,

 

Charles


MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: Mavericks?
    RatVega™ Level 4 Level 4 (1,910 points)

    The smart money is to do nothing until we get some history on Maverics or until you actually need some feature.

     

    A lot of us are still on Snow Leopard because it's stable (even if you can't get all that iToy support...)

  • 2. Re: Mavericks?
    Nick Holmes Level 7 Level 7 (29,835 points)

    >Anyone know if the Mavericks update will support FCS- and specifically FCP7?

     

    Yes. It does.

  • 3. Re: Mavericks?
    Dennis Csillag Level 1 Level 1 (55 points)

    Thanks Nick. I'm in the same boat as Charles. Apple Pro App support folks said "We don't have any data on that yet," but suggested I follow the forums.

  • 4. Re: Mavericks?
    Russ H Level 6 Level 6 (14,255 points)

    Anything you can share on how well it runs on 10.9 – compared to earlier OS versions?

     

    Thanks.

     

    Riuss

  • 5. Re: Mavericks?
    David M Brewer Level 6 Level 6 (9,200 points)

    Russ H wrote:

     

    Anything you can share on how well it runs on 10.9 – compared to earlier OS versions?

     

    Thanks.

     

    Riuss

    It runs just fine... but... I can't can't get the Qmaster panel in the System Prefs to open. Other than that no problems.

     

    (I have Compressor 4 and Motion 5 installed...)

  • 6. Re: Mavericks?
    pacanoe Level 1 Level 1 (0 points)

    thanks for the tip....though Qmaster is somehow essential for speeedy compression...maybe in upcoming updates this might change...anyways, it is not only the Studio apps that matter, also would be great knowing if the plugs, such as Saphyre and the sort, DO work under Mavericks...

     

    cheers

  • 7. Re: Mavericks?
    Matt Gerard Level 2 Level 2 (165 points)

    Qmaster pref pane is 32 bit. If anyone remembers in 10.8, clicking on it would force the system pref app to reopen in 32 bit mode. Same with the old Final Cut server pref pane.

  • 8. Re: Mavericks?
    GNDxero Level 1 Level 1 (10 points)
  • 9. Re: Mavericks?
    jcohoon Level 1 Level 1 (0 points)

    FCP 7 and Compressor (without qmaster) are working fine for me. Haven't tried DVDSP yet. Didn't have to reinstall anything. Haven't done a ton with FCP yet but projects opened and I was able to do some basic editing. Haven't checked any plugins yet. I'll update if I run into any trouble.

  • 10. Re: Mavericks?
    jcohoon Level 1 Level 1 (0 points)

    Today I ran into problems after I ejected the render drive and started FCP. FCP reported not being able to find the drive like normal so I chose 'quit' and plugged the drive back in. At this point FCP crashed on load, citing a thread containing qmaster. I tried reopening a couple times, restarted and did the same to no avail. Compressor failed to load as well. I eventually backed up my Compressor settings folder from ~/Library/Application Support/ and then ran Compressor Repair from Digital Rebellion (http://www.digitalrebellion.com/compressorrepair/) which finally got FCP running again. Hopefully this isn't something I'll have to do regularly.

  • 11. Re: Mavericks?
    dillboy Level 1 Level 1 (0 points)

    Hi all

    I have install fcp on my mbp using ox 10.9 it work fine but it will not update to the lates update of fcp. it just go through the app store finding no updates to fcp. is there any way to update fcp using ox 10.9.

    cheers

  • 12. Re: Mavericks?
    Pretzelcuatl Level 1 Level 1 (0 points)

    You probably need to have the FCP app at the Applications level folder instead of the Final Cut Studio subfolder for Apple to see the app for updating.  For some strange reason.

  • 13. Re: Mavericks?
    Posthumous Level 2 Level 2 (235 points)

    You will no longer have Qmaster functionality with 10.9. So no mutli core compression. Have to get Compressor 4, which integrates Qmaster to allow all cores for compression.

     

    If you are referring to Final Cut Studio's latest update go here:  http://support.apple.com/kb/DL949

  • 14. Re: Mavericks?
    Studio X Level 7 Level 7 (26,940 points)
    You will no longer have Qmaster functionality with 10.9.

     

     

    This is not true. You lose the Qmaster Preference Pane functionality, but Qmaster and Compressor still work just fine.

     

    Also, Compressor Repair by Digital Rebellion still works just fine.

     

    To access the prefs in Compressor 3.5 in 10.9, you use Terminal and the command line. The commands can be found in the Compressor 3 Manual (accessed through the Help menu item in Compressor).

     

    In the manual... Compressor 3 User Manual> Appendix C: Using the Command Line> Using the Command line for distributed processing> Shell Commands for Configuring Service Nodes and Cluster Controllers

     

    Or purchase Compressor 4.

     

    Best,

     

    x

1 2 Previous Next