9 Replies Latest reply: Feb 23, 2014 10:37 AM by Marendins
Merchon Cottrell Level 1 Level 1 (15 points)

I think Apple totaly messed up aperture 3.5 in full screen mode in Maverics. Now my second display is rendered useless. The menu bar will not go away. I use the menu item "Swap Displays" to put the browser on my smaller second display. This menu item now does noting! Why have a menu item if it does nothing. Apple was asleep at the switch. Maverics was supposed to be great for multple displays, not!

  • 1. Re: Aperture 3.5 Full screen
    Thomas Emmerich Level 4 Level 4 (3,485 points)

    Maybe you should try changing the preferences for Spaces.

     

    System Preferences->Mission Control->Displays have separate Spaces

     

    With this enabled (the default), you get a menu on both screens.

  • 2. Re: Aperture 3.5 Full screen
    Clem Level 3 Level 3 (550 points)

    The OS Menu bar on each display is new for Mavericks. If you don't like it to show when you have a secondary display enabled the go to System Prefs/Mission Control and uncheck the "Display have separate Spaces" option. Log out and back in.

  • 3. Re: Aperture 3.5 Full screen
    mikehatfield Level 1 Level 1 (0 points)

    I had this problem too - the solution is detailed by Apple in this support note (the same advice given by Thomas and Clem above): http://support.apple.com/kb/HT5991

     

    I suggest you do as I do and submit a polite feedback request to Apple regarding this problem. If enough people do this they'll hopefully work with the Mavericks team to resolve it. http://www.apple.com/feedback/aperture.html

  • 4. Re: Aperture 3.5 Full screen
    Merchon Cottrell Level 1 Level 1 (15 points)

    Thanks, that does solve the problem. But now, what is the point of Maverics. We need to turn off the new desktop feature of Maverics, which basically reverts to how Mountain Lion functions. I guess thats why Apple gave it away for free, its useless.

  • 5. Re: Aperture 3.5 Full screen
    Merchon Cottrell Level 1 Level 1 (15 points)

    Also, this did not fix the "Swap Displays". It still does nothing, this must be a bug.

  • 6. Re: Aperture 3.5 Full screen
    tmlim Level 1 Level 1 (25 points)

    For some reason, when I go full screen, I can't open the Inspector.  I have to close full screen, open inspector, then go back to full screen!

  • 7. Re: Aperture 3.5 Full screen
    Mulsanne Level 1 Level 1 (0 points)

    I had some similar problems. I like to have a full screen window on my second, larger display and the grid window on my primary display of my MBP. After Mavericks I didn't see anything the secondary and the toolbar for the full screen was at the top of my MBP display. Turns out both windows were stacked on top of each other on the primary.

     

    I fiddled with my display settings and after a while patched the problem by moving the menu bar in the display preferences from my primary display to the secondary. Then I saw the fix detailed above and that worked for my as well.

  • 8. Re: Aperture 3.5 Full screen
    EdwardWinter Level 1 Level 1 (0 points)

    Merchon Cottrell

     

    I've had the same problem.  I tried the solution listed above :

    (System Preferences->Mission Control->Displays have separate Spaces).

     

    But this wasn't a fix to the swap display problem.  I contacted Applecare, and they recreated the same problem, but haven't been able to offer a solution or workaround.  Now my secondary display is useless (which is essential to my photo-editing workflow).

    Have you found a fix?

     

    Typically, I use the main screen to show the single image that I'm working on, and the secondary display for both the inspector HUD and grid view. To achieve this, I use full screen mode + swap displays.

  • 9. Re: Aperture 3.5 Full screen
    Marendins Level 1 Level 1 (0 points)

    I'm also experiencing the same problem. Just like other posters, I also use my main screen to edit a photo and the secondary screen to show the grid and huds.

     

    It's really frustating that the 'swap displays' menu option is doing nothing.