14 Replies Latest reply: Nov 16, 2013 9:29 AM by Type17
dachan2 Level 1 (15 points)

After upgrade to 10.9 and Aperture to 3.5 I can't export photos anymore from Aperture nor iPhoto.


I repaired the database in the three possible ways without success.


I would appreciate if someone could tell me what else I can do.



MacBook Pro, OS X Mavericks (10.9), 8GB RAM - 2.4GHz Intel Core i7
  • Clem Level 3 (670 points)

    Do you have permission to write to your export destination? Tried a different destiantion? Repaired disk permissions? Have you tried creating a new test account and doing the export from there?

  • dachan2 Level 1 (15 points)

    I can't even choose a destination because the window to make it does not appear. I've repaired disk permissions with no results.


    I have tried with the Guess Account and its work.


    I don't know what else to do :-(

  • Frank Caggiano Level 7 (25,722 points)

    What happens when you try to export?


    If the export window does not appear try deleting Aperture's Preference file to see if that makes a difference.


    See Aperture 3: Troubleshooting Basics or directions on how to do that.


    Post back if you still have problems.

  • Clem Level 3 (670 points)

    If you open the Console application in the Utilities folder, and then try to bring up the Export window in Aperture, do you see any messages posted to the main Console window? Repost them here if you do.


    Besides clean prefs as Frank suggests I might try reinstalling a clean version of the app. Sounds like the problem lies on the app/OS/prefs side, not your library itself...

  • dachan2 Level 1 (15 points)

    The console sends this message when trying to export in Aperture or, as you can see on other line, clicking on a button in the System Preferences.


    25-10-13 13:49:40,110 System Preferences[808]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32



    25-10-13 13:51:56,284 Aperture[828]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32




    I think this is related to the interface. Also in Pixelmator I have a window open and I can't close it.

    A few years ago I changed a Safari preference with a preference pane called Secrets and I think this in some way spoiled the interface. Now with Mavericks various applications do not work well.

    With a new user all goes well, so I'm moving to another new user. My God!. It's like if you move to another house.

  • léonie Level 10 (90,876 points)

    With a new user all goes well, so I'm moving to another new user. My God!. It's like if you move to another house.

    If it works in another user account, you might consider to move out all preference files from the Preferences folder in your user library, also to uninstall the custom preferences panes you installed for your current account, the start up items, - effectively clean out your user library of all suspicious items and try to keep unsuspicious things like your mailboxes. This will make the account like a new account, but preserve your user identity and ownership settings. Moving to a new account makes things more difficult, because you no longer will be the owner of the files in your home folder.

  • Frank Caggiano Level 7 (25,722 points)

    It is to bad you did not spend a bit more time on getting this fixed. Moving to a new user account can cause problems down the road. Hopefully you'll avoid them.


    Those messages in the console most likely have nothing to do with this probelm. Likewise for  Pixelmator.


    When you created the new user id you try the old user's library or did you try a new library?



  • dachan2 Level 1 (15 points)

    I spent all day Sunday trying to fix my previous user account. I tried 3 times 3 with Migration Assistant from a CCC backup and a copy of Time Machine. They were all the folders and files, but for some reason the user was not created. Now with the new user I have Aperture, which is the most important thing to me in the same condition as always with the same projects, presets and all other things. I didn't delete the old user and I use both until I have everything right in the new.


    Frank, I think the console messages certainly have to do with the problem. Two more examples:

    This is when I want to close the window from Pixelmator:

    28-10-13 14:32:34,686 Pixelmator[6716]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32


    Of course the window don't close.


    This is when I try to choose another Library in iMovie:

    28-10-13 14:35:31,320 iMovie[6747]: -[NSRemoteView viewDidMoveToWindow] caught non-fatal NSInternalInconsistencyException 'unable to convert NSNamedColorSpace System controlColor to RGB del dispositivo colorspace

    -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32' with backtrace (.


    Of course I can't choose anything.


    Anyway, now I can use Aperture again which is what matters to me. Then I will change gradually from the old to the new user.


    Thank you all for your interest.



  • Frank Caggiano Level 7 (25,722 points)

    Frank, I think the console messages certainly have to do with the problem. Two more examples:

    I meant nothing to do with your Aperture problem, what is happening with Pixelmator is another issue.


    Given that you are having troubles with 3 different (as far as we know) applications you might what to take a step back and try to figure out if there is a relationship here or if you are just unlucky.


    I upgraded to 10.9 and have not experienced any troubles along the lines of what you are seeing. You might what to do a re-install or at least go over you upgrade procedures and see if there is something amiss.



    spent all day Sunday trying to fix my previous user account. I tried 3 times 3 with Migration Assistant from a CCC backup and a copy of Time Machine. They were all the folders and files, but for some reason the user was not created

    This really indicates some underlying problem. The problems with Aperture are likely to come back in the new user account if the underlying issues aren't  resolved.


    good luck



  • Simon_MBP Level 1 (0 points)

    I have the same issue.  Aperture 3.5 - just upgraded to Mavericks.  Export working fine until yesterday - now I can't get the dialogue box to appear - selecting export has no effect at all.


    Console shows:


    29/10/2013 00:40:47.292 Aperture[383]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32


    followed by

    29/10/2013 00:40:47.296 Aperture[383]: -[NSRemoteView viewDidMoveToWindow] caught non-fatal NSInternalInconsistencyException 'unable to convert NSNamedColorSpace System controlColor to Device RGB colorspace' with backtrace (

        0   CoreFoundation                      0x00007fff8a71041c __exceptionPreprocess + 172

        1   libobjc.A.dylib                     0x00007fff8a27de75 objc_exception_throw + 43

        2   CoreFoundation                      0x00007fff8a7101f8 +[NSException raise:format:arguments:] + 104

        3   Foundation                          0x00007fff87146c61 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 189

        4   ViewBridge                          0x00007fff9397a65c -[NSSecureColor initWithColor:] + 724

        5   ViewBridge                          0x00007fff9397a36f +[NSSecureColor secureColorWithColor:] + 48

        6   ViewBridge                          0x00007fff9399dcfb -[NSRemoteView sendFontSmoothingBackgroundColorToService:] + 40

        7   ViewBridge                          0x00007fff9399ebf5 -[NSRemoteView viewDidMoveToWindow] + 197

        8   AppKit                              0x00007fff910f71d0 -[NSView _setWindow:] + 2899

        9   AppKit                              0x00007fff910f4804 -[NSView addSubview:] + 364

        10  AppKit                              0x00007fff91108953 -[NSFrameView addSubview:] + 45

        11  AppKit                              0x00007fff91116cb5 -[NSWindow setContentView:] + 511

        12  AppKit                              0x00007fff9197c233 -[NSVBSavePanel init] + 287

        13  AppKit                              0x00007fff916fe5b9 +[NSSavePanel newRemotePanel] + 309

        14  AppKit                              0x00007fff916fe675 +[NSSavePanel _crunchyRawUnbonedPanel] + 120

        15  Aperture                            0x0000000109c119fc Aperture + 666108

        16  Aperture                            0x0000000109bb63ef Aperture + 291823

        17  AppKit                              0x00007fff912fe3d0 -[NSApplication sendAction:to:from:] + 327

        18  ProKit                              0x000000010b3d1626 -[NSProApplication sendAction:to:from:] + 101

        19  Aperture                            0x0000000109fdbe86 Aperture + 4640390

        20  AppKit                              0x00007fff91319348 -[NSMenuItem _corePerformAction] + 394

        21  AppKit                              0x00007fff91319084 -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 117

        22  AppKit                              0x00007fff913684dd -[NSMenu _internalPerformActionForItemAtIndex:] + 35

        23  AppKit                              0x00007fff91368359 -[NSCarbonMenuImpl _carbonCommandProcessEvent:handlerCallRef:] + 104

        24  AppKit                              0x00007fff9130f176 NSSLMMenuEventHandler + 716

        25  HIToolbox                           0x00007fff8c47b6d4 _ZL23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 892

        26  HIToolbox                           0x00007fff8c47ac87 _ZL30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14H andlerCallRec + 385

        27  HIToolbox                           0x00007fff8c48ed90 SendEventToEventTarget + 40

        28  HIToolbox                           0x00007fff8c4c4a30 _ZL18SendHICommandEventjPK9HICommandjjhPKvP20OpaqueEventTargetRefS5_PP14OpaqueE ventRef + 420

        29  HIToolbox                           0x00007fff8c4f7618 SendMenuCommandWithContextAndModifiers + 59

        30  HIToolbox                           0x00007fff8c4f75c4 SendMenuItemSelectedEvent + 178

        31  HIToolbox                           0x00007fff8c4f74a5 _ZL19FinishMenuSelectionP13SelectionDataP10MenuResultS2_ + 94

        32  HIToolbox                           0x00007fff8c4d556e _ZL19PopUpMenuSelectCoreP8MenuData5PointdS1_tjPK4RecttjS4_S4_PK10__CFStringPP13 OpaqueMenuRefPt + 1726

        33  HIToolbox                           0x00007fff8c4d46c6 _HandlePopUpMenuSelection7 + 596

        34  AppKit                              0x00007fff91367221 _NSSLMPopUpCarbonMenu3 + 4153

        35  AppKit                              0x00007fff914d1a95 -[NSCarbonMenuImpl _popUpContextMenu:withEvent:forView:withFont:] + 192

        36  ProKit                              0x000000010b461fc2 -[NSProCarbonMenuImpl _popUpContextMenu:withEvent:forView:withFont:] + 375

        37  ProKit                              0x000000010b3c3ccc -[NSMenu(ProAdditions) _popUpContextMenu:withEvent:forView:withFont:] + 741

        38  AppKit                              0x00007fff9184506f -[NSView rightMouseDown:] + 127

        39  AppKit                              0x00007fff912e2f71 -[NSWindow sendEvent:] + 3721

        40  ProKit                              0x000000010b3f3e50 -[NSProWindow sendEvent:] + 236

        41  AppKit                              0x00007fff91283744 -[NSApplication sendEvent:] + 2021

        42  ProKit                              0x000000010b3d251e -[NSProApplication sendEvent:] + 129

        43  Aperture                            0x0000000109fdbb35 Aperture + 4639541

        44  AppKit                              0x00007fff910d3a29 -[NSApplication run] + 646

        45  ProKit                              0x000000010b3d2dca NSProApplicationMain + 333

        46  Aperture                            0x0000000109b7ef50 Aperture + 65360

        47  Aperture                            0x0000000109b7e8f4 Aperture + 63732


    timestamp: 00:40:47.296 Tuesday 29 October 2013

    process/thread/queue: Aperture (383) / 0x7fff77698310 / com.apple.main-thread

    code: line 607 of /SourceCache/ViewBridge/ViewBridge-46/ViewBridgeUtilities.m in logCaughtException

    domain: exceptions

  • dachan2 Level 1 (15 points)

    This is exactly what happened to me, at least these first lines as you can see below.

    25-10-13 13:51:56,284 Aperture[828]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32


    29/10/2013 00:40:47.292 Aperture[383]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32






    I had to migrate to a new user, now everything works fine.




  • luke_aus Level 1 (10 points)

    I think there is a larger issue going on here that is affecting secondary issues in System Preferences and "Save As" dialogues in multiple programs.


    The issues seem to be secondary preference windows

    System Prefs> Security & Privacy> Advanced button not responding in any of the frames ( lock is unlocked / I'm administrator)


    System Prefs> Security & Privacy> general allow apps downloaded from: wont let me choose Anywhere


    System Prefs> Time machine> options button not responding


    System Prefs> Network > Advanced button not responding


    Text edit won't let you save or save as from the menu or with key combo shortcut

    And "Save As" dialogues from Pixelmator, Apperture and iPhoto



    The errors are:


    7/11/2013 8:12:13.583 am System Preferences[390]: *** Assertion failure in -[NSSecureColor initWithColor:], /SourceCache/ViewBridge/ViewBridge-46/NSSecureColor.m:32


    and 2.

    7/11/2013 8:12:13.584 am System Preferences[390]: -[NSRemoteView viewDidMoveToWindow] caught non-fatal NSInternalInconsistencyException 'unable to convert NSNamedColorSpace System controlColor to Device RGB colorspace' with backtrace (

              0   CoreFoundation                      0x00007fff86a2d41c __exceptionPreprocess + 172

              1   libobjc.A.dylib                     0x00007fff9300ce75 objc_exception_throw + 43

              2   CoreFoundation                      0x00007fff86a2d1f8 +[NSException raise:format:arguments:] + 104

              3   Foundation                          0x00007fff935b2c61 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 189

              4   ViewBridge                          0x00007fff86be965c -[NSSecureColor initWithColor:] + 724

              5   ViewBridge                          0x00007fff86be936f +[NSSecureColor secureColorWithColor:] + 48

              6   ViewBridge                          0x00007fff86c0ccfb -[NSRemoteView sendFontSmoothingBackgroundColorToService:] + 40

              7   ViewBridge                          0x00007fff86c0dbf5 -[NSRemoteView viewDidMoveToWindow] + 197

              8   AppKit                              0x00007fff8e5601d0 -[NSView _setWindow:] + 2899

              9   AppKit                              0x00007fff8e55d804 -[NSView addSubview:] + 364

              10  AppKit                              0x00007fff8e571953 -[NSFrameView addSubview:] + 45

              11  AppKit                              0x00007fff8e57fcb5 -[NSWindow setContentView:] + 511

              12  ViewBridge                          0x00007fff86c13868 rendezvousPanel + 895

              13  ViewBridge                          0x00007fff86c12f3f -[NSRemoteView beginSheet:modalForWindow:size:isCritical:styleMask:] + 420

              14  ViewBridge                          0x00007fff86c13eea -[NSRemoteView beginDeferredSheet:] + 209

              15  ViewBridge                          0x00007fff86c14098 -[NSRemoteView beginDeferredSheets] + 283

              16  ViewBridge                          0x00007fff86c18ca2 __85-[NSRemoteViewMarshal beginSheet:modalForWindow:size:isCritical:styleMask:withReply:]_block_invoke + 83

              17  ViewBridge                          0x00007fff86c1c892 __deferBlockOntoMainThread_block_invoke_3 + 441

              18  CoreFoundation                      0x00007fff8695e7cc __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12

              19  CoreFoundation                      0x00007fff8694fee5 __CFRunLoopDoBlocks + 341

              20  CoreFoundation                      0x00007fff8694fc6e __CFRunLoopRun + 1982

              21  CoreFoundation                      0x00007fff8694f275 CFRunLoopRunSpecific + 309

              22  HIToolbox                           0x00007fff93221f0d RunCurrentEventLoopInMode + 226

              23  HIToolbox                           0x00007fff93221cb7 ReceiveNextEventCommon + 479

              24  HIToolbox                           0x00007fff93221abc _BlockUntilNextEventMatchingListInModeWithFilter + 65

              25  AppKit                              0x00007fff8e54928e _DPSNextEvent + 1434

              26  AppKit                              0x00007fff8e5488db -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 122

              27  AppKit                              0x00007fff8e53c9cc -[NSApplication run] + 553

              28  AppKit                              0x00007fff8e527803 NSApplicationMain + 940

              29  libdyld.dylib                       0x00007fff8e5245fd start + 1

              30  ???                                 0x0000000000000001 0x0 + 1


    timestamp: 08:12:13.584 Thursday 07 November 2013

    process/thread/queue: System Preferences (390) / 0x7fff776b3310 / com.apple.main-thread

    code: line 607 of /SourceCache/ViewBridge/ViewBridge-46/ViewBridgeUtilities.m in logCaughtException

    domain: exceptions



    I think we need to merge this discussion over to



  • luke_aus Level 1 (10 points)

    I believe I have found the issue and the solution:


  • Type17 Level 1 (20 points)

    You have indeed - my Aperture exports are now working again, as well as the System Prefs issue in the other thread, Thanks again!